Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: TC2, System Manager, Variablen-Zuordnung scheint nicht zu passen

  1. #11
    cpalm is offline Neuer Benutzer
    Themenstarter
    Join Date
    03.02.2009
    Posts
    17
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    @oliver.tonn: Ist mir klar und ist auch nicht so... Bin ja kein NOOB und habe seit 2006 da schon sehr viele Variablen und Klemmen angesteuert trotzdem danke.

    Globale Variablen mit der im letzten Beitrag angegebenen Deklaration sind hier:
    08-04-_2021_14-07-46.png

    Die dazu generierte Config (eine Zeile tiefer) ist natürlich Read Only. Im Falle von TwinCAT darf man da nicht nur nicht rumeditieren, sondern man kann auch gar nicht.
    08-04-_2021_14-09-48.png

  2. #12
    Join Date
    26.01.2013
    Location
    Hannover
    Posts
    127
    Danke
    4
    Erhielt 16 Danke für 11 Beiträge

    Default

    Hast du die Klemme im System Manager von Hand eingefügt oder im Config Mode durch scannen?
    In der PLC mal Projekt bereinigt und komplett neu übersetzt, dann im System Manager neu einlesen...
    Was ist, wenn du eine Testvariable vom Typ UINT oder WORD anlegst und verknüpfst?
    Sonst fällt mir nicht mehr viel ein.

  3. Folgender Benutzer sagt Danke zu NieZuSpaet für den nützlichen Beitrag:

    cpalm (11.04.2021)

  4. #13
    cpalm is offline Neuer Benutzer
    Themenstarter
    Join Date
    03.02.2009
    Posts
    17
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich wollte mich einmal bei allen Autoren für die Antworten bedanken. Ich habe den Bug mittlerweile gefunden und poste einmal am Ende, was es war.

    @NieZuSpaet: Ja, ich füge alle Klemmen per Hand ein. Durch ein Durchscannen verliere ich individuelle Benennungen und Klemmen, die dadurch nicht gefunden werden können, die mir aber Numerierung und Übersicht erleichtern und manche Klemmen musste man in einen Subtyp wandeln (der technisch gleich aussieht). Falls jemand anders dazu eine Best-Practice hat, lerne ich die aber gerne.

    Das Anlegen einer alternativen Struktur mit USINT bzw. UINT's brachte mich auf die richtige Fährte. Die neue Struktur wurde vom Programm nämlich noch nicht beschrieben und verknüpft. Dadurch verhielten sich die Werte exakt wie erwartet und es funktionierte. Überall stand der richtig Wert der Klemme: physisch und im Programm.

    Mein Fehler war, im initialisierenden DALI Baustein die DataTerminal und Data Klemmen zu vertauschen (rot bzw. gelb):
    11-04-_2021_17-54-07.png

    Hierdurch gab es scheinbar dauernd Schreibimpulse, die zu einem Mix (bitwise OR) des gesetzten Status Bit's 1 im Hardware-Register und Bit 7 des SPS-Programms führten. Macht dann zusammen Hex 82.

  5. Folgender Benutzer sagt Danke zu cpalm für den nützlichen Beitrag:

    NieZuSpaet (Yesterday)

Similar Threads

  1. Replies: 3
    Last Post: 06.08.2020, 17:26
  2. TC2, System Manager, Fehler beim Wählen des Zielsystems
    By Paddi299 in forum CODESYS und IEC61131
    Replies: 2
    Last Post: 28.05.2020, 17:15
  3. Replies: 2
    Last Post: 22.04.2016, 07:03
  4. System Manager öffnet nicht?
    By lifenec in forum CODESYS und IEC61131
    Replies: 4
    Last Post: 07.06.2011, 08:21
  5. System Manager öffnet nicht
    By timod79 in forum CODESYS und IEC61131
    Replies: 2
    Last Post: 05.04.2009, 17:36

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •