Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: S7-300 und BK3150 mit KL4408 Analogausgabe

  1. #1
    Registriert seit
    04.07.2005
    Ort
    Bautzen
    Beiträge
    67
    Danke
    3
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute!

    Ich hab zur Zeit ein kleines Problem mit einer Analogausgabeklemme von Beckhoff.

    Die DP-Masteranschaltung ist eine S7 313C - 2DP und als Slave hab ich den BK3150 mit einigen KL1408, KL2408ern und einer KL4408. In der Hardwarekonfig sind Koppler und Klemmen laut Beschreibung und Beckhoff Support korrekt eingepflegt. Alle digitalen Ein- und Ausgänge sind erreichbar es gibt keine Busfehler etc. nur irgendwie kommt aus den analogen Ausgängen keine Spannung raus...

    Ich habe im im Anwenderprogramm folgende Zeilen probiert:

    L 2000
    T PAW776

    Eigentlich war ich der Meinung dann irgendeine Regung zwischen -10V und +10V zu erreichen.

    Beckhoff Information System hat mir verraten, dass 12 Bit Prozessdaten + 1 Bit Vorzeichen + 3 Bit Beckhoff Interna im Wort übertragen werden. Jetzt vermute ich, dass ich durch das einfache draufschreiben die Statusbits zu Null schreibe und deshalb nichts rauskommt.

    Hat jemand schonmal eine solche Konfiguration am Laufen gehabt? Wo liegt mein Fehler?

    Beckhoff meinte noch ich könne die Klemmen auch als Komplexe Klemmen in der Hardwarekonfig projektieren und so ein PEW mit Statusinformationen der Klemme auslesen, aber leider klappte as auch nicht so richtig PEW-Inhalt = 0

    Gruß mclear
    Zitieren Zitieren S7-300 und BK3150 mit KL4408 Analogausgabe  

  2. #2
    mclear ist offline Benutzer
    Themenstarter
    Registriert seit
    04.07.2005
    Ort
    Bautzen
    Beiträge
    67
    Danke
    3
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Also ich kann die Antwort auf die Frage nun selber geben. Für alle die eventuell auch mal vor so einem Problem stehen.

    Die Klemmen werden als komplexe Klemmen in in der Step 7 Hardwarekonfiguration projektiert. Das erste Byte der Ausgänge ist das Controlbyte. Mit diesem kann die Klemme mittels Registerzugriff ( 0x88 ) zu einer Antwort bzw. Rückmeldung im Sinne von "Ich bin hier, in Ordnung und warte auf eine Eingabe" gebracht werden. Die Antwort für die KL4408 lautet 0x1138 in den folgenden beiden Bytes.
    Diese beiden Bytes nach dem Controlbyte sind gleichzeitig auch die Peripheriebytes für das zu beschreibende PAW in Step7.

    Im Klartext:

    L 2000
    T PAW777

    Sieht ungewöhlich aus, ist aber so und funtioniert prima.

    Gruß mclear
    Geändert von mclear (23.07.2007 um 21:50 Uhr) Grund: (0x8Smilie ist ungleich hex achtundachtzig

  3. #3
    Registriert seit
    16.06.2003
    Ort
    88356 Ostrach
    Beiträge
    4.811
    Danke
    1.231
    Erhielt 1.101 Danke für 527 Beiträge

    Standard

    hat das ding power?

    was für eine klemme befindet sich links daneben?
    "Es ist weit besser, große Dinge zu wagen, ruhmreiche Triumphe zu erringen, auch wenn es manchmal bedeutet, Niederlagen einzustecken, als sich zu den Krämerseelen zu gesellen, die weder große Freude noch großen Schmerz empfinden, weil sie im grauen Zwielicht leben, das weder Sieg noch Niederlage kennt." Theodore Roosevelt - President of the United States (1901-1909)

  4. #4
    mclear ist offline Benutzer
    Themenstarter
    Registriert seit
    04.07.2005
    Ort
    Bautzen
    Beiträge
    67
    Danke
    3
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    links daneben befindet sich eine 8er Analogeingabe 3xx8...

    Power hat sie, wie gesagt war eindeutig ein Adressierfehler.

    Hab sowas noch nicht gesehen, zumal Step7 oder auch TwinCAT gerne mal bei ungeraden Wortangaben anfagen zu meckern --> Übersetzen oder Übertragen ist dann unmöglich.

    In diesem Fall gehts aber nur so.

    Gruß mclear

Ähnliche Themen

  1. S7-bk3150- kl5101
    Von SEAL im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 15.08.2011, 07:17
  2. Probleme mit BK3150 K-BUS LED blinkt
    Von Krumnix im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 25.03.2011, 13:16
  3. BK3150 Konfigurationsproblem
    Von Onkel Dagobert im Forum Feldbusse
    Antworten: 6
    Letzter Beitrag: 30.07.2007, 17:22
  4. S5-135U Analogausgabe
    Von Kleissler im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 24.01.2006, 17:50
  5. Problem mit Analogausgabe
    Von arsirc im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 11.02.2005, 06:43

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •