Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 20

Thema: Twido via no-ip.com

  1. #1
    Registriert seit
    20.03.2007
    Beiträge
    47
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo ,

    nu bin ich mit meinen Latein am Ende.

    Folgende Situation:

    Hardware:
    Twido mit TCP/IP Karte (IP:192.168.178.100)
    Fritzbox 7150
    httx://name.no-ip.biz (IP:80.139.xx.xxx)

    Ich würde gerne die SPS die via LAN mit meiner FritzBox verbunden ist,
    eben über ein no-ip account erreichen. Den Port in der Fritzbox hab ich geroutet. z.b.

    Port (80)
    an
    192.168.178.100
    an
    Port (80),

    um von mir aus an meinem Teich die Pumpe aus einem Hotel ein/auszuschalten.

    Im internen Netzwerk funktioniert der Zugriff (ist Klar )
    Uupps, Telefon......
    Schreibe später mehr.....

    Danke
    Zitieren Zitieren Twido via no-ip.com  

  2. #2
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    220
    Erhielt 233 Danke für 204 Beiträge

    Standard

    Hi

    httx://name.no-ip.biz (IP:80.139.xx.xxx)
    httx: ?



    Was macht ein Ping http://name.no-ip.biz Ansprechbar ?



    Mit Browser http://name.no-ip.biz von deinem Hotel hast du die Fritzbox dran ?

    Normalerweise Antwortet die Fritzbox auf dem Port 80


    Verwende doch mal einen "anderen" Port !
    Karl

  3. #3
    Registriert seit
    20.03.2007
    Beiträge
    47
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Httx... damit hier kein link angezeigt wird

    Im LAN zu Hause kann ich die Twido anpingen und natürlich meine no-ip adresse aufrufen.
    Jedoch wenn ich versuche die Twido von extern anzusprechen wie zum beispiel name.no-ip.biz/192.168.178.100 funktioniert nicht.

    Hier sind mal meine IP's

    NO-IP 80.138.56.118 (gestern)

    Notebook 192.168.178.29
    Twido 192.168.178.100
    Subnet 255.255.255.0

    Ich befürchte, das die Fritzbox da irgendwas blockt!?
    Zitieren Zitieren Twido  

  4. #4
    Registriert seit
    14.08.2004
    Beiträge
    824
    Danke
    45
    Erhielt 73 Danke für 66 Beiträge

    Standard

    Dein Problem ist, dass du die lokale LAN-Adresse und den Port auf deine global sichtbare IP im Router mappen must.

  5. #5
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    220
    Erhielt 233 Danke für 204 Beiträge

    Standard

    Hi

    Jedoch wenn ich versuche die Twido von extern anzusprechen wie zum beispiel name.no-ip.biz/192.168.178.100 funktioniert nicht.
    name.no-ip.biz/192.168.178.100 --> name.no-ip.biz


    Du darfst NUR "name.no-ip.biz" angeben.
    Dein Router nimmt den "Anruf" entgegen.


    und ein Port-Forward von Port 81 auf Adresse 192.168.178.100



    Also in deine Fritzbox --> Portfreigabe

    Liste der Portfreigaben
    AktivBezeichnungProtokollPortan IP-Adressean Port
    V SPS TCP 81 192.168.178.100 80
    V SPS UDP 81 192.168.178.100 80


    Damit kommst du an den Webserver deiner SPS (Soweit verfügbar)



    Aufruf vom Hotelzimmer

    http://name.no-ip.biz:81



    So sollte es gehen
    Karl

  6. #6
    Registriert seit
    20.03.2007
    Beiträge
    47
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ersteinmal Danke für eure Tipps!

    Die Twido hat keinen Webserver!!!

    Leider funktioniert es nur im internen Netzwerk.

    Ich hab mich jetzt mal im internen Netzwerk mit dem Notebook an die Fritzbox , an welcher auch die Twido hängt, eingesteckt.

    Vorweg, meine IP no-ip.biz und die Twido kann ich anpingen.
    Zum Test hatte ich auch schon den Miniwebserver installiert, und konnte
    über das Internet meine name.no-ip ebenfalls erreichen.

    Einstellungen in der Fritzbox
    AktivBezeichnungProtokollPortan IP-Adressean Port
    V Web TCP 80 192.168.178.28 80 Webserver (Miniwebserver)
    V SPS TCP 81 192.168.178.100 502 Twido (502 wegen Modbus)
    V SPS UDP 81 192.168.178.100 502 Twido

    So, nun möchte ich mit einem Modbus/TCPIP Treiber den ich mir VB geschrieben habe, Daten aus der Twido holen und schicken.

    Wenn ich über das interne Netz mit
    Winsock1.Connect "192.168.178.100", 502
    in VB auf die Twido zugreife , erhalte ich sofort ein "Connect" und kann
    auch Daten holen und schicken. Kommt auch auf der Twido richtig an und wird auch von ihr geschluckt.

    Wenn ich jedoch über das Internet mit
    Winsock1.Connect "name.no-ip.biz", 81 (port 81 siehe Fritzboxeinst.)
    oder auch mit der ip direkt z.b.
    Winsock1.Connect "80.138.49.27", 81 (port 81 siehe Fritzboxeinst.)
    versuche mich mit der Twido zuconnecten, sehe ich auf den Statusled
    der TCPIP-Karte der Twido, das diese angepingt wird, jedoch nicht
    connectet, was mir mein VB-Prog auch meldet.

    Testhalber habe ich dann mal
    Winsock1.Connect "80.138.49.27", 82 (port 82 nicht eingestellt in der Fritzbox)
    ausgeführt und siehe da die Statusled an der Twido bleiben dunkel.
    Also kann ich doch davon ausgehen, das die physikalische Verbindung über das
    Internet mit dem vorherigen Connect ok sein dürfte.

    Hab jetzt schon Google gequällt, jedoch nicht annäherndes gefunden.

    Ich hoffe es ist ausreichend dargestellt, und wäre für eine Hilfe echt dankbar.
    Geändert von skyracer (06.09.2007 um 12:19 Uhr)
    Zitieren Zitieren und weiter geht's!  

  7. #7
    Registriert seit
    28.10.2005
    Ort
    Ottweiler, Saar
    Beiträge
    940
    Danke
    259
    Erhielt 124 Danke für 109 Beiträge

    Standard

    Was spricht dagegen, auch bei der Fritzbox den
    Port 502 zu nehmen ?

  8. #8
    Registriert seit
    20.03.2007
    Beiträge
    47
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Hallo,
    den Port 502 hab ich auch schon mal getestet. Leider ohne Erfolg!

    Sollte eigentlich egal sein, den wenn ich mehrere Twido dran hänge muss ich
    sowieso mit den Port's rangieren.

    1.Twido z.b. Port 4000
    2.Twido z.b. Port 4002 u.s.w......
    Geändert von skyracer (06.09.2007 um 13:13 Uhr)
    Zitieren Zitieren Port 502  

  9. #9
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    220
    Erhielt 233 Danke für 204 Beiträge

    Standard

    Hi

    Hast du mal ein Port-Forward der Fritzbox von Port 502 an deinen Twido versucht ?
    Karl

  10. #10
    Registriert seit
    20.03.2007
    Beiträge
    47
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn Du 502 an 192.168.178.100 zu 502 meinst , ja das hat auch nichts gebracht.Irgendwo auf dem weg von mir über das Internet geht anscheinend etwas "verloren". Wenn irgendetwas nicht stimmen würde, könnte es ja intern auch nicht funktionieren.

Ähnliche Themen

  1. Betriebsstundenzähler in ner Twido?
    Von Sascha im Forum Programmierstrategien
    Antworten: 2
    Letzter Beitrag: 30.06.2005, 20:19

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •