Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Problem mit LOGO!

  1. #1
    Registriert seit
    31.03.2008
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Erstmal n Hallo an alle die sich entschlossen haben mal schnell in das Posting zu schauen!

    Hab n relativ großes Problem mit dem dummen LOGO! Comfort, kann mit dem Programm einfach keinen wirklichen Ablauf erstellen...
    Deshalb jetzt meine frage, gibt es denn irgend eine Möglichkeit, das Modul mit irgend einem anderen Programm zu beschreiben, etwas wo ich meine bisherigen Programmiererfahrung einbringen kann (Java, PHP, HTML, JS, AS...)?

    Für eine schnelle Hilfe wäre ich echt dankbar!

    Grüße, Psyco.
    Zitieren Zitieren Problem mit LOGO!  

  2. #2
    Registriert seit
    14.01.2004
    Ort
    Hattorf
    Beiträge
    3.201
    Danke
    297
    Erhielt 311 Danke für 266 Beiträge

    Standard

    hallo,
    das tut mir leid, ein schwein kann nicht fliegen
    mfg

    dietmar

    Nichts ist so beständig wie ein Provisorium.

  3. Folgende 2 Benutzer sagen Danke zu lorenz2512 für den nützlichen Beitrag:

    edison (01.04.2008),vierlagig (01.04.2008)

  4. #3
    Registriert seit
    07.03.2007
    Ort
    am Kyffhäuser
    Beiträge
    400
    Danke
    120
    Erhielt 70 Danke für 55 Beiträge

    Standard

    Hallo,

    das geht nur mit Logo!Soft. Wo ist da das Problem? Ist doch alles Logo! logisch aufgebaut. Beschreibe mal Dein Vorhaben.

    Frank

  5. #4
    Psyco ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    31.03.2008
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Schonmal Danke für die antworten,
    poste mal ne kurze Projektbeschreibung:

    Geht um ne hydraulische presse, drei doppelt wirkende Zylinder ( somit sechs Ventile, stomlos offen), sechs endtaster (zwei pro Zylinder), desweiteren gibts noch ne kleine Tastenleiste mit nem Start, Stopp und Nullstellungstaster.

    Funktionsübersicht:

    Als erstes schliest Zylinder eins, dann Zylinder zwei und dann Zylinder drei.
    Sobald Zylinder drei vollständig geschlossen wurde, öffnet er wieder als erstes, dann der zweite und zuletzt der erste, das is schon alles...
    Gibt da noch zwei verschiedene Hydraulikaggregate, aber das is alles kein Problem...

    jetzt zum Hauptfakt...:

    alles läuft wunderbar, erst schliest eins, dann zwei, dann drei, alles läuft prima, bis Zylinder drei wieder öffnet...
    Denn sobald Zylinder drei wieder vollständig geöffnet ist, ist der gleiche Eingangszustand wieder hergestellt wie als ob er noch nicht geschlossen wurde...
    [ ES_Zyl_1_zu=1 ; ES_Zyl_2_zu=1 ; ES_Zyl_3_auf=1 ]
    (endschalter=ES)

    wenn ich da nur irgend nen ablauf reinbringen könnte...

    ...hoff ich konnte mich wenigstens ein bissl verständlich ausdrücken,
    is meine erste SPS, bin also auf dem Gebiet n fast totaler Noob...


    Gruß, Psyco

  6. #5
    Registriert seit
    20.10.2007
    Ort
    Krauchthal
    Beiträge
    48
    Danke
    4
    Erhielt 6 Danke für 6 Beiträge

    Standard

    du kannst zum beispiel am ende, also wenn alle zylinder geschlossen sind ein RS (Selbsthaltung) setzen, dann weisst du dass jetzt die zylinder wieder hoch müssen. wenn der letzte zylinder oben ist, setzt du das RS zurück und der ablauf beginnt von vorne.

  7. #6
    Registriert seit
    07.03.2007
    Ort
    am Kyffhäuser
    Beiträge
    400
    Danke
    120
    Erhielt 70 Danke für 55 Beiträge

    Standard

    Hallo,

    ..klingt doch soweit schon gut. Stelle doch mal Dein Programm hier als Anhang rein, dann ist der Rest ein Kinderspiel.

    Frank

  8. #7
    Registriert seit
    09.01.2008
    Ort
    Wernigerode
    Beiträge
    26
    Danke
    32
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo,

    musst das mit einer Schrittkette lösen. Wie im Anhang, aber noch ohne das Ansteuern der Ventile. Dazu musst Du noch festlegen welcher Art sind Deine Arbeitsventile ? Speicherventile 4/2 WV nehme ich an ?? oder einzelne 3/ 2 WV ??
    Wenn das klar ist kann der Plan vervollständigt werden. In Logo kannst Du dann selber umsetzen.

    Achim

    In der Zeichnung links, Einschaltbedingung für Schritt 1, nicht ES_Zyl.3_ sondern ES_Zyl.1_
    Angehängte Dateien Angehängte Dateien
    Geändert von achim532000 (04.04.2008 um 09:31 Uhr) Grund: Zeichnungsbeschriftung
    Zitieren Zitieren LOGO! Probleme  

  9. #8
    Registriert seit
    09.01.2008
    Ort
    Wernigerode
    Beiträge
    26
    Danke
    32
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    noch einige Fragen.
    Was meinst Du mit Zylinder schließt? (nicht als Belehrung auffassen)
    Ein Zylinder fährt "aus" oder "ein",
    "hintere Endstellung", "vordere Endstellung", "vor" oder "zurück".

    Anbei Zeichnung mit Zylinderansteuerungen. Welche trifft zu? Danach kann die Ventilansteuerung ausgewählt werden.

    Achim
    Angehängte Dateien Angehängte Dateien
    Zitieren Zitieren Logo!  

Ähnliche Themen

  1. Siemans Logo Problem
    Von Marcus4281 im Forum Sonstige Steuerungen
    Antworten: 14
    Letzter Beitrag: 19.10.2011, 19:40
  2. Logo!Soft Problem
    Von Saltguy im Forum Programmierstrategien
    Antworten: 2
    Letzter Beitrag: 29.09.2011, 15:29
  3. Problem mit LOGO
    Von mapavo im Forum Sonstige Steuerungen
    Antworten: 14
    Letzter Beitrag: 26.06.2011, 21:32
  4. Problem mit Logo
    Von chrisl im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 15.09.2009, 23:08
  5. Problem mit Logo!
    Von Error404 im Forum Sonstige Steuerungen
    Antworten: 12
    Letzter Beitrag: 12.03.2008, 20:46

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •