Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 14 von 14

Thema: Seltsames Phänomen mit VIPA 315/SN und MP277

  1. #11
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.227
    Danke
    534
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ok, in diesem Zusammenhang bekam ich gestern eine Mail:

    ...

    wir hatten im Dezember 2007 mal das Thema, dass die VIPA 315SB CPU einen Dauerprozessalarm auslöst.

    Nun kann ich Ihnen mitteilen, dass dieser Fehler auf eine falsche Interpretation eines Profibusteilnehmers zurück zu führen ist. Hier lag das Übel im Bereich vom DP-V1 Protokoll.

    Mit der neuesten Firmware:

    CPU Firmware Version 3.41
    DP-Master Firmware 3.19 (wichtig!!)

    Sollte das Problem behoben sein.

    ...
    Es geht also nichts verloren, kann halt mal etwas dauern, war ja nicht so dramatisch. Muß ich unserem Vertreter wohl doch etwas Abbitte leisten.

    Leider komme ich in nächster Zeit nicht an die Anlage, aber die läuft eh volle Pulle.


    PS: @Maxl

    Kann sein, daß der Manufacture_Alarm kam, wenn am PNOZMULTI ein Fehler auftrat, z.Bsp. die Gleichzeitigkeitsüberwachung von Sicherheitskontakten. Das ist ja im Prinzip ok so, aber ohne den OB57 ... Vielleicht kannst du das einmal nachstellen, ich kann mich dunkel erinnern, daß da die SPS in Stop ging.
    Geändert von Ralle (10.07.2008 um 22:23 Uhr)
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  2. #12
    Avatar von Maxl
    Maxl ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    20.11.2004
    Ort
    Linz, OÖ
    Beiträge
    1.365
    Danke
    96
    Erhielt 177 Danke für 133 Beiträge

    Standard

    Zitat Zitat von Ralle Beitrag anzeigen
    PS: @Maxl

    Kann sein, daß der Manufacture_Alarm kam, wenn am PNOZMULTI ein Fehler auftrat, z.Bsp. die Gleichzeitigkeitsüberwachung von Sicherheitskontakten. Das ist ja im Prinzip ok so, aber ohne den OB57 ... Vielleicht kannst du das einmal nachstellen, ich kann mich dunkel erinnern, daß da die SPS in Stop ging.
    Wir setzen viele PnozMultis ein, bei keiner SPS ist der OB57 vorhanden. Gleichzeitigkeitsfehler und andere Fehler sind schon häufig aufgetreten (bzw. provoziert worden) - die CPU ging nie in Stop. Ich vermute also einfach eine defekte PnozMulti Anschaltung.


    Zurück zum Thema:

    VIPA hat mir zugesagt, mir eine Profibus-Analyzer Software leihweise zuzuschicken. Dann werde ich mir mal ansehen, was auf dem Bus wirklich abgeht.



    [OT]Vielleicht kann mir jemand von VIPA ein kurzes Statement dazu geben: Ab wann (und in welcher Form) darf ich mit EtherCat-Unterstützung durch die Speed7 CPUs rechnen. Im Jänner war ja schon in den News davon zu lesen, nur konkretes finde ich bis jetzt nicht auf der Homepage[/OT]



    mfg Maxl
    Geändert von Maxl (14.07.2008 um 19:47 Uhr)
    Bin aufgrund §2 der "Rechte des Betreibers" der Forum-Regeln nicht mehr aktiv, da nicht nicht akzeptiere, dass Informationen und Erkenntnisse ohne Quellangabe weitergegeben werden sollen. Jedem steht frei, auf die gleichen Erkenntnisse durch Eigenversuche zu kommen, vor allem Buchautoren.

  3. #13
    Avatar von Maxl
    Maxl ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    20.11.2004
    Ort
    Linz, OÖ
    Beiträge
    1.365
    Danke
    96
    Erhielt 177 Danke für 133 Beiträge

    Standard

    So, hab mich heute mit dem Telegramm-Analyzer an den Bus gehängt. Einige Erkenntnisse konnte ich dabei schon sammeln.

    1. War am Panel die Image-Version 1.0.0.0 installiert, so tritt das Problem nicht auf.
    2. Hab nun das Panel wieder auf Image-Version 1.0.0.5 geflasht und das komplette Projekt draufgespielt. Interessanterweise war der Fehler auch hier nicht mehr reproduzierbar.
    3. Hab daher wieder das 2. Panel (welches ich letzte Woche schon mal kurz an den Bus gehängt hatte um zu sehen, obs am Panel liegt) an den Bus gehängt: siehe da - Fehler lässt sich reproduzieren.

    So, nun Fehlerhafte Telegramme gesucht. Hier bin ich dann mit meinem Know-How ziemlich am Ende. Der Analyzer liefert zwar "Fehlertelegramme" und ein paar Details dazu, allerdings kann ich mit den Daten nicht ganz vo viel anfangen.
    Es sieht aber so aus, als ob tatsächlich ein Teilnehmer hier ungefragt, komplett außerhalb des Protokolls einfach was auf den Bus legt. Ob das nun ein Kurzschluss ist, oder sinnlose Datenpakete lässt sich nicht sagen. Am besten werde ich diese Daten morgen mal weitergeben.

    mfg Maxl
    Bin aufgrund §2 der "Rechte des Betreibers" der Forum-Regeln nicht mehr aktiv, da nicht nicht akzeptiere, dass Informationen und Erkenntnisse ohne Quellangabe weitergegeben werden sollen. Jedem steht frei, auf die gleichen Erkenntnisse durch Eigenversuche zu kommen, vor allem Buchautoren.

  4. #14
    Avatar von Maxl
    Maxl ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    20.11.2004
    Ort
    Linz, OÖ
    Beiträge
    1.365
    Danke
    96
    Erhielt 177 Danke für 133 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Um die Geschichte nun zum Abschluss zu bringen (vorweg: ich bin bei den Profibus-Internas kein Profi):

    Die Telegrammaufzeichnung wurde bei VIPA analysiert. Es sieht also so aus, als ob das MP277 am Profibus einen Kurschluss erzeugt bzw. einfach Sch.... auf den Bus wirft. Die "Telegramme" haben unterschiedliche längen - der Sniffer kann damit nichts anfangen - somit der profibus-Master auch nicht. Die Fehler am Bus sind auch bei Einsatz einer Siemens-CPU messbar.
    Der wesentliche Unterschied liegt hier in der Erkennung und Behandlung des Fehlers.

    Der VIPA Master setzt dabei eine Funktion Names "Tokenwatch" ein. Diese prüft, ob der Token korrekt zwischen den Teilnehmern hin und hergegeben wird. Tritt dabei ein Fehler auf (z.B. Kurzschluss), wird der Master Not-heruntergefahren und neu gestartet. --> diese Funktion sind die von mir beobachteten "Abstürze".
    Die Funktion "Tokenwatch" bietet die Siemens-CPU offenbar nicht - bei VIPA ist sie per Default eingeschaltet.

    Wird der Tokenwatch nun abgeschaltet (sprich: Annäherung an das Verhalten der Siemens-CPU), tritt dieses Not-Herunterfahren nicht mehr auf. Allerdings bleibt das Phänomen, dass 3-4 DP-Slaves kurz "Station Ausfall" und kurz danach "Station Wiederkehr" melden. Der Unterschied dürfte in einer unterschiedlichen Fehlerbehandlung liegen. Die VIPA-CPU trägt sofort, nachdem ein Teilnehmer auf einen Data-Request nicht antwortet, einen Fehler ein - die Siemens-CPU hingegen schweigt sich über einzelne Fehler aus und macht knallhart weiter.


    Fazit:

    Die Ursache ist mit ziemlicher Sicherheit in einem fehlerhaften Treiber am MP277 zu suchen. Es sieht so aus, als ob die Panels, wenn sie ausgeliefert werden, andere Treiber mitbringen als wenn man nachträglich ein Betriebssystem-Image lädt. Der Fehler ist nach wie vor nur mit "neuen" Panels mit Image-Version 1.0.0.5 reproduzierbar, auf die nach dem Einbau noch kein "neues" Image geladen wurde.

    Die Siemens-CPU "verschluckt" kurze Fehler am Profibus. Das mag zwar augenscheinlich toll sein wenn die BUSF-LED nicht aufflackert, allerdings tritt nachweislich ein Fehler auf und ein oder mehrere DP-Slaves liefern kurrzeitig (im ms-Bereich) keine gültigen Daten. (was das bedeutet, darf jeder für sich selber interpretieren).

    Dass die VIPA-CPU hier so schnell reagiert und einen Fehler meldet, ist zwar lästig - aber es wird wieder mal vorgeführt, dass am Profibus doch nicht alles so glatt läuft. Die Geschichte mit dem Tokenwatch macht die Sache noch etwas verwirrender. Hier hilft schlicht und einfach abschalten! (optimal wäre es, wenn der Tokenwatch per Default abgeschaltet ist).

    Danke an Vipaner_112 und das VIPA-Team für die rasche Unterstützung.


    Auswirkungen:

    Bis VIPA-CPUs bei uns bei Projekten zum Einsatz kommen könnten, werden wohl alle Siemens-Panels mit Image-Versionen für WinCCflex 2007 ausgeliefert werden. Ich bin guter Hoffnung, dass das Treiberproblem bei diesen Images nicht mehr besteht. Da wir noch immer Flex 2005 einsetzen, werden wir ohnehin zum Image-Downgrade gezwungen, womit dann auch immer eine fehlerfreie 1.0.0.5-Version geladen wird.
    Abgesehen davon spricht bei einer VIPA-CPU auch nichts dagegen, die MP277 generell per Ethernet an die CPU zu koppeln.

    Meine Empfehlung an die Projektleiter lautet in jedem Fall, bei geeigneten Projekten (wo der Kunde es zulässt) VIPA-CPUs einzusetzen, denn die Fakten sprechen für sich (hab schließlich neben den Profibus-Messungen auch einige Maschinen-Programme auf der CPU laufen lassen).

    1. S7 315-2PN/DP durch 315SN ersetzt
    vorher 18-20 ms Zykluszeit
    nachher 3-4 ms Zykluszeit

    2. weitere 315-2PN/DP durch 315SN ersetzt
    vorher 38-40 ms Zykluszeit
    nachher 5 ms Zykluszeit

    3. probeweise das Programm eines Bearbeitungszentrums (319-3PN/DP) auf die CPU geladen (Hardware-Umbau ging nicht, da bei 319 2 Profibus-Stränge genutzt werden)
    Zykluszeit S7 319: 6 ms
    Zykluszeit VIPA 315-SN: 7 ms

    Die CPU kann sich also problemlos mit einer 319 messen - zumindest bei der Geschwindigkeit. Mir ist noch aufgefallen, dass die VIPA ihren Geschwindigkeitsvorteil aber nur dann richtig ausspielen kann, wenn die Siemens-CPU bereits sehr hohe Zykluszeiten > 10 ms hat. Eine Anwendung, bei der die Siemens-CPU eine Zykluszeit von 2-3 ms schafft, kann durch die VIPA kaum noch beschleunigt werden.


    Also dan, schönes Wochenende.

    mfg Maxl
    Bin aufgrund §2 der "Rechte des Betreibers" der Forum-Regeln nicht mehr aktiv, da nicht nicht akzeptiere, dass Informationen und Erkenntnisse ohne Quellangabe weitergegeben werden sollen. Jedem steht frei, auf die gleichen Erkenntnisse durch Eigenversuche zu kommen, vor allem Buchautoren.

  5. Folgende 3 Benutzer sagen Danke zu Maxl für den nützlichen Beitrag:

    josieone (23.07.2008),Ralle (18.07.2008),ssound1de (09.09.2009)

Ähnliche Themen

  1. Phänomen bei bitweisem UND
    Von herdi im Forum Simatic
    Antworten: 20
    Letzter Beitrag: 02.09.2008, 08:29
  2. Rätselhaftes Phänomen
    Von rnovak im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 22.04.2008, 14:23
  3. Phänomen bei Speed7
    Von Ralle im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 23.08.2007, 16:17
  4. merkwürdiges phänomen ?
    Von volker im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 27.09.2006, 08:40
  5. Seltsames
    Von drfunfrock im Forum Stammtisch
    Antworten: 2
    Letzter Beitrag: 02.03.2005, 08:56

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •