Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 20

Thema: Programmierhilfe Siemens Logo

  1. #1
    Registriert seit
    08.08.2008
    Beiträge
    9
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!
    Ich habe eine Siemens Logo "Steuerung" und ein keines Problem beim Programmieren.
    Ich habe einen Tischantrieb der über einen Näherungschalter an einem Zahnrad abgefragt wird.
    18 Impulse sind eine Umdrehung.(ca 1 u/min)
    Einen Schalter der zwischen Automatik und Handbetrieb umschaltet.
    Einen Taster Cycle Start, der im Auto-Betrieb dem Tischmotor startet und nach 18 Impulsen den Motor stopt.
    Soweit wars auch kein Problem.
    Wenn der Schalter auf auf Hand steht, soll der Tisch nach Drücken eines weiteren Tasters im Dauerlauf laufen bis erneut der Taster gedrückt wird.
    Zyclus-Start soll in dieser zeit natürlich nicht zu aktivieren sein.

    Das ganze soll eine Steuerung für eine Maschine die Zahnräder entgratet werden.
    Diese Maschine wird komplett von mir gebaut.Na ja, ich versuchs.
    Ein Teil der Mechanik ist bereits fertig.

    Hoffentlich kann mir jemand eine kleine Starthilfe geben

    mfg Micha*
    Zitieren Zitieren Programmierhilfe Siemens Logo  

  2. #2
    Registriert seit
    07.03.2007
    Ort
    am Kyffhäuser
    Beiträge
    400
    Danke
    120
    Erhielt 70 Danke für 55 Beiträge

    Standard

    Hallo,

    stelle doch mal deine bisherige Lösung hier ein, dann kann man das ganze weiterstricken.

    Frank

  3. #3
    Micha* ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    08.08.2008
    Beiträge
    9
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo.
    Hier meine ersten Gehversuche.


    Und die isc Datei
    ftp://www.x-periment.de/temp/Steuerung_Gratomat.lsc

    Habe mal alle Schalter aus Eingang definiert.
    Wichtig ist die Umschaltung zwischen Hand und Auto Betrieb.
    Desweiteren habe ich das Problem, das der Zyclus mit dem Einschalten der Prorammes aktiv. Sollte so aber nicht sein.
    Ich hoffe mir kann geholfen werden.

    mfg Micha*

  4. #4
    Registriert seit
    07.03.2007
    Ort
    am Kyffhäuser
    Beiträge
    400
    Danke
    120
    Erhielt 70 Danke für 55 Beiträge

    Standard

    ....naja, ist entwicklungsfähig! Da die Maschine im Automatikbetrieb etwas anderes macht wie im Handbetrieb musst Du jede Betriebsart für sich zusammenstricken.
    Vorschlag, wir fangen mit dem Automatikbetrieb an und später wird der Handbetrieb eingefügt. An B001 kannst Du nun weiter den Automatikbetrieb einfügen.

    Frank
    Angehängte Grafiken Angehängte Grafiken

  5. #5
    Registriert seit
    07.03.2007
    Ort
    am Kyffhäuser
    Beiträge
    400
    Danke
    120
    Erhielt 70 Danke für 55 Beiträge

    Standard

    ich würde dann so weitermachen Somit wäre auch der Zähler etwas besser integriert. Evtl. würde ich noch einen zusätzlichen Taster anbringen, einen Zyklus STOP um den Zyklus jederzeit auch anhalten zu können. Schleiferein haben ja im allgemeinen etwas viel Schmutz und Feinstaub rumfliegen. Wenn dadurch die Gefahr besteht das der Taster Zyklus Start verschmutzt und somit immer EIN ist ( ist hier schon passiert) würde ich noch mittels pos. Flanke den Schalter abfragen sonst fährt ein Zyklus nach dem anderen durch.
    Angehängte Grafiken Angehängte Grafiken
    Geändert von himbeergeist (08.08.2008 um 21:07 Uhr)

  6. #6
    Micha* ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    08.08.2008
    Beiträge
    9
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo.
    Danke für deine Hilfe.
    Hab mal die Schaltung "nachgebaut".
    Bei der Simulaion geht das nicht so wie das soll.
    Der Automatikbetrieb soll an sein.
    Der Start-Taster soll gedrückt werden.
    Danach 18 mal den Näherungsschalter betätigen.
    Und dann soll der Motor wieder ausgehen.
    Was mache ich falsch?

    mfg Micha

  7. #7
    Registriert seit
    07.03.2007
    Ort
    am Kyffhäuser
    Beiträge
    400
    Danke
    120
    Erhielt 70 Danke für 55 Beiträge

    Standard

    Hast Du die Simulation richtig eingestellt? Du musst den Eingang I1 als Taster ausführen. Bei mir funktioniert es wie beschrieben.Automatikbetrieb ist an wenn I5 Aus ist.
    Geändert von himbeergeist (08.08.2008 um 21:27 Uhr)

  8. #8
    Micha* ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    08.08.2008
    Beiträge
    9
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo.
    Ich hab den Fehler gefunden.
    Der Zähler war nicht korrekt eingestellt.
    Jetzt gehts.

    Danke mfg Micha*

  9. #9
    Registriert seit
    07.03.2007
    Ort
    am Kyffhäuser
    Beiträge
    400
    Danke
    120
    Erhielt 70 Danke für 55 Beiträge

    Standard

    ..hätte mich auch gewundert . So, nun aber ins Bett, morgen muss ich 4.40 Uhr aufstehen, die Arbeit ruft. Lass was hören wenn es wieder klemmt oder stelle das fertige Projekt mal ein. Läuft der Motor nach dem Ausschalten nach und erzeugt weitere Impulse? Dann musst Du den Zähler nur zählen lassen solange der Motor an ist.

    Gute Nacht
    Frank

  10. #10
    Micha* ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    08.08.2008
    Beiträge
    9
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi
    Hab mal noch weitergebastelt.
    Hab aber ein Problem mit der Umschaltung von Auto auf Hand.
    Wie kann ich Q1 im Handbetrieb ansteuern?
    mfg Micha*
    Angehängte Grafiken Angehängte Grafiken

Ähnliche Themen

  1. Programmierhilfe für CoDeSys
    Von Pubi im Forum CODESYS und IEC61131
    Antworten: 16
    Letzter Beitrag: 01.03.2010, 02:08
  2. programmierhilfe
    Von holschin im Forum Suche - Biete
    Antworten: 1
    Letzter Beitrag: 09.12.2009, 09:31
  3. Antworten: 11
    Letzter Beitrag: 16.12.2008, 12:16
  4. Programmierhilfe für S7
    Von Joe.Baer im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 26.04.2005, 13:29
  5. Programmierhilfe: Pumpensteuerung
    Von xpert im Forum Programmierstrategien
    Antworten: 4
    Letzter Beitrag: 28.01.2005, 13:33

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •