Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: Problem mit Omron SPS

  1. #1
    Registriert seit
    31.10.2008
    Beiträge
    7
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!

    Ich habe bei einem Kunden Probleme mit einer CQM1 CPU21 von Omron.
    Ich kann sowohl mit dem CX-Programmer, als auch mit Syswin das Programm auslesen. Will ich es jedoch sofort wieder in die SPS schreiben, kommt die Fehlermeldung Parameter außerhalb des Bereichs. Schau ich mir das Progi an sind dort Sprünge zu Unterprogrammen programiert mit Zieladresse 201 und 201. Laut Handbuch sind diese aber erst ab CPU 48 möglich. Da ein Rückschreiben nicht möglich ist und ich dem Kunden keinen Maschinenstillstand verursachen will, habe ich mir eine zweite CPU versorgt. Ich habe jetzt das originale Prog auf einen peichererweiterrungschip geschoben, den in die neue SPS gesteckt und vom Chip booten lassen. Danach hab ich die neue SPS in die Anlage eingebaut und gestartet. Die Initialisierung hat noch funktioniert und das Menü ließ sich auch starten. Nur das Referenzieren des Hubarmes ging nicht, so das eine Programmabarbeitung nicht möglich ist. Der Motor läuft einfach nur durch.
    Keine Ahnung was da nicht stimmt.
    Vielleicht hat ja von euch einer eine Idee.
    Zitieren Zitieren Problem mit Omron SPS  

  2. #2
    Registriert seit
    20.06.2007
    Ort
    NRW
    Beiträge
    106
    Danke
    2
    Erhielt 14 Danke für 14 Beiträge

    Standard

    Hallo,
    Unterprogrammsprünge (SBS) sind kein Problem, solange es die Unterprogrammdefinitionen (SBN) mit den gleichen Labelnummern gibt.
    Das funktioniert bei allen CPU-Typen.
    CQM1-CPU48 gibt es gar nicht.
    Du hast nicht beschrieben, wie Du das Programm aus deiner CPU hoch- und wieder runtergeladen hast?
    Außerdem gibt es immer noch die Möglichkeit des Online-Editierens.

    Der Fehler:
    "Parameter außerhalb des Bereichs"
    weist eigentlich darauf hin, dass versucht wurde, außer dem Programm auch Einstellungen herunterzuladen, die fehlerhaft sind.

    Nachdem Du aber das ursprüngliche Programm, mit dem aus der Speicherkarte überschrieben hast, ist jetzt alles hin!

    Lass lieber einen Fachmann ran.

    Tut mir leid, dass ich keine besseren Nachrichten geben kann.

  3. #3
    motmonti ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    31.10.2008
    Beiträge
    7
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von bugatti66 Beitrag anzeigen
    Nachdem Du aber das ursprüngliche Programm, mit dem aus der Speicherkarte überschrieben hast, ist jetzt alles hin!

    Lass lieber einen Fachmann ran.
    Hallo!

    Danke erstmal für deine Antwort!

    Ich bin zwar nicht der Vollprofi, aber auch nicht ganz blöd. Berufsbedingt habe ich mit unterschiedlichen Steuerungen zu tun und kann daher nicht jede 100% kennen.

    Ich hab das Programm mit CX-Programmer ausgelesen und gespeichert. Der Versuch das Programm gleich wieder zur Steuerung zu übertragen scheiterte mit der genannten Fehlermeldung. Mir war klar, das ich im Fall das etwas schief geht, keine Möglichkeit habe die Anlage wieder zum laufen zu bekommen. Also habe ich mir eine Steuerung vom gleichen Typ versorgt. Auf diese habe ich nach Löschen der Fehler das Programm aufgespielt und diese Steuerung dann eingebaut. Leider lief die Anlage damit nicht. Jetzt habe ich mir das Programm des alten angeblichen Originalspeichers auf meine Steuerung gezogen und diese dann getestet. Leider wieder mit einem negativen Ergebnis. Jetzt habe ich das lauffähige Programm auf den Chip gezogen und mit dem Chip dann in meine neue Steuerung. Kann sein das da etwas nicht funktioniert hat, jedenfalls lief die Anlage damit auch nicht.
    Die Idee mit dem Online-Edit htte ich auch und hab es auf der neuen Steuerung getestet. Es hat funktioniert, aber bevor ich nicht zwei lauffähige Steuerungen habe, ist es mir zu heiß auf der originalen teuerung zu experimentieren.
    Die Reaktion der Anlage läßt sich auch Hardwareseitig mit Zeitglied und ni realisieren. Daher hab ich dann auch nicht auf biegen und brechen versucht zum Erfolg zu kommen.

    Es wurmt mich aber mächtig das ich es nicht hinbekommen habe.

Ähnliche Themen

  1. Omron cqm1h
    Von Kieler im Forum Sonstige Steuerungen
    Antworten: 4
    Letzter Beitrag: 10.03.2010, 16:02
  2. Sps von omron
    Von nourdine im Forum PC- und Netzwerktechnik
    Antworten: 3
    Letzter Beitrag: 03.03.2009, 15:47
  3. Omron PLC
    Von Phil im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 26.03.2008, 16:58
  4. Omron im Allgemeinen
    Von andbulk im Forum Sonstige Steuerungen
    Antworten: 4
    Letzter Beitrag: 02.07.2007, 20:55
  5. Omron C 200 HG
    Von JS1 im Forum Sonstige Steuerungen
    Antworten: 0
    Letzter Beitrag: 20.01.2007, 21:00

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •