Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: Wago io pro 32

  1. #1
    Registriert seit
    07.05.2009
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    kennt sich jemand mit dem WAGO IO PRO 32 aus?
    In dem Handbuch zum Programm ist ein Beispiel Programm
    drin, eine Ampelsteuerung. Ich habe jeden Schritt getan.
    Am Ende muss man den Quelltext übersetzen. Da bekomm
    ich Fehlermeldungen:

    Error_Globale_Variablen(2): Unzulässige Adresse: %IB0.0
    ....

    Obwohl ich in den Globalen Variablen genau das reingeschrieben habe, was in dem Handbuch stand.

    VAR_GLOBAL
    EIN AT %IB0.0: BOOL;
    A1_gruen AT %QB0.0: BOOL;
    A1_gelb AT %QB0.1: BOOL;
    A1_rot AT %QB0.2: BOOL;
    A2_gruen AT %QB0.4: BOOL;
    A2_gelb AT %QB0.5: BOOL;
    A2_rot AT %QB0.6: BOOL;
    END_VAR


    Wäre schön wenn ihr mir helfen könntet.

    Mfg Marcel
    Zitieren Zitieren Wago io pro 32  

  2. #2
    Registriert seit
    28.03.2008
    Beiträge
    142
    Danke
    19
    Erhielt 25 Danke für 25 Beiträge

    Standard

    Zielsystemeinstellungen Harken bei "Keine Adressprüfung" reinmachen.

    ODER

    In der Hardwarekonfig die Ein und Ausgänge zuweisen.
    Komm und wecke den Teufel unter meiner Schädeldecke. Das Chaos hat die Macht!

  3. #3
    Marcel1989 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.05.2009
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für die schnelle Antwort.
    Wenn du mir sagst, wo ich die Zielsystemeinstellungen finde, wäre es perfekt

  4. #4
    Registriert seit
    28.03.2008
    Beiträge
    142
    Danke
    19
    Erhielt 25 Danke für 25 Beiträge

    Standard

    Ich kenne Wago io pro 32 ja nicht aber da es auf CoDeSys basiert solltest Du es unter Resourcen => Zielsystemeinstellungen finden. Gibt es den Begriff in der Hilfe?
    Komm und wecke den Teufel unter meiner Schädeldecke. Das Chaos hat die Macht!

  5. #5
    Registriert seit
    20.01.2005
    Beiträge
    179
    Danke
    37
    Erhielt 13 Danke für 10 Beiträge

    Standard

    EIN AT %IB0.0: BOOL; --> Totaler Quatsch
    mach ma das:
    EIN AT %IX0.0: BOOL;
    und dann alle Binären mit %*x*.*

    ---> %*B* ist nämlich BYTE
    schöne grüße
    Michael

  6. #6
    Marcel1989 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.05.2009
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke @ BadTaste
    Das was du als totaler Quatsch bezeichnest, steht aber genau so in dem Handbuch drin
    und wenn ich das

    EIN AT %IX0.0: BOOL;

    schreibe dann zeigt er mir keinen fehler mehr an,
    doch wenn ich denn mich einloggen will, schmeißt er mich immer wieder raus.

    Kommunikationsfehler: Du wirst automatisch ausgeloggt.

    Wie kann ich das umgehen?

  7. #7
    Registriert seit
    20.01.2005
    Beiträge
    179
    Danke
    37
    Erhielt 13 Danke für 10 Beiträge

    Standard

    Kannst mir mal ein Link zeigen wo das steht?

    Versuch doch erst einmal mit dem Simulator das Programm zu simulieren.
    Ansonsten tippe ich auf Kommunikationsfehler wegen faschen Treiber... aber die Kristallkugel ist grade seeeeehr nebelig.

    bis dann Michael

  8. #8
    Marcel1989 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.05.2009
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Sorry ich habs nur als PDF. Kann ich die hier irgendwie anhängen (3.33 MB) ?

    Genau ich will es ja erstmal simulieren. Das steht in der PDF dazu drin:

    Testen Sie nun Ihr Programm. Dazu müssen Sie es übersetzen (‘Projekt’ ‘Alles übersetzen’) und laden (‘Online’ ‘Einloggen’ und dann ‘Online’ ‘Laden’).
    Wenn Sie nun ‘Online’ ‘Start’ ausführen, können Sie die zeitliche Abfolge der
    einzelnen Schritte ihres Hauptprogramms verfolgen. Das Fenster des Bausteins
    PLC_PRG hat sich nunmehr zum Monitor Fenster gewandelt. Mit Doppelklick
    auf das Pluszeichen im Deklarationseditor klappt die Variablendarstellung auf
    und Sie können die Werte der einzelnen Variablen beobachten."

  9. #9
    Registriert seit
    20.01.2005
    Beiträge
    179
    Danke
    37
    Erhielt 13 Danke für 10 Beiträge

    Standard

    Mußt du aber vorher unter
    Online - Simulation anklicken, sonst läuft der Simulator ja auch nicht

  10. #10
    Marcel1989 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.05.2009
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ah da war der Fehler. Hab herzlichst Dank.

Ähnliche Themen

  1. Wago 750-841
    Von Erzengel im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 31.08.2011, 10:55
  2. Wago 750-303
    Von Heinz im Forum Feldbusse
    Antworten: 1
    Letzter Beitrag: 20.09.2010, 12:03
  3. Wago M-Bus. lib
    Von wero im Forum Feldbusse
    Antworten: 6
    Letzter Beitrag: 22.07.2008, 17:17
  4. Mit Wago OPC-Server eine Wago 750-481 auslesen?
    Von Reto Hasler im Forum Hochsprachen - OPC
    Antworten: 8
    Letzter Beitrag: 26.06.2008, 10:02
  5. WAGO I/O 750-842
    Von wagotester im Forum Feldbusse
    Antworten: 1
    Letzter Beitrag: 11.07.2004, 01:42

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •