Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: 2 stck PS3 als master und slave

  1. #1
    Registriert seit
    17.07.2009
    Beiträge
    3
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Zusammen,

    ich habe auf einer Schiffsinstallation zwei Stück PS3 (24V DC) die als Master und Slave miteinander verbunden sind. Die SPSen dienen zur Steuerung und Überwachung der Hauptdieselmaschiene und der Hilfsdieselmaschine und sind räumlich voneinander getrennt. Der Master sitzt im Maschienenraum, nahe der Dieselmotoren und der Slave sitzt im Brückenhaus.

    Ich besitze alle Program Listings, die Software (sucos PS3), das Kommunikationskabel und auch noch einen alten DOS PC. Die Kommunikation zwischen PC und Master funktioniert, das Diagnoseprogram zeigt den Status der Ein und Ausgänge (leider nur Master).

    Soweit ich die Programlistings richtig verstanden habe, liegt die gesamte Steuerung nur im Master und der Slave dient nur zur Signalisierung im Brückenhaus. Die Maschienen lassen sich auch starten und anhalten, nur ist man im Brückenhaus leider blind, da die Anzeigelampen (alle am Slave angeschlossen) nicht funktionieren.

    Obwohl die Kommunikation mit der Sucosoft PS3 Software funktioniert und auch das Program gelesen und geändert werden kann, kann ich keine Verbindung zum Slave herstellen. Ich sehe keinen Status der Eingänge und die Ausgänge lassen sich nicht "forcen". Ich bekomme aber keine Fehlermeldung, dass die Kommunikation nicht funktioniert o. Ä..

    Meine Frage nun: Muss der Slave über die Prozedur "Make slave" als passiver Slave initiiert werden oder nicht? Leider habe ich diese Information aus den Handbüchern der PS4, da ich zur PS3 keine Handbücher habe.

    In beiden PS3 sind neue Batterien eingesetzt und die BetriebsLED sowie die Run LED leuchten wie erwartet.

    Wenn mir jemand einen Tip geben kann, wäre ich sehr dankbar.
    Zitieren Zitieren 2 stck PS3 als master und slave  

  2. #2
    Registriert seit
    31.12.2003
    Beiträge
    223
    Danke
    1
    Erhielt 32 Danke für 28 Beiträge

    Standard

    Hallo AfürD!

    Dieses Programm kommt mir sehr bekannt vor.
    Habe da schon mal geholfen.
    Aber nun zu Deiner Frage.

    Es ist Denkbar einfach!
    Unter jeder PS3 Abdeckung, wo die Batterie sind, gibt es Hakenschalter!
    Diese sind für Festlegung von Master und Slave!
    Es wird die Hardwareadresse eingestellt.
    Für Master P3 gilt: 0,1,1,1,1
    Für ersten Slave gilt: 1,0,1,1,1
    Bitte so einstellen und dann beide PS3 neu an Spannung legen, damit die Adrtesscodierung übernommen werden kann.
    Dann sollte man im Status auch die zweite PS3 erkennen und Forcen können.
    Im Programm muß natürlich auch für die Master PS3 nur Eingänge und Ausgänge mit dem Index wie z.B. I0.2 oder Q0.4 genommen werden.
    In der ersten Slave PS3 sind dann z.B. I1.5 oder Q1.3 zu nehmen.

    Wenn noch Fragen einfach melden.
    mfg Uwe
    Zitieren Zitieren Das hab ich schon einmal gehabt!!!  

  3. Folgender Benutzer sagt Danke zu Uwe Schröder für den nützlichen Beitrag:

    AfürD (20.07.2009)

  4. #3
    AfürD ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.07.2009
    Beiträge
    3
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Uwe,

    vielen Dank für die Antwort. Jetzt habe ich schon soviel über mein Problem ins Forum gestellt, und dabei vergessen, dass die "Häckchenschalter" natürlich schon so gesetzt waren, wie Du es beschrieben hast. Die Benennung der I/O ist ebenfalls so wie Du es beschrieben hast.

    Vielleicht noch eine Info. Das System hat mal einwandfrei funktioniert. Nur wurden dann aus dem Schiff (ehemaliges Polizeiboot) diverse System ausgebaut. Ich könnte mir vorstellen, dass dabei recht "rustikal" vorgegangen wurde und einfach Kabel gekappt wurden. Eventuell hat die slave SPS dabei einen Schaden erlitten.

    Was allerdings neu für mich war, ist die Sache mit dem Spannung wegnehmen und dann wieder zuschalten. Das will ich dann mal ausprobieren. Verstehst Du unter Spannug wegnehmen auch Batterien entfernen?

    Verstehe ich Dich weiter richtig, dass das in den Handbüchern beschriebene Verfahren für die PS4 "make slave" bei der PS3 nicht benötigt wird?

    Vorab schon einmal recht herzlichen Dank. Da ich neu bin, weiss ich noch nicht, wie ich den DANK offiziell ins Forum stelle.

    Gruß

    Alexander alias AfürD

  5. #4
    Registriert seit
    31.12.2003
    Beiträge
    223
    Danke
    1
    Erhielt 32 Danke für 28 Beiträge

    Standard

    Hallo !
    Zitat Zitat von AfürD Beitrag anzeigen
    Vielleicht noch eine Info. Das System hat mal einwandfrei funktioniert. Nur wurden dann aus dem Schiff (ehemaliges Polizeiboot)kenne ich diverse System ausgebaut. Ich könnte mir vorstellen, dass dabei recht "rustikal" vorgegangen wurde und einfach Kabel gekappt wurden. Eventuell hat die slave SPS dabei einen Schaden erlitten.
    Brauchst Du eine Erstsatz PS3?
    Vielleicht ist auch nur die Busleitung gestört?
    Bitte Stecker mit Pin 1 und 4 auf Durchgang prüfen!
    ( Pin 1 zu 1 und Pin 4 zu 4)

    Was allerdings neu für mich war, ist die Sache mit dem Spannung wegnehmen und dann wieder zuschalten. Das will ich dann mal ausprobieren. Verstehst Du unter Spannug wegnehmen auch Batterien entfernen? Nein, denn dann ist das Programm weg!
    Es braucht übrigens nur die Master PS3 die Batterie, Slaves brauchen keine!

    Verstehe ich Dich weiter richtig, dass das in den Handbüchern beschriebene Verfahren für die PS4 "make slave" bei der PS3 nicht benötigt wird?Ja

    Vorab schon einmal recht herzlichen Dank. Da ich neu bin, weiss ich noch nicht, wie ich den DANK offiziell ins Forum stelle.

    Gruß

    Alexander alias AfürD
    mfg Uwe , wir fangen alle mal an...

  6. Folgender Benutzer sagt Danke zu Uwe Schröder für den nützlichen Beitrag:

    AfürD (20.07.2009)

  7. #5
    Registriert seit
    20.07.2009
    Beiträge
    2
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Frage:
    Wie stehts mit der RUN-LED am Slave? Blinkt diese ist die Bus-Verbindung zum Master unterbrochen.

    Ist die Spannungsversorgung für die Ausgänge überhaupt vorhanden? (24V³,0V³)

    mfg christian
    Zitieren Zitieren PS3 als Slave  

  8. Folgender Benutzer sagt Danke zu ch_ristian für den nützlichen Beitrag:

    AfürD (20.07.2009)

  9. #6
    AfürD ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.07.2009
    Beiträge
    3
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Christian,

    ja, die LED leuchten richtig, und die RUN LED blinkt auch nicht. Die Spannungsversorgung ist ebenfalls vorhanden.

    Ich glaube langsam, das die SPS einen Knacks hat und defekt ist. Jetzt werde ich erst einmal die Reset Procedure von Uwe ausprobieren. Mal sehen was dann passiert.

    Kann aber ein paar Tage dauern, da ich im Moment nicht an Bord bin.

    Vorab vielen Dank

    AfürD

  10. #7
    Registriert seit
    31.12.2003
    Beiträge
    223
    Danke
    1
    Erhielt 32 Danke für 28 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!

    Habe noch eine PS3 zum probieren!

    Einfach mal melden.

    mfg Uwe
    Zitieren Zitieren Einfach zu helfen!  

Ähnliche Themen

  1. 2 FU's Master und Slave ist nacheilend
    Von Anonymous im Forum Elektronik
    Antworten: 3
    Letzter Beitrag: 11.02.2010, 09:57
  2. DP-Master - DP-Slave???
    Von davka im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 29.08.2008, 11:09
  3. Master-Slave
    Von titinparma im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 20.08.2007, 10:59
  4. S7 Master und Slave
    Von Anonymous im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 21.12.2005, 20:39
  5. 315 DP Master zu 315 DP Slave
    Von Anonymous im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 24.06.2005, 11:33

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •