Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Ausgang direkt schalten Wago 750-841-517

  1. #1
    Registriert seit
    19.03.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich stehe auf dem Schlauch. Ich versuche (über TCP-ModbusTCP) mit der Funktion FC5 den 1. Ausgang zu schalten. Ich bekomme als Response für Byte 8-11 auch das, was in der Beschreibung steht, das Relais zieht aber nicht an:

    zur 841 -> 0000 0000 0006 0105 0000 ff00
    von 841 <- 0000 0000 0006 0105 0000 ff00

    Wo liegt mein Denkfehler? Auf der SPS läuft kein Programm! Die Adressen von Merkern zu setzen und zu lesen geht.

    Gruß,
    Peter
    Zitieren Zitieren Ausgang direkt schalten Wago 750-841-517  

  2. #2
    Registriert seit
    06.02.2005
    Beiträge
    120
    Danke
    1
    Erhielt 10 Danke für 10 Beiträge

    Standard

    Versuche mal : 0000 0000 0006 0105 0001 ff00

  3. #3
    peter65 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    19.03.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von IFATD Beitrag anzeigen
    Versuche mal : 0000 0000 0006 0105 0001 ff00
    Nun dann geht es um das 2. Bit statt dem ersten, geht leider auch nicht. Die Kiste reagiert nicht darauf, trotz Antwort:
    <- 0000 0000 0006 0105 0001 ff00

  4. #4
    Registriert seit
    06.02.2005
    Beiträge
    120
    Danke
    1
    Erhielt 10 Danke für 10 Beiträge

    Standard

    Das mit den Modbus Befehl ist erstmal so o.k.! Ist die Ausgangsklemme schon mal getauscht worden?(defekt)

  5. #5
    peter65 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    19.03.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von IFATD Beitrag anzeigen
    Das mit den Modbus Befehl ist erstmal so o.k.! Ist die Ausgangsklemme schon mal getauscht worden?(defekt)
    Wenn ich ein Programm lade und die Ausgänge über Merkerwörter schalte, geht es. Nicht defekt! Ich wollte aber den direkten Weg auch testen. Habe mit Codesys die Kiste in den Ursprung zurück gesetzt und wollte direkt schalten. Antwort kommt aber Relais zieht nicht

  6. #6
    peter65 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    19.03.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also, der WAGO-Support wusste die Lösung. Sobald man mit CoDeSys an dem 841 war, kommt man nicht mehr direkt an die Ausgänge. Da hilft nur eins: "WAGO Ethernet Settings" -> Format, danach Extract, danach Restart. Dann ist die Kiste wieder "dumm" und dann klappt auch sofort das Schalten mit FC5!

  7. #7
    Registriert seit
    10.05.2005
    Beiträge
    2.005
    Danke
    220
    Erhielt 234 Danke für 205 Beiträge

    Standard

    HI

    Oder zweitens

    Mit einer Inteligenten PLC.
    Zuordnen der Ausgänge wer "verändern" darf.

    Nach dem Motto "Es kann nur einen geben".




    Da gibt es eine Einstellung die sagt werde der "Chef" ist.

    Irgend wie unter

    Resourcen --> Steuerungskonfiguration --> HArdware configuration --> K-Bus


    Auf die Klemme dann gibt es hier unter z.b. 0750-0501 2DO


    Basisparameter und Modulparameter.


    Bei Modulparamteter unter Wert kanst du PLC oder fieldbus 1 auswählen.


    Sagt dass der "Chef" der Feldbus ist, dann wird dieser von der PLC nicht mehr überschrieben.

    Das klappt für jede Klemme separat.


    Feedback willkommen.
    Geändert von gravieren (07.04.2010 um 13:15 Uhr)
    Karl

  8. #8
    peter65 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    19.03.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Was für "Resourcen" ...? Von welcher GUI redest du?

  9. #9
    Registriert seit
    10.05.2005
    Beiträge
    2.005
    Danke
    220
    Erhielt 234 Danke für 205 Beiträge

    Standard

    Hi

    CoDeSys starten



    Links unten gibt es "Reiter".


    Bausteine, Datentypen, Visualisierungen und Resourcen.

    (Bei Bausteine ist meist "PLC_PRG" vorhanden)
    Karl

  10. #10
    peter65 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    19.03.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja so geht es auch! Getestet! Schade, dass du dich nicht ein paar Tage eher gemeldet hast. Trotzdem Danke für den Tipp!

    Gruß,
    Peter

Ähnliche Themen

  1. Lasten direkt schalten mit Befehlsgeräten 3SB3...
    Von element. im Forum Schaltschrankbau
    Antworten: 1
    Letzter Beitrag: 24.02.2011, 17:49
  2. Ausgang erst bei Dauersignal schalten
    Von Andelot im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 10.10.2010, 09:00
  3. Ausgang mehrmals nacheinander schalten
    Von marcel0509 im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 20.07.2009, 08:57
  4. Ausgang schalten
    Von Moboso im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 15.04.2008, 10:49
  5. Antworten: 1
    Letzter Beitrag: 17.06.2004, 10:26

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •