Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 12 von 12

Thema: B&R X20 mit IF1030 --> Fehler 8258

  1. #11
    Avatar von BadTaste
    BadTaste ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    20.01.2005
    Beiträge
    179
    Danke
    37
    Erhielt 13 Danke für 10 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Jawohl das läuft, hatte leider vergessen zu schreiben... sorry
    der Support hat mir geholfen, ich habe ein Fehler im Variablenaufruf im Datenmodul

    Im Datenmodul wird der Programmname dem Variablennamen vorangestellt.

    der Programmname unterscheidet sich aber von dem im Beispiel.


    die meisten Fehler macht man halt doch selbst...

    schöne Grüße
    Michael
    ---
    Tatsachen muss man kennen, bevor man sie verdrehen kann (Mark Twain)

  2. #12
    Registriert seit
    19.01.2010
    Ort
    Graz / Austria
    Beiträge
    100
    Danke
    6
    Erhielt 10 Danke für 8 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von BadTaste Beitrag anzeigen

    Im Datenmodul wird der Programmname dem Variablennamen vorangestellt.

    der Programmname unterscheidet sich aber von dem im Beispiel.

    die meisten Fehler macht man halt doch selbst...
    Eigentlich ist es ja im Beispiel schon nicht richtig angeben.
    Wenn lokale Variablen (sind nur im jeweiligen Task gültig) verwendet werden, muss der entsprechende Taskname mit angegeben werden, da die SPS sonst den Namen nicht sicher zuordnen kann. Es könnte ja mehrer lokale Variablen mit dem selben Namen geben.

    Es sollte eigentlich heißen:
    Code:
    "TaskXXX:EventPV1 ", 01, $01, "TaskXXX:LocalPV1 ", 0000, 0005
    "TaskXXX:EventPV2 ", 02, $01, "TaskXXX:LocalPV2 ", 0000, 0003

Ähnliche Themen

  1. Antworten: 9
    Letzter Beitrag: 17.06.2011, 08:02
  2. OPC BDE Fehler
    Von Power_Pete im Forum Hochsprachen - OPC
    Antworten: 13
    Letzter Beitrag: 19.05.2011, 13:53
  3. Wo ist der Fehler???
    Von husox81 im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 30.01.2010, 16:07
  4. Wo ist der Fehler???
    Von husox81 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 28.01.2010, 18:12
  5. S5 DB1 Fehler
    Von mariob im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 26.01.2009, 17:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •