Hallöle...

Ich habe ein Problem, bei dem ich nicht weiterkomme. Der Schrittkettenbaustein lässt sich nicht so verwenden wie gewünscht!!!

Als AWL-Code fand ich im Handbuch Folgendes...

Code:
PROGRAM T_check
    VAR_GLOBAL
        Schrittnummer : USINT ;
        Grundstellung AT %I0.0.0.0.0 : BOOL ;
        Schutztuer_zu AT %I0.0.0.0.1 : BOOL ;
        AUS AT %I0.0.0.0.2 : BOOL ;
        Kessel_voll AT %I0.0.0.0.3 : BOOL ;
        Temperatur_erreicht AT %I0.0.0.0.4 : BOOL ;
        Ventil_auf AT %Q0.0.0.0.0 : BOOL ;
        Heizung_an AT %Q0.0.0.0.1 : BOOL ;
    END_VAR

    VAR
        chain : SFC_3 ;
        Erster_Zyklus : BOOL ;
        Initial : Init_FB ;
        fuellen : FB1 ;
        heizen : FB2 ;
        ablassen : FB3 ;
    END_VAR

    LD ISA
    PLC_Message
    ST Erster_Zyklus
    CAL chain(Set := TRUE,
                    ReSet := Erster_Zyklus,
                    StepInputNumber := Schrittnummer,
                    InitStep := Initial,
                    Step_1 := fuellen,
                    Step_2 := heizen,
                    Step_3 := ablassen
                    |
                    :=Error,
                    :=StepOutputNumber,
                    :=StepToggle)
END_PROGRAM
Analog dazu mein Quellcodeauszug in ST

Code:
...
(*** SCHRITTKETTE*)
    stepChain(Set:=isRun,
              ReSet:=firstCycle,
              StepInputNumber:=stepNum,
              InitStep:=checkBasicPostion,
              Step_1:=turnOffOutputs,
              Step_2:=getBasicPosition);
...
Wenn ich den Code nun übersetze, bringt er mir die Meldung...

Fehler => Anw, Ze: 15, Sp: 6 - Baustein bzw. Struktur hat kein Element namens 'Step_2'

Im Editor-Tooltip erscheint Folgendes...



...eine Erklärung für den Fehler finde ich dennoch nicht!