Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: PC WorX: Fehler beim kompilieren

  1. #1
    Registriert seit
    25.06.2008
    Ort
    Blomberg/Lippe
    Beiträge
    1.297
    Danke
    51
    Erhielt 130 Danke für 124 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe folgendes Problem. Ich habe eine eigene Bibliothek erstellt. Wenn ich diese kompiliere ist alles in Ordnung.
    Binde ich sie in einem Projekt ein und Bausteine verwende, kommt der Fehler
    Code:
    Fehler beim Generieren des nativen Code!
    beim kompilieren. Weiß jemand woran das liegen kann?
    Gruß
    Mobi


    „Das Einfache kompliziert zu machen ist alltäglich. Das Komplizierte einfach zu machen –
    das ist Kreativität“ (Charles Mingus).
    Zitieren Zitieren PC WorX: Fehler beim kompilieren  

  2. #2
    Registriert seit
    24.11.2011
    Ort
    Esbjerg, Denmark
    Beiträge
    15
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Das Problem kenne ich gut. Schau doch mal nach ob alle deine Data Typs mit in dein Program gekommen sind. Da gibt es noch Probleme.
    Um dem Fehler besser zu verstehen: Welche PCWorx version benutz du?

    MadCat

  3. #3
    Avatar von Mobi
    Mobi ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.06.2008
    Ort
    Blomberg/Lippe
    Beiträge
    1.297
    Danke
    51
    Erhielt 130 Danke für 124 Beiträge

    Standard

    Die 6.00.25 SP 3.73.
    Gruß
    Mobi


    „Das Einfache kompliziert zu machen ist alltäglich. Das Komplizierte einfach zu machen –
    das ist Kreativität“ (Charles Mingus).

  4. #4
    Registriert seit
    24.11.2011
    Ort
    Esbjerg, Denmark
    Beiträge
    15
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich habe die 6.10.145 und habe das gleiche Problem gehabt, da PCWorx meine sys_flag_type nicht übernommen hatte. Ich muste meine data_typs manuel überarbeiten.

    MadCat

  5. #5
    Avatar von Mobi
    Mobi ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.06.2008
    Ort
    Blomberg/Lippe
    Beiträge
    1.297
    Danke
    51
    Erhielt 130 Danke für 124 Beiträge

    Standard

    Um was ging es denn genau? Ich hab nämlich auch eigene data_types drin.
    Gruß
    Mobi


    „Das Einfache kompliziert zu machen ist alltäglich. Das Komplizierte einfach zu machen –
    das ist Kreativität“ (Charles Mingus).

  6. #6
    Registriert seit
    24.11.2011
    Ort
    Esbjerg, Denmark
    Beiträge
    15
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Bei mir hatte er die data_tyes nicht übernommen von meiner Libraries. Ich programmiere meine eigenen FB's in einer selbständigen Librarie und lese diese dann einfach in mein Project ein. Als der Fehler bei mir auftrat, Hatte PCWorx die data_type für den FB nicht übernommen. So ich habe dann die fehelenden Einträge in der data_type ergänzt und dann ging es schon. Hatte gehoft das es auch bei dir so sein könnte. Aber leider ist es nicht immer so einfach.
    Meine RFC 470 hat sich gerade verabschiedet. Program komieliert ohne Fehler, in die SPS geladen und jetz ist sich nicht mehr zufrieden. Na, schauen wir mal.

    MadCat

  7. #7
    Avatar von Mobi
    Mobi ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.06.2008
    Ort
    Blomberg/Lippe
    Beiträge
    1.297
    Danke
    51
    Erhielt 130 Danke für 124 Beiträge

    Standard

    Hier mal das Test-ZWT, vielleicht hilfts. Wie gesagt der Fehler kommt beim kompilieren.
    Test-My_Library.zip
    Gruß
    Mobi


    „Das Einfache kompliziert zu machen ist alltäglich. Das Komplizierte einfach zu machen –
    das ist Kreativität“ (Charles Mingus).

  8. #8
    Registriert seit
    24.11.2011
    Ort
    Esbjerg, Denmark
    Beiträge
    15
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich schau mal ob ich was sehen kann. Könnte aber bis Montag dauern. Muss leider übers Wochenende arbeiten. Melde mich dann.

    MadCat

  9. #9
    Registriert seit
    24.11.2011
    Ort
    Esbjerg, Denmark
    Beiträge
    15
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    OK. Ich bekomme den gleichen Fehler! Schau mal ob ich was finde. Nur mal eine Frage: was wilst du loggen? Ich sehe das du eine STRING array loggen möchtest mit einer help array. Ich denke das in der declaration der fehler liegen wird.

    I have a look

  10. #10
    Avatar von Mobi
    Mobi ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.06.2008
    Ort
    Blomberg/Lippe
    Beiträge
    1.297
    Danke
    51
    Erhielt 130 Danke für 124 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hey,

    danke das du dir das auch mal angesehen hast. Also das Array sieht folgendermaßen aus. In der Dimension [0] kommen die Namen der Werte rein (z.B.: Temp1, p2 oder Vol6) und in der Dimension [1] die Werte inkl. Einheit. Man kann insgesamt 100 Werte gleichzeitig loggen.
    Bin ja schonmal "froh", dass es bei dir auch einen Fehler gibt.
    Das Helparray muss ich ja anlegen, weil es ein mehrdimensionales Array ist.
    Die Bibliothek hat auch schonmal funktioniert, ich musste nur noch einige Sachen beim loggen ändern.
    Glaube nicht, dass es an der Deklaration liegen wird von dem Array.
    Gruß
    Mobi


    „Das Einfache kompliziert zu machen ist alltäglich. Das Komplizierte einfach zu machen –
    das ist Kreativität“ (Charles Mingus).

Ähnliche Themen

  1. Fehler beim Übersetzen
    Von B4D_Dr1ft im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 01.09.2011, 15:13
  2. Antworten: 9
    Letzter Beitrag: 17.06.2011, 08:02
  3. AEG ALU 201 fehler beim Urladen
    Von Marschl89 im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 05.05.2011, 10:42
  4. String-Fehler bei PC Worx
    Von Mobi im Forum Sonstige Steuerungen
    Antworten: 5
    Letzter Beitrag: 22.11.2010, 07:47
  5. C7-621 Fehler beim Datentransfer ins OP
    Von S7-Tester im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 25.11.2009, 09:49

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •