Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 22

Thema: B&R Kopieren einer Datei auf einen FileZilla FTP-Server

  1. #1
    Registriert seit
    02.02.2011
    Beiträge
    109
    Danke
    16
    Erhielt 13 Danke für 13 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!
    Beim Kopieren der Datei BDE051211_66.asc von einer Steuerung CP1484 auf einen FileZilla Server bekomme ich folgenden Log:

    FileZilla Server version 0.9.40 beta
    Copyright 2001-2011 by Tim Kosse (tim.kosse@filezilla-project.org)
    Connecting to server...
    Connected, waiting for authentication
    Logged on
    (0022105.12.2011 12:04:09 - (not logged in) (192.168.179.171)> Connected, sending welcome message...
    (0022105.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 220
    (0022105.12.2011 12:04:09 - (not logged in) (192.168.179.171)> USER SPS_MA
    (0022105.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 331 Password required for sps_ma
    (0022105.12.2011 12:04:09 - (not logged in) (192.168.179.171)> PASS *******
    (0022105.12.2011 12:04:09 - sps_ma (192.168.179.171)> 230 Logged on
    (0022105.12.2011 12:04:09 - sps_ma (192.168.179.171)> disconnected.
    (002219)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> Connected, sending welcome message...
    (002219)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 220
    (002219)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> USER SPS_MA
    (002219)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 331 Password required for sps_ma
    (002219)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> PASS *******
    (002219)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 230 Logged on
    (002219)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> TYPE I
    (002219)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 200 Type set to I
    (002219)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> CWD /
    (002219)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 250 CWD successful. "/" is current directory.
    (002219)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> PORT 192,168,179,171,4,68
    (002219)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 200 Port command successful
    (002219)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> NLST
    (002219)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 150 Opening data channel for directory list.
    (002219)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 226 Transfer OK
    (002219)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> disconnected.

    (002220)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> Connected, sending welcome message...
    (002220)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 220
    (002220)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> USER SPS_MA
    (002220)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 331 Password required for sps_ma
    (002220)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> PASS *******
    (002220)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 230 Logged on
    (002220)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> TYPE I
    (002220)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 200 Type set to I
    (002220)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> CWD BDE051211_66.asc ????????????????????????? was soll das ?
    (002220)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 550 CWD failed. "/BDE051211_66.asc": directory not found.
    (002220)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> PORT 192,168,179,171,4,70
    (002220)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 200 Port command successful
    (002220)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> NLST BDE051211_66.asc
    (002220)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 550 Directory not found
    (002220)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> QUIT
    (002220)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 221 Goodbye
    (002220)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> disconnected.

    (002221)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> Connected, sending welcome message...
    (002221)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 220
    (002221)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> USER SPS_MA
    (002221)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 331 Password required for sps_ma
    (002221)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> PASS *******
    (002221)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 230 Logged on
    (002221)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> TYPE I
    (002221)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 200 Type set to I
    (002221)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> CWD BDE051211_66.asc ???????????????????????????????????
    (002221)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 550 CWD failed. "/BDE051211_66.asc": directory not found.
    (002221)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> QUIT
    (002221)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 221 Goodbye
    (002221)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> disconnected.

    (002222)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> Connected, sending welcome message...
    (002222)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 220
    (002222)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> USER SPS_MA
    (002222)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 331 Password required for sps_ma
    (002222)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> PASS *******
    (002222)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 230 Logged on
    (002222)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> TYPE I
    (002222)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 200 Type set to I
    (002222)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> CWD BDE051211_66.asc ??????????????????????????????
    (002222)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 550 CWD failed. "/BDE051211_66.asc": directory not found.
    (002222)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> PORT 192,168,179,171,4,73
    (002222)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 200 Port command successful
    (002222)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> NLST BDE051211_66.asc
    (002222)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 550 Directory not found
    (002222)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> QUIT
    (002222)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 221 Goodbye
    (002222)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> disconnected.

    (002223)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> Connected, sending welcome message...
    (002223)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 220
    (002223)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> USER SPS_MA
    (002223)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 331 Password required for sps_ma
    (002223)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> PASS *******
    (002223)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 230 Logged on
    (002223)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> TYPE I
    (002223)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 200 Type set to I
    (002223)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> CWD BDE051211_66.asc ??????????????????????????????????????
    (002223)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 550 CWD failed. "/BDE051211_66.asc": directory not found.
    (002223)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> QUIT
    (002223)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 221 Goodbye
    (002223)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> disconnected.

    (002224)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> Connected, sending welcome message...
    (002224)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 220
    (002224)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> USER SPS_MA
    (002224)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> 331 Password required for sps_ma
    (002224)05.12.2011 12:04:09 - (not logged in) (192.168.179.171)> PASS *******
    (002224)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 230 Logged on
    (002224)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> TYPE I
    (002224)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 200 Type set to I
    (002224)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> PORT 192,168,179,171,4,76
    (002224)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 200 Port command successful
    (002224)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> STOR BDE051211_66.asc jetzt aber……………………………………….
    (002224)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 150 Opening data channel for file transfer.
    (002224)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 226 Transfer OK
    (002224)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> QUIT
    (002224)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> 221 Goodbye
    (002224)05.12.2011 12:04:09 - sps_ma (192.168.179.171)> disconnected.



    Warum versucht der Server mehrfach mit CWD BDE051211_66.asc das Directory (vor allem wohin) zu ändern anstatt direkt zu kopieren.
    Mit einem lokalen Kopiervorgang macht der Server das nicht.
    Wo kommt das unnötige und falsche CWD BDE051211_66.asc her? (Netztraffic)
    Es geht dem ein DevLink(...) und ein FileCopy(....) der SPS zum Homedirectory des Servers voraus
    Im Zielstring steht BDE051211_66.asc und sonst nichts

    Vielen Dank für einen Hinweis
    Zitieren Zitieren B&R Kopieren einer Datei auf einen FileZilla FTP-Server  

  2. #2
    Registriert seit
    28.04.2005
    Beiträge
    205
    Danke
    22
    Erhielt 17 Danke für 14 Beiträge

    Standard

    Hast du den Zielstring evtl. nicht mit "\0" abgeschlossen?
    Oder versuch mal "./" vor den Dateinamen zu setzen...

    MfG

    Markus
    Geändert von da_kine (05.12.2011 um 15:38 Uhr)

  3. #3
    Avatar von gaiskasimir
    gaiskasimir ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.02.2011
    Beiträge
    109
    Danke
    16
    Erhielt 13 Danke für 13 Beiträge

    Standard

    wie es sich geziemt...

  4. #4
    Registriert seit
    28.04.2005
    Beiträge
    205
    Danke
    22
    Erhielt 17 Danke für 14 Beiträge

    Standard

    Okay...
    Dieses ganze B&R File-Handling ist mir eh etwas suspekt...habe noch keine Erfahrungen mit FTP gesammelt, aber dafür ausreichend mit USB gekämpft.

    Aber so wie es aussieht hast du bei deinem Dateinamen immer ein "/" vor dem Dateinamen wenn es nicht funktioniert...schau dir doch mal im Debug an was wirklich in deinem String steht, wenn ein Fehler auftritt.

  5. #5
    Avatar von gaiskasimir
    gaiskasimir ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.02.2011
    Beiträge
    109
    Danke
    16
    Erhielt 13 Danke für 13 Beiträge

    Standard

    Nein, im String steht nur der reine Dateiname mit 0 terminiert.
    Kopiere übrigens von einem USB Stick problemlos - nicht mal von B&R

  6. #6
    Registriert seit
    28.04.2005
    Beiträge
    205
    Danke
    22
    Erhielt 17 Danke für 14 Beiträge

    Standard

    Ja, das mit den USB-Sticks ist irgendwie komisch...habe schon mit teueren "industrial grade" schlimme Dinge gesehen wo hingegen Werbegeschenk-Sticks tadellos über Jahre funktionierten...

    Hast du dir mal mit Wireshark oder ähnlichem den Traffic angesehen? Damit du siehts was da wirklich hin und her gesendet wird?

  7. #7
    Avatar von gaiskasimir
    gaiskasimir ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.02.2011
    Beiträge
    109
    Danke
    16
    Erhielt 13 Danke für 13 Beiträge

    Standard

    Laut Wireshark sagt die SPS CWD BDE051211_66.asc - aber warum ?

  8. #8
    Registriert seit
    28.04.2005
    Beiträge
    205
    Danke
    22
    Erhielt 17 Danke für 14 Beiträge

    Standard

    Was gibt dir denn die SPS als Fehlermeldung zurück?

  9. #9
    Avatar von gaiskasimir
    gaiskasimir ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.02.2011
    Beiträge
    109
    Danke
    16
    Erhielt 13 Danke für 13 Beiträge

    Standard

    Es ist in dem Sinne kein Fehler - das FileCopy gibt außer "busy" (65535) und "Ok" (0) nichts zurück
    Es gehen nur unnötige Telegramme auf das Netz

  10. #10
    Registriert seit
    19.01.2010
    Ort
    Graz / Austria
    Beiträge
    100
    Danke
    6
    Erhielt 10 Danke für 8 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von gaiskasimir Beitrag anzeigen
    Es ist in dem Sinne kein Fehler - das FileCopy gibt außer "busy" (65535) und "Ok" (0) nichts zurück
    Es gehen nur unnötige Telegramme auf das Netz
    Das heißt der Kopiervorgang selbst ist eigentlich erfolgreich?
    In diesem Fall tippe ich einmal auf einen Fehler in der Library der einfach noch niemandem aufgefallen ist, da der Vorgang selbst ja erfolgreich ist und sonst kaum jemand auf die Server Logs oder den eigentlichen Traffic im Netz schaut.

Ähnliche Themen

  1. Von MMC auf USB die Logs datei kopieren
    Von zvende im Forum HMI
    Antworten: 0
    Letzter Beitrag: 20.05.2010, 16:07
  2. Mit Adressregister von Daten von DBx in einen DBy kopieren
    Von iga-graz im Forum Programmierstrategien
    Antworten: 11
    Letzter Beitrag: 15.10.2007, 21:17
  3. Antworten: 2
    Letzter Beitrag: 16.11.2006, 17:45
  4. Wie einen Atmega 8515-16 kopieren?
    Von maxi im Forum Elektronik
    Antworten: 1
    Letzter Beitrag: 13.07.2006, 13:18
  5. ProTool VBS Datei kopieren
    Von RyanB im Forum HMI
    Antworten: 5
    Letzter Beitrag: 05.10.2005, 14:24

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •