Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 14 von 21 ErsteErste ... 41213141516 ... LetzteLetzte
Ergebnis 131 bis 140 von 206

Thema: ILC 150 ETH Webserver

  1. #131
    Portisch ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.09.2011
    Beiträge
    145
    Danke
    0
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ne, aber ich habe mir einmal den Rawstring in Delphi angesehen:
    000000b4h: 68 F6 63 68 ; höch

    Scheint also ISO-8859-1 zu sein!?
    XMLHTTPRequest ist es zumindest beim IE9 egal was für ein Encoding ich einstelle...

    Wenn ich ein UTF8 Encode fom responseText mache kommt das raus: ï¿¿
    Geändert von Portisch (27.09.2012 um 19:44 Uhr)

  2. #132
    Registriert seit
    25.06.2008
    Ort
    Blomberg/Lippe
    Beiträge
    1.293
    Danke
    51
    Erhielt 130 Danke für 124 Beiträge

    Standard

    Versuch mal in der .js
    so
    Code:
    xhttp.setRequestHeader("Content-Type", "application/xml; charset=ISO-8859-1");
    xhttp.setRequestHeader("Charset", "ISO-8859-1");
    oder so
    Code:
    xhttp.setRequestHeader("Content-Type", "application/xml; charset=UTF-8");
    xhttp.setRequestHeader("Charset", "UTF-8");
    Gruß
    Mobi


    „Das Einfache kompliziert zu machen ist alltäglich. Das Komplizierte einfach zu machen –
    das ist Kreativität“ (Charles Mingus).

  3. #133
    Portisch ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.09.2011
    Beiträge
    145
    Danke
    0
    Erhielt 3 Danke für 3 Beiträge

    Standard

    http://channel9.msdn.com/Forums/Tech...equest-charset

    Genau so ist es hier! Der XMLHTTPRequest bekommt keinen UTF-8 Response -> Sonderzeichen werden zu 0xFFFF -> unbrauchbar.
    Wenn ich den responseText als Byte Array in der Console ausgebe ist das 0xFFFF beim 'ö' zu finden.

    Lösung dafür: Keine Sonderzeichen verwenden!
    Ich habe auch Spirdercontrol mal angeschrieben ob man den Webserver auf der ILC auf UTF-8 umstellen kann. Mal sehen ob da eine Antwort kommt.

  4. #134
    Registriert seit
    25.06.2008
    Ort
    Blomberg/Lippe
    Beiträge
    1.293
    Danke
    51
    Erhielt 130 Danke für 124 Beiträge

    Standard

    Ich habs jetzt mal getestet mit den Umlauten bei mir. Bei mir klappt es.
    Gruß
    Mobi


    „Das Einfache kompliziert zu machen ist alltäglich. Das Komplizierte einfach zu machen –
    das ist Kreativität“ (Charles Mingus).

  5. #135
    Portisch ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.09.2011
    Beiträge
    145
    Danke
    0
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Mit Javascript (XMLHTTPRequest)? Welcher Browser?
    Kannst du mir die entry.html und Javascript Datei hochladen?

  6. #136
    Registriert seit
    26.02.2008
    Ort
    Kulmbach
    Beiträge
    151
    Danke
    13
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,
    konnte es auch gerade testen, bei mir kommt folgende Meldung: var_not_found

    Habe eine String Variable umlaut angelegt, als Startwert habe ich böse angegeben...

    Mit der Original Datei von Portisch bekomme ich zwar das Ergebnis zurück, das ö von böse ist aber ein Viereck...
    Getestet mit IE9 und Firefox...


    Schöne Grüße
    Daniel
    Angehängte Grafiken Angehängte Grafiken
    Geändert von Vaninger (28.09.2012 um 16:05 Uhr)
    Zitieren Zitieren umlaut  

  7. #137
    Registriert seit
    25.06.2008
    Ort
    Blomberg/Lippe
    Beiträge
    1.293
    Danke
    51
    Erhielt 130 Danke für 124 Beiträge

    Standard

    Variable umlaut wirds auch nicht geben. Wenn dann @GV.Umlaut oder Main.Umlaut oder so, je nachdem obs Global oder Lokal ist.


    @Portisch: ne nix von dem. Ohne Browser. Mit meiner exe.
    Gruß
    Mobi


    „Das Einfache kompliziert zu machen ist alltäglich. Das Komplizierte einfach zu machen –
    das ist Kreativität“ (Charles Mingus).

  8. #138
    Registriert seit
    26.02.2008
    Ort
    Kulmbach
    Beiträge
    151
    Danke
    13
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi Mobi,
    stimmt, siehe Korrektur meines vorherigen Beitrages. Ist mir dann auch noch aufgefallen

    Das ö wird halt als Viereck angezeigt!

    Gesendet von meinem GT-I9300 mit Tapatalk 2

  9. #139
    Registriert seit
    25.06.2008
    Ort
    Blomberg/Lippe
    Beiträge
    1.293
    Danke
    51
    Erhielt 130 Danke für 124 Beiträge

    Standard

    Wie ist das eigentlich bei euch? Bei mir dauert es, wenn ich lokal auf die ILC zugreife, ca. 60ms zwischen Anfrage und Antwort. Wenn ich extern (über DynDns), also über Internet zugreife, ca. 300ms.
    Gruß
    Mobi


    „Das Einfache kompliziert zu machen ist alltäglich. Das Komplizierte einfach zu machen –
    das ist Kreativität“ (Charles Mingus).

  10. #140
    Portisch ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.09.2011
    Beiträge
    145
    Danke
    0
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    @Portisch: ne nix von dem. Ohne Browser. Mit meiner exe.
    Hier geht es die ganze Zeit um XMLHTTPRequest mit Javascript.
    Mit meiner EXE geht es auch Umlaute oder Sonderzeichen zu übertragen.

    Mit Javascript aber direkt aber nicht!

Ähnliche Themen

  1. Phoenix Contact ILC 150 ETH FTP Upload
    Von cag im Forum PHOENIX CONTACT
    Antworten: 7
    Letzter Beitrag: 10.11.2011, 19:14
  2. Phoenix ILC 170 ETH + IL ETH BK + IB IL AI 4/U
    Von valik.vak im Forum PHOENIX CONTACT
    Antworten: 24
    Letzter Beitrag: 17.06.2011, 11:22
  3. ILC 150 ETH an Fritzbox 7270
    Von Mobi im Forum Sonstige Steuerungen
    Antworten: 3
    Letzter Beitrag: 19.05.2011, 13:36
  4. Phoenix ILC 150 ETH + Stromüberwachung
    Von underxpressure im Forum PHOENIX CONTACT
    Antworten: 11
    Letzter Beitrag: 03.12.2010, 13:48
  5. ILC 150 ETH mit Webvisit+Ipad
    Von simonhu im Forum Sonstige Steuerungen
    Antworten: 8
    Letzter Beitrag: 06.10.2010, 09:06

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •