Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: TCP/IP Verbindung Rockwell - Sensoren

  1. #1
    Registriert seit
    27.07.2012
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich versuche eine Ethernet Kommunikation zwischen einen Rockwell Logix5571 controller mit einer 1756-EN2TR Ethernet/IP Karte und Temperatur Sensoren der Firma Rotronic mit einem Ethernet Port aufzubauen. Ich habe über die RSLinx Software einen neuen Treiber eingefügt mit der IP des Rechners, der IP der 1756-EN2TR Ethernet/IP Karte und die IPs der Sensoren. Sowohl die RSLogix als auch die RSNetworx Software erkennt nur den Rechner und die 1756-EN2TR Ethernet/IP Karte aber nicht die Sensoren.

    Könnt ihr mich weiterhelfen?
    Zitieren Zitieren TCP/IP Verbindung Rockwell - Sensoren  

  2. #2
    Registriert seit
    29.08.2008
    Beiträge
    68
    Danke
    1
    Erhielt 8 Danke für 7 Beiträge

    Standard

    Hallo,

    schon mal versucht, die Sensoren "anzupingen" ? Ist der Hardwareaufbau auch richtig? Es gibt das Programm "RsNetWorx for Ethernet/IP". Schon mal über das Programm versucht. Braucht man eventuell ein eds-File?

    Gruß

    gd

  3. #3
    trachanas ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.07.2012
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo georg_demmler,

    danke für deine Antwort. Der Hardwareaufbau ist in ordnung und die Sensoren lassen sich problemlos anpingen. Wie ich bereits geschrieben habe versuchte ich eine "Ethernet/IP" Verbindung mit Hilfe vom Programm "RsNetWorx for Ethernet/IP" aufzubauen was nicht klappt weil die Sensoren das Applikationsprotokol wahrscheinlich nicht unterstützen. Nun versuche ich die Kommunikation über ein selbst geschriebenes Program aufzubauen. Dabei haben sich neue Fragen ergeben, die ich schon in dem Rockwell Forum gepostet habe:

    "Indeed Rotronic does not advertise that they support the Rockwell Ethernet/IP application protocol. You can find information about the devices I use here: http://www.rotronic.de/productattach...wnload?id=449I assume that the sensors do not support the Ethernet/IP application protocol and I started reading the documentation about the "open sockets" feature. I updated the firmware of the 1756-EN2TR Ethernet/IP card to version 5.028 and started programming the communication between one sensor and the controller using structured text and especially the MSG command (create socket -> open connection (TCP) -> write socket -> read socket), but new questions came up:

    1. What my application has to do is to send a specific byte sequence (using TCP) to the sensors every e.g. 100ms and receive the answer (already working with a siemens PLC). Therefore, I created a periodic main task, where the "write socket" and "read socket" takes place. I put the "create socket" and "open connection" in the Power-Up handler after a "delete all sockets" because according to my understanding these actions have to be made once at the beginning and not periodically. I downloaded the project to the controller, set the mode to run and watched some variables using quick watch but nothing happens (everything is zero). Did I do something wrong?
    2. In the message configuration of e.g. the "open connection" a instance number of the socket is needed. I didn't know what to put there so I just put a value (29120), but I am sure this is wrong. What I understand is that after creating a socket the MSG command returns this value, but I already need to input the value by hand in the message configuration. I don't get this. Can you help?"

    Ich würde mich über jeden Hinweis von euch sehr freuen!

    Viele Grüße,
    IT

  4. #4
    trachanas ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.07.2012
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    ich habe beide meine Fragen selbst beantworten können, habe aber eine Frage noch. Hier ist mein Beitrag vom Rockwell Forum:

    "Hallo,


    I just wanted to write that I answered both questions myself. All variables were zero because the program that was downloaded in the controller was empty. Now I found out how to download the project correctly. What the instance number of the socket concerns I update the "Instance" member of the MESSAGE tag with the value that is returned by the "create socket" action (MSG command).



    I still have a question that I couldn't clarify: Where can I put a routine that runs only once (e.g. after power-up or after a transition from the "program mode" to the "run mode"? I think that the power-up handler is not the right place for such a routine."

    Könnt ihr mir weiterhelfen?

    Viele Grüße,
    IT

  5. #5
    Registriert seit
    11.07.2004
    Beiträge
    1.597
    Danke
    10
    Erhielt 213 Danke für 183 Beiträge

    Standard

    S:FS schimpft sich das Bit welches nur beim ersten Zyklus wahr ist.

  6. #6
    trachanas ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.07.2012
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke!

    Ich habe das Problem der Initialisierung anders gelöst: Ich habe einen EVENT gesteuerten Task erstellt und auf eine Variable getriggert die ich irgendwo im Code in diesen Klammern gesetzt habe: [:=]. Ich habe gelesen, dass wenn man die Variable so setzt wird sie bei jeder Initialisierung (bei Power-Up oder bei Programmodus -> Runmodus) auf 0 gesetzt. Und das ist der Fall.

    Viele Grüße,
    IT

Ähnliche Themen

  1. Codesys v3 TCP Verbindung
    Von kai86 im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 10.05.2012, 20:42
  2. TCP Verbindung S7-1200
    Von RogerSchw85 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 03.04.2012, 17:04
  3. Unterschied TCP- und ISO-on-TCP-Verbindung
    Von kassla im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 19.08.2007, 07:27
  4. TCP Verbindung
    Von Loipe im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 26.03.2007, 10:33
  5. WinCC V6.0 TCP/IP Verbindung
    Von ottopaul im Forum HMI
    Antworten: 7
    Letzter Beitrag: 21.11.2006, 11:42

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •