Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: B & R über serielle Schnittstelle programmieren

  1. #1
    Registriert seit
    23.09.2005
    Beiträge
    17
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Morgen an alle Forumbesucher,

    ich habe folgendes Problem. Vor kurzem war in unserer Firma ein unerwarteter Stromausfall, was dazu führte, dass unser Panel von B&R nicht mehr zu kontaktieren ist. Nicht einmal mehr über die serielle Schnittstelle. Seltsamerweise hat es der SPS von B&R überhaupt nichts ausgemacht, diese ist nachdem dem Stromausfall wieder ganz normal hochgefahren.
    Was kann ich tun um das Panel wieder in Betrieb zu bekommen, die Reset Taste zu drücken hilft auch nicht?

    Hardware:
    B&R Power Panel 100
    B&R Zentraleinheit CP340

    mfg
    Kobold
    Zitieren Zitieren B & R über serielle Schnittstelle programmieren  

  2. #2
    Registriert seit
    28.04.2005
    Beiträge
    205
    Danke
    22
    Erhielt 17 Danke für 14 Beiträge

    Standard

    Zeigt das Panel denn irgendwas an?

    MFG

    Markus

  3. #3
    Kobold ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.09.2005
    Beiträge
    17
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    @Markus

    Das Panel zeigt folgendes an!

    Bernecker + Rainer Industrie-Elektronik

    Version 03
    Device ID 1594
    CompatibilityID 00
    Brigthness D5 EA FF
    Contrast 00 46 FF

    Mode/Node 01
    MAC Address 00:60:65:01:3A:CA
    BootLoader 00.00.00
    HW Layer 1.2.0
    OnBoard AR V2.65

    All values in hex

    Ich kann Dir leider nicht sagen, ob vor dem Ausfall das Panel andere Werte angezeigt.Ich hab nie darauf geachtet was dort stand, weil alles so problemlos gearbeitet hatte.

    mfg Kobold

  4. #4
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Du kannst die Knotenschalter auf FF stellen (besser in der Hilfe nachschauen) um in den Servicemode zu kommen. Dann kannst du auf die COM zugreifen.

    Schau mal, was die Knotenschalterstellungen bedeuten. Ich habe mit dem Typ keine Erfahrungen.

    Gruß,pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

  5. #5
    Anonymous Gast

    Standard

    Ich habe nun das Panel im Servicemodus neu gestartet, konnte aber trotzdem keine Verbindung aufbauen.

    Wie sieht es eigentlich mit dem Bootloader aus müsste dort nicht irgendeine Version auf dem Panel angezeigt werden und nicht 00.00.00. Ich habe auch die Knotenstellung auf 00 gestellt um zu Booten, aber das Panel zeigt nur "Bootin please wait" an, und das über mehrere Minuten bis man dann abbricht.

    mfg
    Kobold

  6. #6
    Kobold ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.09.2005
    Beiträge
    17
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Sorry hab vergessen mich anzumelden

    Kobold

  7. #7
    Registriert seit
    28.04.2005
    Beiträge
    205
    Danke
    22
    Erhielt 17 Danke für 14 Beiträge

    Standard

    Wie sieht es denn aus, wenn du an die Steuerung rangehst? Siehst du das Panel in der Online Ansicht?

    Wie sieht es mit der Visualisierung des Panels aus? Ist die in der CPU oder auf einer CompactFlash im PP?

    MFG

    Markus

  8. #8
    Kobold ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.09.2005
    Beiträge
    17
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Markus ,

    ich kann das Panel nichteinmal in der Online Ansicht sehen, daran hängt's ja schon. Und darum kann ich leider auch kein Betriebssystem herunterladen.

    mfg
    Kobold

  9. #9
    Registriert seit
    28.04.2005
    Beiträge
    205
    Danke
    22
    Erhielt 17 Danke für 14 Beiträge

    Standard

    Ist die Visualisierung auf dem PP??

    Wenn ja, dann organisier dir doch einen USB-CardReader und schau mal auf die CF Karte die in der Steuerung bzw. dem PowerPanel drin ist, ob da noch was drauf ist.

    Ansonsten kannst du das ganze nochmal über dein AutomationStudio und den CardReader neu drauf machen. Dann sparst du dir nämlich die ganze Serielle übertragerei, die ja auch ne Zeit lang dauert.

    Das ganze hört sich für mich nämlich Verdächtig danach an, dass sich die CF-Karte verabschiedet hat.

    Markus

  10. #10
    Registriert seit
    20.11.2004
    Ort
    Linz, OÖ
    Beiträge
    1.365
    Danke
    96
    Erhielt 177 Danke für 133 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Üblicherweise werden PP100 im Terminal-Mode betrieben.

    In dieser Betriebsart ist auf dem Panel gar nichts installiert,
    sondern das Panel lädt beim Hochlaufen das Visu-Objekt von der CP340 über Ethernet.

    Wie das ganz genau Funktioniert, kann ich auch nicht beantworten, ich würde mal den B&R-Support befragen, die haben sicher schnell eine passende Antwort!


    mfg
    Max

Ähnliche Themen

  1. Serielle Schnittstelle
    Von Anonymous im Forum Simatic
    Antworten: 23
    Letzter Beitrag: 07.08.2006, 11:16
  2. Antworten: 2
    Letzter Beitrag: 09.07.2006, 17:59
  3. Serielle Schnittstelle
    Von Anonymous im Forum PC- und Netzwerktechnik
    Antworten: 5
    Letzter Beitrag: 05.02.2006, 16:20
  4. S7-200: Serielle Schnittstelle
    Von reini69 im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 24.11.2004, 16:59
  5. Serielle Schnittstelle
    Von Anonymous im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 18.06.2004, 11:20

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •