Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Installation von TwinCat V2.9 Build 1031 - bereitet Probleme

  1. #1
    Registriert seit
    15.12.2005
    Ort
    USA
    Beiträge
    45
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    Ich habe Probleme mit der TwinCat Software. Seit dieser Woche habe ich ein neues Laptop und wollte nun "mal eben, neben dem anderen Kram" die TwinCat Software installieren.

    Es koennte ja so einfach sein... Das TwinCat Info Fenster welches nach dem hochfahren auf dem Desktop erscheint friert ein. Normalerweise sollte es nach kurzer Zeit, wenn der Dienst gestartet wurde, wieder verschwinden tut es aber nicht. Das Problem haengt wohl mit dem TwinCat Sys-Server zusammen, dieser Dienst kann im Hintergrund irgendwie nicht gestartet werden. Wenn ich den laufenden Prozess "TCATSysSrv.exe" beende verschwindet das Fenster und ich kann TwinCat wenigstens wieder vernuenftig deinstallieren.

    Folgende Versionen habe ich installiert und getestet.
    - V2.9 Build 1025
    - V2.9 Build 1031
    - V2.10 Build 1244
    alle negativ

    Die Beckhoff Hotline ist ratlos und meint es wuerde an meinem Rechner liegen. Hat schon mal jemand aehnliche Probleme mit der Installation der TwinCat Software gehabt ?

    Folgendes System habe ich im Einsatz:
    Brand: Sager NP5710-C
    Pentium M770 2.13 GHZ / 2GB RAM
    ATI Mobility Radeon X700 128MB / WSXGA+ 1680x1050
    100GB SATA 150 Hard Disk
    WinXP Pro SP2

    Distributor:
    Sager Midern Computer Inc.
    18005 Cortney Court,
    City of Industry, CA 91748
    United States

    Link: http://www.sagernotebook.com/pages/n...5710&SubType=C


    Bjoern
    Zitieren Zitieren Installation von TwinCat V2.9 Build 1031 - bereitet Probleme  

  2. #2
    Registriert seit
    25.04.2005
    Beiträge
    98
    Danke
    19
    Erhielt 8 Danke für 7 Beiträge

    Standard

    Hallo,
    ich hatte mal ein Problem mit der installation einer Kabeltester-Software,
    es gibt in Windows XP einen Ausführungsschutz DEP.
    Der Hersteller der Software hat hat mir den Tip gegeben in der BOOT.INI den Eintrag "noexecute=OptIn" in NOEXECUTE=AlwaysOff zu ändern, danach ging das Ding


    mfg Max
    mfg max

  3. #3
    Registriert seit
    25.07.2005
    Ort
    Vogelsbergkreis
    Beiträge
    1.717
    Danke
    48
    Erhielt 68 Danke für 60 Beiträge

    Standard

    Zitat Zitat von maxmax
    Hallo,
    ich hatte mal ein Problem mit der installation einer Kabeltester-Software,
    es gibt in Windows XP einen Ausführungsschutz DEP.
    Der Hersteller der Software hat hat mir den Tip gegeben in der BOOT.INI den Eintrag "noexecute=OptIn" in NOEXECUTE=AlwaysOff zu ändern, danach ging das Ding


    mfg Max
    Genau mach den Depp mal ganz aus, wie oben geschrieben, oder füge TwinCat als Ausnahme unter Systemsteuerung -> System -> Leistungsoptionen -> Ausführungsschutz hinzu.

  4. #4
    Registriert seit
    15.12.2005
    Ort
    USA
    Beiträge
    45
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Unter System -> Advanced -> Perfomance Options -> Data Execution Prevention (DEP) habe ich TwinCat System Service mal als Ausnahme hinzugefuegt, ohne Erfolg.

    Wo finde ich die BOOT.INI ? Ich moechte den -DEPP...- mal komplett deaktivieren.


    Bjoern

  5. #5
    Registriert seit
    25.07.2005
    Ort
    Vogelsbergkreis
    Beiträge
    1.717
    Danke
    48
    Erhielt 68 Danke für 60 Beiträge

    Standard

    Zitat Zitat von Bjoern
    Unter System -> Advanced -> Perfomance Options -> Data Execution Prevention (DEP) habe ich TwinCat System Service mal als Ausnahme hinzugefuegt, ohne Erfolg.

    Wo finde ich die BOOT.INI ? Ich moechte den -DEPP...- mal komplett deaktivieren.


    Bjoern
    Unter C:\

    erstmal die Ordneroptionen auf Alle Dateien + Systemdateien umstellen, dann siehst du sie auch!

  6. #6
    Registriert seit
    15.12.2005
    Ort
    USA
    Beiträge
    45
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke !

    Mit "Show hidden files and folders" alleine war es nicht getan. Ich musste den Haken bei "Hide protected operating system files" entfernen und anschliessend noch das "Read only" von der .INI deaktivieren.

    Habe den DEPP nun deaktiviert in dem ich "NOEXECUTE=AlwaysOff " in der BOOT.INI gesetzt habe. Das Problem ist dadurch jedoch immer noch nicht behoben.

    Mittlerweile hat sich Beckhoff auch wieder gemeldet. Also ich muss sagen, die Hotline ist im Vergleich zu Siemens deutlich schneller zu erreichen und bis jetzt auch unheimlich hilfsbereit und sachlich. Man hat das Thema bereits etwas hoeher aufgehangen und an die Softwareentwicklung weiter gegeben. Am Montag wollen wir uns dann gemeinsam mal die Registry Eintraege vornehmen. Bis jetzt bin ich noch guter Dinge das wir das Problem in den Griff bekommen.

    Im EventViewer von Windows erscheint folgender Eintrag, welchen ich momentan noch nicht verstehe.
    Event Type: Warning
    Event Source: TcRouter
    Event Category: None
    Event ID: 54
    Date: 12/15/2005
    Time: 3:25:10 PM
    User: N/A
    Computer: ADMINISTRATOR-LT
    Description:
    The description for Event ID ( 54 ) in Source ( TcRouter ) cannot be found.
    The local computer may not have the necessary registry information
    or message DLL files to display messages from a remote computer.
    You may be able to use the /AUXSOURCE= flag to retrieve this description;
    see Help and Support for details. The following information is part
    of the event: \Device\TCROUTER.

    Data:
    0000: 00 00 00 00 01 00 5a 00 ......Z.
    0008: 00 00 00 00 36 00 04 80 ....6..?
    0010: 00 00 00 00 00 00 00 00 ........
    0018: 00 00 00 00 00 00 00 00 ........
    0020: 00 00 00 00 00 00 00 00 ........
    Bjoern

  7. #7
    Registriert seit
    15.12.2005
    Ort
    USA
    Beiträge
    45
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Tage spaeter...

    Habe ich nun endlich ein Feedback zu meinen Problemen mit der TwinCat Software bzw. mit dem TwinCat Router bekommen. Man stelle sich vor, Beckhoff moechte die Schuld nun Siemens in die Schuhe schieben

    Zitat Zitat von Die Beckhoff Hotline
    Da ich von unserem Produkmanager die Meldung bekommen habe, dass hier ein nicht bekanntes Problem vorliegt, kann ich Ihnen leider keine echte Lösung anbieten. Ein gangbarer Weg, um herauszufinden ob es an der Hardware liegt ist, dass Sie TwinCat auf einem "Nackten" Betriebssystem installieren, ohne Siemens oder anderer Software. Siemens hat leider die unangenehme Angewohnheit, dll's auszutauschen, die im System liegen und von TwinCat benutzt werden können. Dann kann es zu solchen Effekten kommen.
    Eine andere Möglichkeit kann ich ihnen im Moment nicht bieten.
    Hat schon einmal jemand aehnliche Probleme mit der TwinCat Software gehabt bzw. geloest ?


    Bjoern
    Zitieren Zitieren Tage spaeter... Beckhoff schiebt die Schuld nun auf Siemens.  

  8. #8
    Registriert seit
    15.12.2005
    Ort
    USA
    Beiträge
    45
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    So...

    Nach dem ich ja nun von Beckhoff in diesem Fall nicht wirklich unterstützt wurde (Siemens soll der Bösewicht sein...) habe ich mir zwischen den Feiertagen mal die Zeit genommen und die Probleme gründlich untersucht.

    WindowsXP wurde fluchs auf der 3.Partition von meinem Laptop installiert und anschließend noch die mitgelieferten Treiber. Der Schock folgte sogleich, nach dem ich die TwinCat Software wieder installiert hatte. Sie lief immer noch nicht . Aber wo war jetzt der Bösewicht ? Von Siemens und Kollegen war zu diesem Zeitpunkt nichts auf dem System installiert.

    Und auch der nächste Tag ging dafür drauf, alles weiter zu untersuchen. Stück für Stück wurden die Treiber installiert bzw. deinstalliert. Der Bösewicht wurde nach einigen Stunden schließlich gefunden. Nein, er heißt nicht Siemens und hat auch sonst recht wenig mit dem Konzern zu tun. Es ist der Treiber vom Touchpad !

    Komisch, was tauscht eine Touchpad Software wohl für dll´s aus die von Beckhoff TwinCat benutzt werden ? Eigentlich auch wurscht, denn egal in welcher Reihenfolge man die beiden Komponenten installiert, es ist immer das selbe Ergebnis. TwinCat läuft nicht... Man sollte eigentlich davon ausgehen, dass die Beckhoff Software die entsprechenden dll´s welche sie für einen Betrieb unter WindowsXP benötigt auch installiert.

    Morgen werde ich Beckhoff entsprechend informieren und die Software vom Touchpad mal weiterleiten. Ich gespannt, wer nun der Bösewicht ist.

    Mein Vertrauen in die Beckhoff Software ist mittlerweile stark in der Gunst gesunken. Aber wir geben ja bekanntlich nicht auf.

    Hoch lebe Siemens ! Dreimal hoch...hoch...hoch...


    Gruß
    Bjoern

  9. #9
    Registriert seit
    06.03.2007
    Beiträge
    1
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,
    habe ähnliche Probleme mit der Installation!!!
    Schon eine Lösung gefunden???

    Bitte dringend melden!!!

    Danke im Voraus.
    Mfg
    Uwe B.
    Zitieren Zitieren Probleme TwinCat-Installation  

  10. #10
    Registriert seit
    29.09.2006
    Beiträge
    368
    Danke
    0
    Erhielt 41 Danke für 38 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Bjoern,

    welche Dll'en hast Du denn angemerkt oder kennst die Namen durch den Touchpad Install?

    Viele Grüsse

Ähnliche Themen

  1. Installation TwinCat
    Von blackhack im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 24.08.2010, 13:47
  2. Installation von TwinCAT unter Win7
    Von jensi-7910 im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 01.12.2009, 20:29
  3. TwinCAT 2.11 Installation
    Von TheBuzz im Forum CODESYS und IEC61131
    Antworten: 5
    Letzter Beitrag: 26.11.2009, 10:50
  4. Antworten: 4
    Letzter Beitrag: 03.11.2009, 14:05
  5. TwinCat 2.10 Build 1340
    Von Byteverdreher im Forum CODESYS und IEC61131
    Antworten: 5
    Letzter Beitrag: 21.09.2009, 09:23

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •