Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: B+R PT100 Eigenerwärmung reduzieren

  1. #1
    Registriert seit
    25.09.2011
    Beiträge
    53
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo, ich habe in einer Anlage ca ~18 PT100 (2-Leiter) eingebaut. Nun vermute ich eine doch recht hohe Eigenerwärmung durch die Strom. An einem Edelstahlrohr gab der PT einen Wert von ~40°C an. Gefüllt war das Rohr aber deutlich kälter.

    3 oder besser noch 4 Leiter PT100 kann ich nicht einbauen. Nun gibt es eine möglichkeit, den PT100 immer nach xxx ms auslesen zulassen, sodass er nicht dauerhaft stromgeführt ist. Nun bin ich mir bei der Automation Studio nicht 100% sicher, den richtigen Punkt gefunden zu haben.

    Physical View -> X20AT4222 -> Open I/O Configuration

    Dort gibt es den Punkt Input Filter. Dieser ist Standard auf 20ms. Ich kann diesen auf max. 66,7ms anheben.

    Liege ich hier auf dem richtigen Weg? Für den Prozess sind die Messwerte in der Genauigkeit nicht Systemrelevant. Jedoch kam es mir vor, dass dieser eine Temperaturdifferenz von ca 10°C aufwies.
    Zitieren Zitieren B+R PT100 Eigenerwärmung reduzieren  

  2. #2
    Registriert seit
    03.09.2007
    Ort
    Saarland
    Beiträge
    79
    Danke
    4
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Hi, du liegst nicht auf dem richtigen Weg.

    Die Filterzeit hat nichts damit zu tun in welchen Zeitabständen die Fühler eingelesen werden. Diese ist zum Entstören der Eingänge gedacht. Ähnl. Entprellen bei Tastern.


    Allerdings ist mir im Moment auch etwas unklar warum sich die PT100 erwärmen sollen durch den Strom???

    Die Dinger machen eine ganz normale Widerstandsmessung. Wenn als alles richtig angeschlossen und verkabelt ist dürfen sich die Fühler nicht erwärmen!

    Wie lang ist denn das Kabel von Eingangskarte zu den einzelnen Fühlern?
    Sind Klemmen zwischen Eingangskarte und Fühlern wo etwas falsch angeschlossen werden könnte?
    Was bekommst du für Temperaturwerte, wenn du mal einen Fühler direkt ohne Zwischenklemmen auf die Karte klemmst? Sind diese Werte plausibel?
    Tritt der Effekt nur bei einem Fühler auf oder bei allen?

  3. #3
    Registriert seit
    24.02.2009
    Beiträge
    1.244
    Danke
    23
    Erhielt 276 Danke für 235 Beiträge

    Standard

    Bei PT100 ist es im 2 Leiterbetrieb sehr sehr wichtig den Leitungswiderstand zu kompensieren. Durch den recht schmalen Widerstandsbereich (40 Ohm zw. 0°C und 100°C) können schon 2-3 Ohm einen großen Unterschied machen.
    Ich verwende daher lieber Ni1000 Fühler, bei denen kann man die Leitungswiderstand in den Skat drücken.

    PT100 Messklemmen sollte idR schon von sich aus nur einen sehr kleinen Strom durch die Fühler schicken.

  4. #4
    Registriert seit
    25.09.2011
    Beiträge
    53
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    @MasterOhh: NI1000 Fühler kann ich aufgrund der steileren Kennlinie nicht mit dem Modul auswerten auf direktem Wege. Die Baugruppen sind für PT100/1000 sowie reinen Wiederstandsmessung ausgelegt. Somit müsste ich für jeden Temperatursensor eine Skalierung ähnlich mit dem AI und AO machen. Das eher kontraproduktiv in meinem Fall.

    @Hardy: Die Zuleitung der PT100 ist 3m lang mit je 2x0,14mm² Leitung. Die Enden sind direkt auf die Klemmen der Steuerungaufgelegt. Die Fühler kommen von Greisinger, wenn ich es bei denen richtig sehe, handelt es sich immer um 4-Leiter, die aber von Werk aus auch als 2-Leiter angeboten werden, bei denen die entsprechenden Paare zusammengefügt werden. Könnte somit morgen mal testweise den Fühler umschalten auf 3-Leiter.

  5. #5
    Registriert seit
    11.07.2004
    Beiträge
    1.597
    Danke
    10
    Erhielt 213 Danke für 183 Beiträge

    Standard

    Eigenerwärmung bei einem Luftfühler mag ja noch sein, nicht aber an einem Fühler an einem Edelstahlrohr. Würde auch mal auf Probleme mit dem Widerstand der Leitung ausgehen. Eine Vergleichsmessung und dann einen passenden Offset in der Software drauf und fertig.

  6. #6
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Zitat Zitat von Oberchefe Beitrag anzeigen
    ...und dann einen passenden Offset in der Software drauf und fertig.
    Und der ist über den benutzten Messbereich immer gleich? Und wenn mal einer den Messfühler wechseln muß, ist der Offset dann immer noch gleich?

  7. #7
    Registriert seit
    03.09.2007
    Ort
    Saarland
    Beiträge
    79
    Danke
    4
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Für den Offset könnte man eine kleine Kalibrierfunktion ins Programm einbauen. Das hab ich auch schon öfters gemacht.

    Was allerdings immer noch nicht beantwortet ist, ob es alle Fühler betrifft oder wirklich nur den einen. Wenn es nur der eine ist könnte auch von einem Defekt ausgegangen werden.

    Wandert der "Fehler" mit, wenn du den Kanal an der Karte wechselst?

  8. #8
    Registriert seit
    22.10.2012
    Beiträge
    40
    Danke
    8
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Laut Datenblatt hat die AT4222 einen Messstrom von 250µA.
    Die Eingangsspannung wird mit max. 30V angegeben uns ist bei der Messung sicher niedriger.
    Aber selbst mit 30V und 250µA ergeben sich pro Fühler maximal 7,mW. Das dürfte bei einem PT100
    zu keiner nenneswerten Erwärmung führen.
    Datenblätter sind übrigens auf der B&R-Seite problemlos herunterzuladen.

  9. #9
    Registriert seit
    11.07.2004
    Beiträge
    1.597
    Danke
    10
    Erhielt 213 Danke für 183 Beiträge

    Standard

    Und der ist über den benutzten Messbereich immer gleich?
    die Kennlinie eines PT100 ist im üblicherweise benutzten Bereich linear, ein bestimmter Widerstand ergibt eine bestimmte Temperatur(-differenz). Solange das Kabel bei einem Ersatz die gleiche Länge und den gleichen Querschnitt hat ist auch von einem gleichen Widerstand sprich Temperaturverfälschung auszugehen. Der Offset ist eine gängige Maßnahme in der Praxis, manche machen das über einen HMI-Parameter. Besser ist natürlich die Verwendung von 3-/4-Leiter, nur unterstützen das nicht alle Eingangskarten.

  10. #10
    Registriert seit
    23.03.2006
    Ort
    Thüringen
    Beiträge
    2.005
    Danke
    162
    Erhielt 278 Danke für 199 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    also, wir brauchen eine genaue Messung, wie genau? Wenn richtig genau nimmt man kein 2 Leiter. Ansonsten 10 Grad Abweichung ist heftig und deutet auf ein grobes Problem hin. Ich bin mit meiner Eigenbaumessung zuhause genauer als mancher Fühler auf Arbeit, aber auch an den alten S5en haben wir mit PT100 Karten kaum 2 Grad Differenz. Ist für unseren Zweck ausreichend.
    Und, @Schneetreiber, im Prinzip richtig gerechnet, nur mit 30V auf das bißchen Chip in dem Fühler ->. Beschäftige Dich mal mit dem Meßprinzip überhaupt.

    Gruß
    Mario

Ähnliche Themen

  1. Beckhoff IPC Lüfterdrehtzahl reduzieren
    Von gloeru im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 03.03.2012, 20:39
  2. Antworten: 10
    Letzter Beitrag: 04.04.2010, 15:47
  3. Logo Programm reduzieren ? Aber wie ?
    Von X-Master im Forum Sonstige Steuerungen
    Antworten: 10
    Letzter Beitrag: 16.09.2007, 21:41
  4. Logo Programm reduzieren? wie ?
    Von X-Master im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 16.09.2007, 12:11
  5. Pt100
    Von Much2k im Forum Sonstige Steuerungen
    Antworten: 5
    Letzter Beitrag: 07.06.2006, 21:39

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •