Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Siemens LOGO! für Wasseraufbereitung?

  1. #1
    Registriert seit
    10.07.2013
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich bin neu hier im Forum, kurz zu mir: ich heiße Christian, bin 23, habe mit SPS Steuerungen bisher noch nie gearbeitet und bin keine gelernter Elektriker.

    Zur Zeit versuche ich eine Wasseraufbereitungsanlage zu automatisieren und wollte das eigentlich mit einer Siemens LOGO! verwirklichen.

    Viel zu automatisieren gibt es eigentlich nicht (bisher wird das mit ein paar Zeitrelais und einem Kabelsalat gemacht). Einige Sensoren (Druckschalter; Schwimmschalter; Entkalker) die nur Strom an/aus ausgeben steuern ein Magnetventil und eine Steckdose (Zeitversetzt) und dann noch einen weiteren zeitversetzt geprüften Sensor. Bis hierhin habe ich gedanklich kein Problem, sollte ja mit einer einfachen LOGO! machbar sein.

    Jetzt zur eigentlichen Frage: Die Maschine arbeitet mit Salzsole die von Hand an einem Drehrad eingestellt wird, die optimale Menge wird von einem Amperemeter abgelesen (ca. 30A). In der neuen Version soll das Handrad von einer Peristaltikpumpe abgelöst werden, diese kann ich entweder via Stromimpulse oder via 0-20 mA ansteuern. Der Amperemeter gibt Werte im mV bereich aus.
    --> also die mV Werte des Amperemeters in Impulse oder 0-20 mA umwandeln.

    Die Frage kann das eine Siemens LOGO! oder wäre hier eine andere SPS sinnvoller (bitte welche)?
    Wenn LOGO!, welche Version, bzw welche Eingänge und Ausgänge brauche ich für was?

    Recht herzlichen Dank schon mal im Voraus

    MFG CS
    Zitieren Zitieren Siemens LOGO! für Wasseraufbereitung?  

  2. #2
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.716
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard

    Die Logo ab 0BA6 kann standardmäßig Impulse z.B. über PWM ausgeben.
    Für eine 0-20mA Ausgabe würdest Du das Erweiterungsmodul AM2AQ benötigen. Also würde ich es erst mal mit den Impulsen versuchen.

    Problematisch sind die mV des Amperemeters. Die Logo kann direkt 0-10V als Eingang verarbeiten oder 0-20mA über das Erweiterungsmodul AM2. Allerdings dürfte das auf so ziemlich jede SPS zutreffen. Du wirst Dich also m.M.n. so oder so nach einem Wandler (Verstärker?) für dieses mV-Signal zu einem 0-10V oder alternativ 0/4-20mA Signal umsehen müssen. Oder ein anderes Amperemeter.

    Insgesamt ist die Logo sicher ausreichend. Und wahrscheinlich auch am preiswertesten, denn eigentlich solltest Du ohne Erweiterungsmodule mit der 24V-Version hinkommen:
    - 1 Analogeingang für das Amperemeter
    - 7 weitere Digitaleingänge für die anderen Sensoren (Druckschalter; Schwimmschalter; Entkalker ...)
    - 1 gepulsten Digitalausgang für die Pumpe
    - 1 Digitalausgang für das Magnetventil
    - 2 DA noch übrig

  3. #3
    Baron Samedi ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    10.07.2013
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo hucki,

    danke für die schnelle Antwort, leider bin ich bisher noch nicht zum Antworten gekommen.

    So in etwa habe ich mir das Vorgestellt, die Geschichte mit dem Amperemeter muss ich noch weiterverfolgen.
    Zur Zeit bin ich beruflich etwas stärker eingespannt, sodass das Projekt erst mal in den Hintergrund verschoben wird, es wird also etwas dauern bis ich (hoffentlich) etwas über die Erfolge berichten kann.

    MFG CS

  4. #4
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.716
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard

    Zitat Zitat von hucki Beitrag anzeigen
    Die Logo kann ... 0-20mA über das Erweiterungsmodul AM2.
    Das geht auch direkt ohne Erweiterungsmodul. Man benötigt nur einen 500Ohm-Widerstand mit (ich glaub', muss noch mal nachlesen - oder Harald fragen) 1/4 Watt.

    In den letzten Tagen wurde (ich meine von Harald -> PN/DP) dazu was gepostet, da könnte man auch noch mal suchen.

  5. #5
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.716
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hab' mal nachgeschaut, Harald gibt in seinem Post 0,5 Watt an:
    Zitat Zitat von PN/DP Beitrag anzeigen
    Schalte Deinem Analogeingang einen Widerstand 500 Ohm (0,5W) parallel, der "wandelt" 4...20mA --> 2...10VOder 100 Ohm (1/8W) --> 0,4...2,0V, wenn die Auflösung reicht und Du nicht soviel Wärme willst. Oder irgendeinen Wert dazwischen, dann ist die Umrechnung eben "krumm".
    Harald
    Zitat Zitat von PN/DP Beitrag anzeigen
    Code:
    +24V --+
           |
           |
       +---+---+
       |       |
       | 2-DMU |
       |       |
       |4..20mA|
       |       |
       +---+---+
           |
           |2..10V
           +------o AE+ (0-10V)
           |
           |
          +++
          | |
      500 | |
          | |
          +++
           |    0V
           |   +--o AE- (M)
           |   |
           |   |
      0V --+---+---
    Bei 4-DMU kommt der Sensor parallel zum Widerstand an AE+ und AE-

    Harald

Ähnliche Themen

  1. Testprogramm für Siemens Logo
    Von spesser im Forum Sonstige Steuerungen
    Antworten: 7
    Letzter Beitrag: 13.10.2011, 14:00
  2. Siemens LOGO!, Hilfe für Realisierung
    Von Highrider im Forum Sonstige Steuerungen
    Antworten: 14
    Letzter Beitrag: 17.04.2011, 14:06
  3. Visualisierungen für Siemens Logo
    Von bigboss007 im Forum HMI
    Antworten: 9
    Letzter Beitrag: 28.03.2008, 18:33
  4. Bezugsquelle für Siemens Logo
    Von Anonymous im Forum Sonstige Steuerungen
    Antworten: 4
    Letzter Beitrag: 14.06.2005, 21:48
  5. Temperatur Differenz steurung für Siemens logo
    Von Anonymous im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 20.01.2005, 14:50

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •