Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 21 bis 30 von 39

Thema: LOGO! Soft v7 - Hilfe für Programm

  1. #21
    Tobias Dasch ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.07.2013
    Beiträge
    12
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zwei Speicherzellen pro Eingang, aber was definiert man unter "Speicherzelle"?

  2. #22
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.713
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard

    Zitat Zitat von Tobias Dasch Beitrag anzeigen
    Zwei Speicherzellen pro Eingang, aber was definiert man unter "Speicherzelle"?
    Zitat Zitat von hucki Beitrag anzeigen
    Ihr habt selbst schon 'raus gefunden, dass der Speicher immer zurückgesetzt werden soll, wenn der Ausgang aus ist und nur unter bestimmten Bedingungen eingeschaltet werden darf.
    Daraus entsteht folgende grundlegende Speicherzelle (I1 ist der jeweilige Eingang, I2 simuliert die Bedingung für's Setzen):



    Nächster Step:
    Zitat Zitat von hucki Beitrag anzeigen
    2. Es müssen für jeden Eingang immer 2 Sachen gespeichert werden:
    -> 1. Ist der Eingang unter den ersten 3, damit der Ausgang als Nächstes zum Einschalten dran ist
    -> 2. Ist der Eingang unter den ersten 2, die eingeschaltet wurden, damit der Ausgang eingeschaltet wird
    Sind schon 3 Eingänge aktiv, kommt das Eingangssignal nicht zum ersten Speicher. Hat es diesen Speicher passiert, kann es den nächsten nur erreichen, wenn keine 2 Ausgänge aktiv sind.
    Der Eingang muss also beide Speicher nacheinander passieren, damit der Ausgang eingeschaltet wird.


    Man kann das Rücksetzen von B004 auch direkt mit dem Eingang verbinden. Kommt aber auf's gleiche Ergebnis raus.

  3. Folgender Benutzer sagt Danke zu hucki für den nützlichen Beitrag:

    Tobias Dasch (29.07.2013)

  4. #23
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.713
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard

    Schau mir gerade mal Euren Schaltplan an.

    Jetzt habt Ihr's mit dem getrennt verlegen übertrieben. Wenn Verbindungen auf den gleichen Ausgang gehen, dann dürfen und sollen sie sich sogar überlagern. Die "Weiche" ist ja an dem Verbindungspunkt zu erkennen.

  5. #24
    Tobias Dasch ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.07.2013
    Beiträge
    12
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wir haben es schon so ausprobiert, jedoch verändert sich die Funktion nicht zum vorherigen, soweit wir das überblicken.
    Schaltplan1.zip

  6. #25
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.713
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard

    So seit ihr wirklich sehr nah' dran. Da fehlt Euch jetzt einfach die Erfahrung, wo man etwas drehen muss.
    Deshalb werd' ich jetzt meine Version komplett posten (bin dann unterwegs):




    PS: Irgendwie reagiert Euer Eingangszähler anders wie meiner. Komm' ich aber erst heut' abend zu, zu ergründen warum.
    Angehängte Dateien Angehängte Dateien
    Geändert von hucki (29.07.2013 um 10:08 Uhr) Grund: aktuelleres Bild

  7. Folgender Benutzer sagt Danke zu hucki für den nützlichen Beitrag:

    Tobias Dasch (29.07.2013)

  8. #26
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.713
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard

    Zitat Zitat von hucki Beitrag anzeigen
    PS: Irgendwie reagiert Euer Eingangszähler anders wie meiner.
    Ihr habt die arithmetische Anweisung vor den Analog-Mux erstellt, die diese zusammenrechnen soll. Deshalb habt' ihr da eine Zyklusverschiebung zwischen Erfassung und Ergebnisausgabe drin, was hier bei der Funktion von Nachteil ist.


    Anschließend fehlt bei Euch auf jeden Fall noch Punkt 7.
    In der Druckvorschau hab' ich dabei auf die 2. Variante umgestellt (B024). Das spart ein paar Bausteine.

  9. #27
    Tobias Dasch ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.07.2013
    Beiträge
    12
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Okay, wir mussten es nochmal komplett neu aufbauen, also die MUX vor den Anweisungen aufgebaut, dann hat es funktioniert.
    Wir werden jetzt eine Doku darüber schreiben, damit wir für die nächsten Schaltungen alles gleich besser nachvollziehen können.

    Du warst uns eine große Hilfe, schön wenn jemand sein Wissen weiter gibt!

  10. #28
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.713
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard

    Die Schaltung hat aber immer noch Probleme, wenn mehrere Schalter auf einmal betätigt werden.
    Wenn man normal simuliert, bemerkt man das nicht. Bei der Simulation einzelner Zyklen hat man aber genug Zeit, mehrere Schalter dazwischen zu betätigen. Man kann natürlich auch da noch etwas vorbeugen, trotzdem kommt man da ziemlich an die Grenzen der Logo!, weil man eben keine echten Bytespeicher und die Rechenmöglichkeiten damit wie bei den großen SPS hat.

    Ihr habt Euch also da eine wirklich knifflige Aufgabe ausgesucht.

  11. #29
    Tobias Dasch ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.07.2013
    Beiträge
    12
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich hätte dann doch noch einmal eine Frage.
    Bei deiner Schaltung in der Druckoptimierten Version unter der Überschrift: "Zählung und Auswertung aktiver Eingänge" geht ein zweiter Strang von der arithmetischen Anweisung aus, welche auf einen weiteren Schwellwertschalter und ein Selbsthalterelais geht. Diese Verbindung hat eigentlich immer High-Signal, deswegen verstehen wir den nutzen davon nicht. Wenn man diese zwei Bausteine löscht, sowie das UND-Gatter B027, verändert sich auch nichts an der Funktion soweit wir das überblicken.

    mfg Tobi

  12. #30
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.713
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Tobias Dasch Beitrag anzeigen
    Wenn man diese zwei Bausteine löscht, sowie das UND-Gatter B027, verändert sich auch nichts an der Funktion soweit wir das überblicken.
    Doch -> schaltet mal 3 oder 4 Eingänge ein, bevor Ihr die Simulation startet!

    Sehet und analysiert (und lest nochmal den Punkt 9).




    PS: Das UND-Gatter B027 hab' ich nur eingefügt, damit ich den Freigabe-Strang besser zeichnen kann. Eigentlich wären auf den UND-Gattern B001, B005 ... noch Eingänge frei gewesen, um von B025 da direkt d'rauf zu gehen.
    Geändert von hucki (30.07.2013 um 15:27 Uhr) Grund: Quote & PS

Ähnliche Themen

  1. Suche Hilfe für kleines Step5 Programm
    Von Poikl9 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 17.02.2012, 14:52
  2. LOGO Soft
    Von visu90 im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 26.09.2011, 11:19
  3. Suche LOGO!Soft V2.1
    Von Halifax im Forum Suche - Biete
    Antworten: 4
    Letzter Beitrag: 08.07.2010, 15:51
  4. LOGO!Soft V6.0
    Von kunigunde3447 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 30.11.2008, 18:41
  5. Hilfe zu Steuerung mit Logo Soft Comfort
    Von Kintap im Forum Sonstige Steuerungen
    Antworten: 2
    Letzter Beitrag: 10.02.2008, 02:15

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •