Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Schutz vor zu großem Strom auf I/O-Module

  1. #1
    Registriert seit
    12.07.2014
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Liebe SPS-Forum Gemeinde,

    ich bin gerade dabei eine ABB AC700F SPS zu programmieren und in Betrieb zu nehmen.
    Auf die digitalen Eingänge habe ich ohne Vorwiderstand Schalter geklemmt.

    Jetzt habe ich folgende Messungen vorgenommen:

    Der Widerstand des Schalters und der Drahtes liegt etwa bei 2 Ohm.
    Die Ausgangsspannung an den Klemmen liegt bei etwa 14 Volt.

    Rein rechnerisch müsste ich jetzt auf 7 Ampere kommen, die über den Ausgang laufen.

    Das Datenblatt sagt mir nun, dass maximal 8 milliAmpere fließen.

    Und jetzt komme ich auch zu meiner Frage:
    Wie ist diese Begrenzung des Stroms möglich?

    Ich habe eine Klemmspannung von 14 Volt. Also müssen diese 14 Volt auch an dem Schalter und Leiter abfallen??


    Eine ausführliche Internetrecherche hat leider nichts gebracht.
    Ich hoffe ihr habt für mich eine Antwort parat.
    Ein Schaltplan wäre auch nicht schlecht.


    Ich bedanke mich bereits im Vorraus bei euch!


    Mit freundlichen Grüßen,
    Svenfie
    Zitieren Zitieren Schutz vor zu großem Strom auf I/O-Module  

  2. #2
    Registriert seit
    24.02.2009
    Beiträge
    1.244
    Danke
    23
    Erhielt 276 Danke für 235 Beiträge

    Standard

    Digitaleingänge sind idR hochohmig. Eingangswiderstände liegen je nach Hersteller und Klemmentyp zw. 10kOhm bis >100kOhm.

  3. #3
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.288
    Danke
    932
    Erhielt 3.320 Danke für 2.682 Beiträge

    Standard

    Zitat Zitat von Svenfie Beitrag anzeigen
    Auf die digitalen Eingänge habe ich ohne Vorwiderstand Schalter geklemmt.
    Das ist OK so.
    Wie hoch ist die Spannung vor dem Schalter? Die sollte normal +24VDC sein.
    Der Minus (0V) von den 24VDC ist mit den Masse-Klemmen (ZP) des Eingangsmoduls verbunden?

    Der Widerstand des Schalters und der Drahtes liegt etwa bei 2 Ohm.
    Nicht besonders gut, geht aber noch.

    Die Ausgangsspannung an den Klemmen liegt bei etwa 14 Volt.
    Was meinst Du mit "Ausgangsspannung"? An welchen Klemmen?
    Kommt Spannung aus den Digitaleingängen heraus, wenn die Schalter nicht geschlossen sind???

    Rein rechnerisch müsste ich jetzt auf 7 Ampere kommen, die über den Ausgang laufen.
    Was meinst Du mit "Ausgang"?
    Wie rechnest Du?
    Über den geschlossenen Schalter und den Draht fallen 14V ab?

    Das Datenblatt sagt mir nun, dass maximal 8 milliAmpere fließen.
    genauer: 5mA bei 24V, 8mA bei 30V

    Und jetzt komme ich auch zu meiner Frage:
    Wie ist diese Begrenzung des Stroms möglich?
    Der Digitaleingang hat bei 24V einen Widerstand von ca. 4,8 kOhm (besteht im wesentlichen aus Vorwiderstand und einer LED in einem Optokoppler).

    Ich habe eine Klemmspannung von 14 Volt. Also müssen diese 14 Volt auch an dem Schalter und Leiter abfallen??
    Nein, die sollen an dem Digitaleingang abfallen - und zwar mindestens 15V für 1-Signal. Über Schalter und Leiter sollen möglichst 0V abfallen wenn der Schalter geschlossen ist. Bei offenem Schalter muß die gesamte Betriebsspannung über dem Schalter zu messen sein.
    Was meinst Du mit "Klemmspannung"?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  4. #4
    Svenfie ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.07.2014
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    danke für eure schnellen Antworten.

    Ich habe mal mein "Problem" aufgezeichnet. Hoffentlich kann man noch alles lesen.

    Wenn ich also 14V zwischen dem DI und ZP habe ergibt sich ja folgende Rechnung: I=14V/3Ohm=4,6A

    Wieso laufen aber maximal diese 5 bzw. 8 mA über den Schalter?


    cambild-1405204546.jpg

  5. #5
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.288
    Danke
    932
    Erhielt 3.320 Danke für 2.682 Beiträge

    Standard

    Ich habe jetzt nicht die Beschaltung des Eingangsmoduls hier, doch ich meine, ZP ist ein Minus-Anschluß. Der Schalter muß nach Plus (24V) geschaltet werden, ich meine, der Plus-Anschluß heißt UP.

    Deine Berechnung passt nicht, weil wenn Du die 3 Ohm vom DI nach ZP anschliesst, dann brechen die 14V auf nahezu 0V zusammen.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  6. #6
    Registriert seit
    13.01.2013
    Beiträge
    632
    Danke
    26
    Erhielt 65 Danke für 60 Beiträge

    Standard

    Aufgrund der internen Schaltung in deinem IO Modul fließt nur ein bestimmter Strom und alles ist ok. Vergleiche das mal mit einer einfachen Glühbirne. Wenn du das Licht einschaltest fließen auch keine 200A sondern nur der Strom deines Verbrauchers. Und in deinem Fall ist nicht der Schalter der Verbraucher (siehe Glühlampe) sondern das Modul.

  7. #7
    Registriert seit
    14.05.2014
    Beiträge
    74
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich bin leider zu blind als dass ich auf dem Bild viel erkennen könnte aber eins ist klar:

    Deine Schaltung kann nicht stimmen - was ja meine Vorredner auch schon sagten.


    Generell müssen Eingänge gegen Überspannung und Ausgänge gegen Überstrom geschützt werden.

    Ersteres erreicht man, indem man durch korrekte Verdrahtung immer nur die zulässige Signalspannung an die Eingänge weitergibt, letzteres durch ausreichend hochohmige Verbraucher bzw. Zwischenbaugruppen oder durch Sicherungen.

    In vielen Fällen ist es jedoch so, dass Eingänge bis zu 500V Spannungsfest sind und Ausgänge Kurzschlussfest bzw. mit eingebauter Strombegrenzung.

  8. #8
    Svenfie ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.07.2014
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    langsam wird es für mich verständlicher..


    Aber wenn ich mit dir Digitaleingänge der SPS als Spannungsquelle vorstelle mit in diesem Fall 14V, warum "bricht" dann die Spannung auf ca. 0V zusammen, wenn ich eine Brücke auf den Eingang klemme?
    Wie ist da die interne Verschaltung? Hat da jemand einen Schaltplan von oder ein Stichwort nach dem man im Internet schauen könnte?

    Nochmals danke für eure tatkräftige Hilfe

  9. #9
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.288
    Danke
    932
    Erhielt 3.320 Danke für 2.682 Beiträge

    Standard

    Ein Digitaleingang ist keine Spannungsquelle sondern ein Verbraucher/eine Last.
    Ich kann mir nur schwer vorstellen, daß da tatsächlich 14V 'rauskommen sollen. Da müßte ABB eine sehr unübliche Eingangsbeschaltung intern im Modul verwenden. Oder ist das ein Eingang, der auch als Ausgang konfiguriert werden kann? Welches E/A-Modul genau verwendest Du?

    Wie misst Du? Hast Du korrekt die Spannungsversorgung am E/A-Modul angeschlossen: +24V an UP und 0V an ZP? Misst Du vom Digitaleingang gegen 0V der Spannungsversorgung?

    Ich kenne die S700 I/O Module nicht, als Schaltplan kenne ich nur die Verdrahtungsbilder aus dem Freelance Produktkatalog. Keine Ahnung, ob es von ABB detailliertere Dokumente gibt. Vielleicht findet man was, wenn man nach der genauen Modulbezeichnung sucht.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  10. #10
    Registriert seit
    14.05.2014
    Beiträge
    74
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Mit den 14V hört sich fast so an wie ein PNP Ausgang in Low, den man dann auf Masse zieht und schon hat man 0V.

Ähnliche Themen

  1. Ex-Schutz, Angabe UEG bezogen auf was?
    Von jora im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 1
    Letzter Beitrag: 24.01.2014, 21:39
  2. Virenschutzprogramm als Schutz vor der NSA
    Von rostiger Nagel im Forum Stammtisch
    Antworten: 10
    Letzter Beitrag: 26.11.2013, 17:53
  3. Antworten: 2
    Letzter Beitrag: 19.11.2011, 22:12
  4. Nothalt-Taster Schutz vor Wasser
    Von unwissender22 im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 1
    Letzter Beitrag: 19.03.2010, 11:49
  5. Schutz vor unberechtigten Zugriff auf das Programm
    Von B-K im Forum Sonstige Steuerungen
    Antworten: 0
    Letzter Beitrag: 02.08.2008, 13:20

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •