Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 4 von 4 ErsteErste ... 234
Ergebnis 31 bis 35 von 35

Thema: CoDeSys

  1. #31
    Registriert seit
    13.01.2005
    Ort
    Allgäu
    Beiträge
    146
    Danke
    4
    Erhielt 23 Danke für 18 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    bei älteren Wago's war es zwingend erforderlich die Analogmodule an erster Stelle zu setzen.

    Gruß
    M_o_t

  2. #32
    Registriert seit
    09.06.2005
    Beiträge
    25
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hab ich auch schon probiert, leider erfolglos. Aber ich habe Hoffnung! Es kann sein das es weder an Beckhoff noch an CoDeSys liegt!

    Ich hab jetzt eine Fehlermeldung entdeckt die auf EXOR hinweist. Kurz darauf habe ich bei dennen angerufen, dass scheinbar was mit der EXOR.CAN Libary nicht stimmt.
    Diese haben mir mitgeteilt das Sie einen ähnlichen, funktionstüchtigen Testaufbau mit einer BK5120 besitzen und meine Konfiguration überprüfen wollen. Mal sehen was da rauskommt.

  3. #33
    Registriert seit
    09.06.2005
    Beiträge
    25
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    So ... Problem gelöst! Es lag an dem EXOR modul ... man muste nicht nur die Steuerungskonfiguration durchführen (modul + Beckhoff *.eds einfügen) sondern auch aus einer implementierten Libary einen Funktionsbaustein aufrufen. Dannach funktionierte der CANbus bzw. die Klemmen sauber. Very Happy

  4. #34
    Registriert seit
    09.06.2005
    Beiträge
    25
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Problem doch nur zur Hälfte gelöst! ... Komischer weise funktioniert alles einwandfrei, wenn ich die fertige Projektdatei bzw. die darin enthaltene Steuerungskonfiguration für mich abwandle. Und das OHNE den oben beschriebenen Funktionsbaustein zu starten.

    Erstelle ich ein komplett neues Projekt und konfiguriere/parametriere die Steuerung "gleich", dann gehen die BK5120 in den Pre-Operationalmodus. Sprich es können nur SDO's, aber keine gemappten PDO's, gesendet und empfangen werden.
    Sende ich jetzt einen Node_Start an die BK5120, geht dieser in den Operationalmodus und es funktionieren zwar die digitalen Eingänge halbwegs, aber an den Analogen tut sich komischerweise nix (Obwohl im OBID 6423 ein TRUE steht = Aktiviert das ereignisgesteuerte Senden von PDOs mit Analogeingängen.)!

    Falls mir irgendjemand sagen kann, welche Objekt-ID's von der Defaultkonfiguration in der BK5120.eds verändert werden müssen, dann wäre das fein.

    In meiner Konfiguration handelt es sich um einen BK5120 Firmware C5, 2* 4 digitale E., 1*2 digitale E, 1*4 digitale Ausgänge, 1*1 analogen Eingang. Diese hängen an einem SCM03C Modul von Exor welches mit CoDeSys programmiert/konfiguriert wird.

  5. #35
    Registriert seit
    24.10.2003
    Ort
    Zug, Schweiz
    Beiträge
    73
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Jenser

    Gibts da mit dem CAN Koppler BK5120 und Anlaog etwas neues?
    Welchen Baustein aus der CAN Library musste aufgerufen werden?

    Meine Konfig ist folgende:
    XV200 mit codesys und BK5120 CANknoten mit Digital und Analog KLemmen.
    Auch ich habe gleiche Probleme. Digital KLemmen funktionieren Analoge nicht.

    Integer

Ähnliche Themen

  1. CoDeSys
    Von doug82 im Forum PC- und Netzwerktechnik
    Antworten: 6
    Letzter Beitrag: 02.11.2011, 21:29
  2. EoE mit CoDeSys 3.4 sp3
    Von HomerX im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 07.06.2011, 10:54
  3. CodeSys
    Von Mark4you im Forum Suche - Biete
    Antworten: 6
    Letzter Beitrag: 01.02.2011, 10:28
  4. CodeSys und S7
    Von Tommi im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 19.12.2010, 20:32
  5. CoDeSys
    Von Gast im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 16.06.2006, 21:35

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •