Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: LOGO Digitalsignal im Logo-Display anzeigen

  1. #1
    Registriert seit
    13.03.2007
    Ort
    Nürnberg
    Beiträge
    563
    Danke
    56
    Erhielt 51 Danke für 46 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    jetzt hab ich mal etwas mit der Logo-Simulation gespielt.

    Aber ich habe noch nicht herausgefunden wie man ein Digitalsignal im Logo-Display anzeigen kann.

    ich habe ein FlipFlop mit den Cursortasten verschaltet.
    die "Meldebox" nimmt jedoch nur Analogwerte als Parameter.
    Wie kann ich also z.B.
    - wenn FF-Q = Low : "Meldung: Handbetrieb"
    - wenn FF-Q = High : "Meldung: Automatikbetrieb"
    ausgeben ?

    gruss,
    Logo-Anfänger
    Kabelsalat ist Gesund
    (vom CCC abgekupfert)

    Prognosen sind schwierig,
    besonders wenn sie die Zukunft betreffen.
    (Ursprung nicht wirklich bekannt)


    Zitieren Zitieren LOGO Digitalsignal im Logo-Display anzeigen  

  2. #2
    Registriert seit
    05.07.2012
    Ort
    Niedersachsen
    Beiträge
    72
    Danke
    7
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Hi,

    hast Du mal ein Beispiel?

    Programm oder Bild um einmal zu sehen wo der Fehler liegt.


    Gruss

    piksieben

  3. #3
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard

    Zitat Zitat von Senator42 Beitrag anzeigen
    ich habe ein FlipFlop mit den Cursortasten verschaltet.
    die "Meldebox" nimmt jedoch nur Analogwerte als Parameter.
    Wie kann ich also z.B.
    - wenn FF-Q = Low : "Meldung: Handbetrieb"
    - wenn FF-Q = High : "Meldung: Automatikbetrieb"
    ausgeben ?
    Über dem Display im Meldetext gibt es eine Taste On/Off. Damit können digitale Zustände angezeigt werden, vorausgesetzt die neuen Funktionen wurden in den Meldetexteigenschaften unter dem Menüpunkt Datei aktiviert.
    Allerdings kannst Du je Zustand nur maximal 8 Buchstaben eingeben. Brauchst Du mehr, musst Du ggf. mehrmals den gleichen Zustand zur Anzeige auswählen.
    Je Meldetext können max. 4 solcher Zustände angezeigt werden.

  4. #4
    Registriert seit
    13.03.2007
    Ort
    Nürnberg
    Beiträge
    563
    Danke
    56
    Erhielt 51 Danke für 46 Beiträge

    Standard

    Kabelsalat ist Gesund
    (vom CCC abgekupfert)

    Prognosen sind schwierig,
    besonders wenn sie die Zukunft betreffen.
    (Ursprung nicht wirklich bekannt)



  5. #5
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard

    Zitat Zitat von hucki Beitrag anzeigen
    vorausgesetzt die neuen Funktionen wurden in den Meldetexteigenschaften unter dem Menüpunkt Datei aktiviert.
    Diesen Hinweis beachtet?
    Und welche LOGO!-Version hast Du überhaupt ausgewählt?

    PS: Bin nur am Handy und kann deshalb nicht in Dein Programm schauen.
    Geändert von hucki (17.12.2014 um 19:34 Uhr) Grund: Handy-Umlaute ausgebessert

  6. #6
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    nimm 2 Meldetexte.
    priorität ist mal egal

    Meldetext 1 - wenn FF-Q = Low : "Meldung: Handbetrieb"
    Meldetext 2 - wenn FF-Q = High : "Meldung: Automatikbetrieb"

  7. #7
    Registriert seit
    13.03.2007
    Ort
    Nürnberg
    Beiträge
    563
    Danke
    56
    Erhielt 51 Danke für 46 Beiträge

    Standard

    danke hucki + verpolt, beide varianten funktionieren jetzt.
    V 7,1,5
    Kabelsalat ist Gesund
    (vom CCC abgekupfert)

    Prognosen sind schwierig,
    besonders wenn sie die Zukunft betreffen.
    (Ursprung nicht wirklich bekannt)



  8. #8
    Registriert seit
    13.03.2007
    Ort
    Nürnberg
    Beiträge
    563
    Danke
    56
    Erhielt 51 Danke für 46 Beiträge

    Standard

    Hi,
    habe noch weitere Fragen.

    Nun habe ich auch das Logo-Kabel, eine BA4 (12/24RC 6 In 4 Out) und eine BA2 (12/24RCL 12 In 8 Out)

    Frage 1: die 12/24RC läuft mit 18,4 V DC, die 12/24RCL nur manchmal, mit 27V aber immer. Normal ?

    Frage 2: die BA4 kann das mit den oben genannten Meldungen, die BA2 wohl nicht (also das mir den "erweiterten ..") ?

    Frage 3: bei der BA4 kann zu jeder Zeit das Proggi vom PC zur Logo übertragen, bei der BA2 muss man immer mit den Cursortasten+OK in den PC/Card mode wechseln. Ist das ein altes un-userbility Design ?

    Frage 4: gibt es eine Logo mit Display 12 DC 24V in, 8 Relais-Out in BA4 Variante ? (also nicht in BA2)

    Frage 5: Das Verwenden der Cursotasten als Eingänge funktioniert zwar an der BA4, aber nicht wirklich trivial.
    Will heißen: mal geht (zusammen mit ESC), mal nicht.
    Oder kann man das einstellen, daß die Cursortasten IMMER und ohne ESC funktionieren ?

    [ Logo soft 7.1.5 ]

    gruss
    senator
    Kabelsalat ist Gesund
    (vom CCC abgekupfert)

    Prognosen sind schwierig,
    besonders wenn sie die Zukunft betreffen.
    (Ursprung nicht wirklich bekannt)



  9. #9
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard

    Zitat Zitat von Senator42 Beitrag anzeigen
    Frage 2: die BA4 kann das mit den oben genannten Meldungen, die BA2 wohl nicht (also das mir den "erweiterten ..") ?

    Frage 3: bei der BA4 kann zu jeder Zeit das Proggi vom PC zur Logo übertragen, bei der BA2 muss man immer mit den Cursortasten+OK in den PC/Card mode wechseln. Ist das ein altes un-userbility Design ?
    Aktuelle PC's können auch mehr und sind dabei userfreundlicher als einer von vor 10 Jahren!




    Zitat Zitat von Senator42 Beitrag anzeigen
    Frage 4: gibt es eine Logo mit Display 12 DC 24V in, 8 Relais-Out in BA4 Variante ? (also nicht in BA2)
    Keine Ahnung.
    Aber hältst Du es nicht auch für sinnvoller, sich wenn schon dann eine aktuelle LOGO! der Version 0BA8 zu besorgen?



    Zitat Zitat von Senator42 Beitrag anzeigen
    Frage 5: Das Verwenden der Cursotasten als Eingänge funktioniert zwar an der BA4, aber nicht wirklich trivial.
    Will heißen: mal geht (zusammen mit ESC), mal nicht.
    Oder kann man das einstellen, daß die Cursortasten IMMER und ohne ESC funktionieren ?
    Nein, das Tastengedrücke ist auch bei der 0BA8 noch grausam.
    Allerdings kann man ab der 0BA7 auch andere HMI als das TD über das Ethernetkabel anschließen, die man mit WinCCflex bzw. TIA programmieren und dann sicher auch angenehmer bedienen kann. Am TD selber hat man auch noch die F-Tasten,mit denen sich auch besser bedienen lässt.

  10. #10
    Registriert seit
    13.03.2007
    Ort
    Nürnberg
    Beiträge
    563
    Danke
    56
    Erhielt 51 Danke für 46 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    A-Hoi,

    > Aber hältst Du es nicht auch für sinnvoller, sich wenn schon dann eine aktuelle LOGO! der Version 0BA8 zu besorgen?

    Hatte bisher mit S7 300 + 200 zu tun. (vor 20 jahren mit .. naja)

    Wollte in der Angebotsphase nur eruieren ob die Logo geeignet wäre.
    Die Anwendung ist zu simpel für ne 300, 200. (Kostenfrage).
    Mein Fazit:
    Logo geeignet,
    aber für den User braucht es Übliche Taster und Lämpchen.
    (weil: "das Tastengedrücke ist auch bei der 0BA8 noch grausam"; und das HEUTE )

    auf jeden Fall, danke für die Info.
    Kabelsalat ist Gesund
    (vom CCC abgekupfert)

    Prognosen sind schwierig,
    besonders wenn sie die Zukunft betreffen.
    (Ursprung nicht wirklich bekannt)



Ähnliche Themen

  1. Sonstiges Problem mit LOGO! TD Display
    Von SPS_NEU im Forum Simatic
    Antworten: 16
    Letzter Beitrag: 02.12.2014, 16:18
  2. Display für Logo
    Von söan im Forum Sonstige Steuerungen
    Antworten: 5
    Letzter Beitrag: 08.10.2011, 14:03
  3. Logo Display
    Von L.B. im Forum Sonstige Steuerungen
    Antworten: 6
    Letzter Beitrag: 16.02.2009, 07:21
  4. Logo: Werte im Display ändern?
    Von Simon im Forum Sonstige Steuerungen
    Antworten: 2
    Letzter Beitrag: 03.11.2005, 15:10
  5. Hintergrundbeleuchtung bei LOGO! Display
    Von Anonymous im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 28.05.2004, 08:28

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •