Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: B&R Sensor für einige Sekunden abfragen

  1. #1
    Registriert seit
    18.07.2016
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo alle Zusammen,

    ich und ein Schulkollege arbeiten derzeit auf dem Programm Automation Studio 4.2 und haben ein Problem mit der Abfrage von Sensoren. Unsere Frage: Wie ist es möglich, hier
    einen Sensore (Dunkelschaltende Lichtschranke) für z.B. 2s lang abzufragen und das in den Funktionsplan einzubauen ?

    Danke für die Hilfe im Vorraus
    Zitieren Zitieren B&R Sensor für einige Sekunden abfragen  

  2. #2
    Registriert seit
    13.09.2010
    Beiträge
    111
    Danke
    0
    Erhielt 17 Danke für 17 Beiträge

    Standard

    Hallo,

    die Lösung der Frage ist unabhängig vom Automatisierungssystem.
    Da eine SPS das Programm zyklisch abarbeitet und die IO zyklisch erneuert, muss man sich in jedem Zyklus der zwei Sekunden das Sensorsignal anschauen und darauf reagieren.
    Das kann in allen Sprachen geschehen.

    MfG

  3. #3
    Hammel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    18.07.2016
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für die rasche Antwort,

    wie meinst du das mit man muss sich in jedem Zyklus der zwei Sekunden das Sensorsignal anschauen und darauf reagieren ? Wie kann ich das in meinem FUP einbauen. Das heißt unser Aktor darf erst schalten nachdem das Signal am Sensor 2s anliegt. Ein Baustein oder eine Kombination wären eventuell hilfreich.

    MfG

  4. #4
    Registriert seit
    20.06.2016
    Beiträge
    26
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    Ich denke das die Programmierweise bei dir ähnlich wie bei anderen Programmen ist.

    Sobald der Sensor schaltet erhälst du in der Steuerung in der Regel ein "1" Signal.

    Dieses dann mit einem einschaltverzögerten Timer verzögern und an den gewünschten Aktor schreiben.

    Hoffe das hilft dir etwas weiter.

    Grüße

  5. #5
    Hammel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    18.07.2016
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für die Antwort,

    das mit der Einschaltverzögerung ist leider nicht möglich weil das Signal am Sensor wirklich min. 2s anliegen muss --> erst dann darf der Aktor betätigt werden. Ein einfaches 1 am Sensor genügt leider nicht.... Vl. kann mir trotzdem jemand weiterhelfen

    MfG

  6. #6
    Registriert seit
    20.06.2016
    Beiträge
    26
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wenn der Sensor diese 2 Sekunden benötigt, wie sieht denn die Logik aus, dass diese 2 Sekunden für den Sensor schaltet.

    Was genau sind die Bedingungen?

    Gruß

  7. #7
    Registriert seit
    27.07.2007
    Beiträge
    223
    Danke
    17
    Erhielt 42 Danke für 40 Beiträge

    Standard

    Falsche Antwort.
    Geändert von Hohlkörper (18.07.2016 um 12:05 Uhr)

  8. #8
    Hammel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    18.07.2016
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Der Sensor ist auf einem Förderband befestigt auf dem Teile nach und nach Vorbeitransportiert werden. Sobald die Teile nacheinander auf Staubetrieb gehen weil zu viele Teile vorne am Förderband anstehen sollte der Sensor schalten. Das heißt er darf nicht bei einer kurzen Betätigung schon schalten sondern erst am einer Schließung von 2s. Ist das Umfeld und die Bedingung klar ?

    MfG

  9. #9
    Registriert seit
    27.07.2007
    Beiträge
    223
    Danke
    17
    Erhielt 42 Danke für 40 Beiträge

    Standard

    Den Sensor auf den Eingang eines Timers als Einschaltverzögerung mit T#2s legen. Den Ausgang des Timers dann zum Abschalten verwenden.

  10. #10
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.251
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Aufgabe klar, aber was Du schreibst nicht.

    Das heißt er darf nicht bei einer kurzen Betätigung schon schalten sondern erst am einer Schließung von 2s.
    Der Sensor schaltet vermutlich immer bei "Teil da" - "Teil weg" und das sofort.
    Ich vermute nun, dass Du das in der Steuerung realisieren willst.

    Wo ist da nun das konkrete Problem.
    Sensor da (also LS unterbrochen) -> Einschaltverzögerung 2s -> wenn Einschaltverzögerung =1 dann Ausgang = 1 (oder 0)

Ähnliche Themen

  1. Raspberry Pi & DHT22 Sensor - Problem
    Von win2000 im Forum CODESYS und IEC61131
    Antworten: 5
    Letzter Beitrag: 05.04.2015, 19:06
  2. Sekunden in Tage,Stunden,Minuten,Sekunden
    Von tiego im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 14.09.2013, 22:19
  3. Antworten: 8
    Letzter Beitrag: 30.03.2011, 09:46
  4. Impuls für mehrere Sekunden wiederkehrend
    Von outbreak7 im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 06.05.2010, 15:07
  5. B&R Sensor einlesen
    Von Hannes im Forum Sonstige Steuerungen
    Antworten: 16
    Letzter Beitrag: 07.01.2009, 09:02

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •