Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: Allen-Bradley 1784-PKTX/B Kommunikationskarte-Probleme

  1. #1
    Registriert seit
    05.01.2016
    Ort
    NRW
    Beiträge
    9
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin zusammen,
    bei einem jetzigen Projekt welches wir übernommen haben von einer anderen Firma haben wir ein Kommunikattionsproblem.
    Wir kommunizieren mit einer Allen-Bradley PLC-5/30 über Remote I/O mit einem Windows Rechner. Dieser Rechner hat folgende Allen-Bradley Karte über PCI laufen:
    - Allen-Bradley 1784-PKTX/B. Die Karte kommt von 08/11.

    Der Rechner hat folgende Betriebsdaten:
    -win XP /32bit
    -3gb RAM
    -G45M03 Motherbourd
    -Intel Core DUo CPU E7400 @ 2,8GHZ

    Folgendes Problem:

    Die Karte kommunieziert nicht mehr mit der SPS. Die Kommunikationsleitung habe ich schon durchgemessen sowie die Endwiderstände überprüft. Die Anlage hat vor 8 Wochen noch einwandfrei gelaufen.
    Die Karte blinkt grün und der richtige Treiber ist auch installiert. Die Karte leuchtet wenn sie die Kommunikation hergestellt hat.
    folgende Fehlermeldungen kommt in unserer Software:

    plc err STS= 02
    plc error STS= 2, EXT STS=0, N69 -> keine Kommunikation vom Partner (in dem Fall die SPS)


    Hat jemand ne Ahnung wie man die Karte Überprüfen kann oder ob das an der SPS liegt. Es liegen leider keine Ersatzteile vor, da die SPS seit 2009 nicht mehr gibt.
    CimQues IN-Gear Studio4, mit dieser Software wird die Karte zugewiesen.



    Besten Dank schonmal
    Gruß
    Frank
    Remote IO.PNG
    Geändert von Brockevert (10.10.2017 um 11:40 Uhr)
    Zitieren Zitieren Allen-Bradley 1784-PKTX/B Kommunikationskarte-Probleme  

  2. #2
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.605
    Danke
    376
    Erhielt 798 Danke für 642 Beiträge

    Standard

    Welche Anwendersoftware kommuniziert ?
    Wie kommuniziert der Anwendersoftware ? OPC ? DDE ? Oder .. ?
    Verwendet ihr RSLinx ? Oder Treiber von 3-Anbieter ?

    edit: Ah, du hast ja geschrieben:
    CimQues IN-Gear Studio4, mit dieser Software wird die Karte zugewiesen.
    Jesper M. Pedersen

  3. #3
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.605
    Danke
    376
    Erhielt 798 Danke für 642 Beiträge

    Standard

    Ich wurde der Konfiguration in Ingear checken. Ich kenne es leider nicht.

    Ist der PLC5/30 der "Scanner" (sprich "master") ?
    In inden Fall, gibt es weitere RIO Unterstationen ?
    Und in den Fall, ist alles Grün auf der CPU und bei der Scanner Port ?
    Wenn ja, dann funktioniert der RIO Kommunikation, und das Problem liegt wahrscheinlich auf der PC.
    Jesper M. Pedersen

  4. #4
    Brockevert ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    05.01.2016
    Ort
    NRW
    Beiträge
    9
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von JesperMP Beitrag anzeigen
    Welche Anwendersoftware kommuniziert ?
    Wie kommuniziert der Anwendersoftware ? OPC ? DDE ? Oder .. ?
    Verwendet ihr RSLinx ? Oder Treiber von 3-Anbieter ?

    edit: Ah, du hast ja geschrieben:
    Visual Basic von 2007/2008.
    Ja RSLinx verwenden wir. ist auch noch die Original von damals drauf. Wir hatten auch schon nen neuen Treiber drauf, da hatte aber die Karte gar nicht mehr reagiert.
    Die Anwendersoftware kommunierziert über DDE.
    Ja die SPS PLC5/30 ist der Master und diese kommuniziert mit 2 Slaves. Diese Kommunikation läuft einwandfrei.
    Die Port B zu den Slaves leuchtet konstant und die von Port A blinkt genau wie die LED von der Allen-Bradley 1784-PKTX/B.

  5. #5
    Brockevert ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    05.01.2016
    Ort
    NRW
    Beiträge
    9
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Die Konfiguration in Ingear haben wird von von nem Backup übernehmen können. auch ein zurücksetzen auf einen älteren Stand hat nichts gebracht.

    Update:
    Die PCI Ports laufen einwandfrei. Habe nach dem Mittag die Software mehrmals geschlossen und wieder geöffnet. Nach dem dritten mal kam eine Fehlermeldung mit explorer Fenster:

    - S# 0
    S 79

    Die wurde bestätigt und jetzt läuft alles wieder. Wir haben keine konfiguration geändert und es läuft wieder mit dem alten alten Treiber über dem alten Wiederhestellungpunkt.
    Der Rechner wird auch immer nach jeder Übung runtergefahren und erst wieder bei einer neuen Übung wieder hochgefahren.

    Ich kann mir das so nicht erklären. Die Arbeit wird jetzt erst beendet und der Rechner wird am Donnerstag auf Herz und Nieren geprüft.

    Danke für deine Antwort, vllt fällt dir noch was ein.

  6. #6
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.605
    Danke
    376
    Erhielt 798 Danke für 642 Beiträge

    Standard

    Ich glaube es muss entweder RSLinx oder Ingear sein. Nicht beide auf einmal.
    RSLinx kann DDE. Ich kenne DDE nicht, aber ich nehme an das man soll ein DDE verbindung anlegen, wie man ein OPC Topic anlegt.
    Mit RSLinx kannst du das Karte testen, u z.B mit der "Who" Funktion testen ob RSLinx Teilnehmer sehen kann.
    Es wäre noch schöner mit OPC. Mit OPC kann man ein OPC test client verwenden um zu testen ob man die Variabeln sehen kann. Dies hilft um zu erkennen ob das Problem liegt in Anwenderprogram oder nicht. Ob etwas ähnliches gibts bei DDE weis ich nicht.
    Jesper M. Pedersen

  7. Folgender Benutzer sagt Danke zu JesperMP für den nützlichen Beitrag:

    Brockevert (13.10.2017)

  8. #7
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.605
    Danke
    376
    Erhielt 798 Danke für 642 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Du kannst eventuell in RSLinx den DDE/OPC Topic Configuration öffnen, und dort Bilder von die Einstellungen bei eventuell erstellte Topics aufnehmen und hier posten.
    Remote I/O ist veraltet und dazu auch etwas eigenartig. Es gibt eine Menge Youtube Videos über RSLinx Topic Configuration, aber keine über DDE und Remote IO. (Ich fand keiner auf die Schnelle).
    Jesper M. Pedersen

Ähnliche Themen

  1. [Biete] Allen Bradley 1784-U2DHP
    Von gub im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 28.08.2014, 09:28
  2. SLC500 DH+ 1784-KTX nach 1784-U2DHP
    Von S7-kub im Forum Sonstige Steuerungen
    Antworten: 3
    Letzter Beitrag: 10.07.2013, 12:46
  3. Allen Bradley?
    Von Flo im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 18.05.2010, 08:19
  4. Allen Bradley
    Von 00hausair im Forum Sonstige Steuerungen
    Antworten: 7
    Letzter Beitrag: 16.12.2005, 22:00
  5. Allen Bradley
    Von Anonymous im Forum Sonstige Steuerungen
    Antworten: 4
    Letzter Beitrag: 15.04.2005, 22:30

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •