Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: Probleme mit libnodave + Lubuntu +S7-200

  1. #1
    Registriert seit
    29.10.2013
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo allerseits,

    auch auf die Gefahr hin, das ich den Einen oder Anderen langweile: Aber ich hab ein Problem mit
    libnodave unter Linux.

    Zu meinem Projekt:
    Ich möchte mit einer S7-200 (CPU224XP) eine Haussteuerung realisieren. Damit
    ich auch über das Smartphone Funktionen steuern kann, hab ich einen Apache2 unter
    Lubuntu 13.10 mit Mysql und PHP5 laufen. Soweit funktioniert alles.

    Da PHP5, soweit ich weiß, nicht direkt auf libnodave zugreifen kann, dachte ich an einen Aufruf
    eines kleinen C-Programs.

    Dazu experimentiere ich mit einem Adapter 6ES7-972-0CA22-0XA0 und libnodave rum. Und das schon seit 2 Wochen.
    Ich hab libnodave 0.8.5 installiert und durchkompiliert. Der Adapter hängt an /dev/ttyS0 (eingestellt auf 38400 baud).
    (Unter W7 hab ich das Excel-Demo mit dem Adapter zum Laufen gebracht. Hardware schließ ich deswegen erstmal aus.)

    Prinzipiell ist es mir egal, ob ich PPI oder MPI nutze, aber ich krieg beides nicht zum Laufen.

    Mit "./testMPI --mpi=2 --local=1 -s --route --baud=38400 -9 /dev/ttyS0" bekomm ich "Couldn't connect to PLC."
    Dabei wundert mich, das er die "Partner" nicht findet. Es wird zumindest nichts aufgelistet.
    "daveListReachablePartners List length: 126"

    Mit "./testPPI -w /dev/ttyS0" erhalte ich nur einen Timeoutfehler (-1025) beim Connect.

    In einen Forenbeitrag hab ich gelesen #define LITTLEENDIAN und #define LINUX würde helfen.
    Leider Fehlanzeige.
    Auch #define DAVE_LITTLE_ENDIAN hilft nichts.

    Hab ich irgendeinen Denkfehler?
    Geändert von neumann63 (30.10.2013 um 15:27 Uhr) Grund: Nachtrag: Vergessen
    Zitieren Zitieren Probleme mit libnodave + Lubuntu +S7-200  

  2. #2
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Wenn es ne 200er ist, muß es testPPI sein.

    Was soll der Zoo von Optionen bei
    ./testMPI --mpi=2 --local=1 -s --route --baud=38400 -9 /dev/ttyS0 ?

    Soweit ich mich erinnere, ist die Standard-Baudrate bei 200ern erstmal 9600.
    Bei den 200ern war es wichtig, daß die DIP-Schalter an dem PPI-Adapter richtig stehen. Kann dir jetzt nicht sagen, wie.
    Wenn das Excel-Demo funktioniert, sollte die Hardware funktionieren, aber schau, welchen Pegel die RTS und DTR-Leitungen haben.

    Solange testPPI nicht geht, brauchst du weder eigene Programme noch Libnodave zu kompilieren.

  3. #3
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    634
    Erhielt 955 Danke für 769 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Mit dem Adapter funktioniert der Zugriff auf die S7-200 gar nicht. Laut Siemens:
    6ES7-972-0CA22-0XA0
    SIMATIC S7, PC ADAPTER V5 ZUM ANSCHLUSS AN S7-300/-400, C7, M7; FUER PC OHNE FREIEN STECKPLATZ; UMSETZUNG RS232 (19,2/38,4 KBIT/S) AUF RS485
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

Ähnliche Themen

  1. Probleme mit LibNoDave 8.4.4 und NetlinkUSB
    Von Jochen Kühner im Forum Simatic
    Antworten: 22
    Letzter Beitrag: 15.11.2012, 17:17
  2. libnodave - Probleme mit ListBlocksOfType
    Von Jochen Kühner im Forum Hochsprachen - OPC
    Antworten: 2
    Letzter Beitrag: 14.10.2010, 18:23
  3. Probleme mit Libnodave und Routing
    Von Thorsten Schier im Forum Hochsprachen - OPC
    Antworten: 17
    Letzter Beitrag: 10.08.2010, 13:34
  4. [ S7-200 ] libnodave mit CP 243-1
    Von caret im Forum Hochsprachen - OPC
    Antworten: 0
    Letzter Beitrag: 25.08.2007, 07:48
  5. Probleme mit LibNoDave 0.81
    Von Jochen Kühner im Forum HMI
    Antworten: 7
    Letzter Beitrag: 13.01.2006, 09:27

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •