Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 102 von 119 ErsteErste ... 25292100101102103104112 ... LetzteLetzte
Ergebnis 1.011 bis 1.020 von 1181

Thema: TIA Frust

  1. #1011
    Avatar von Ralle
    Ralle ist offline Super-Moderator
    Themenstarter
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    11.851
    Danke
    500
    Erhielt 2.590 Danke für 1.870 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    @RN
    Der verschwindet schon nicht.
    Ich hab mich an viele Widrigkeiten inzwischen gewöhnt (man lernt die zu umgehen), bin aber immer noch viel langsamer als früher.
    Es gibt auch ein paar wenige (leider nur wenige) gute Dinge, z.B. die Möglichkeit, Variablen in DB einfach einzufügen und alle anderen Variablen werden korrekt verschoben.
    Ansonsten ist die Bedienphilosophie des TIA-Portal offensichtlich von Kollegen erdacht worden, die noch niemals eine SPS mit mehr als 5 Bausteinen mit je 3 Netzwerken programmiert haben und es gewohnt sind ihre Variablen nicht zu strukturieren sowie deren Bezeichnung möglichst kurz zu halten.
    Styleguides von MS haben die auch noch nie in der Hand gehabt, sonst hätten die sich nicht alles neu ausgedacht und es dann auch noch fehlerhaft implentiert.
    Es sind zig Kleinigkeiten, die einem das Leben erschweren und täglich wieder auf den S... gehen.

    PS. RN, die hast einen Doppelpost fabriziert!
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  2. #1012
    Registriert seit
    13.10.2007
    Beiträge
    11.527
    Danke
    2.636
    Erhielt 2.953 Danke für 2.025 Beiträge

    Standard

    Gerade beim Mittelgroßen Projekt die Fremdsprachen eingefügt.
    Das die Übersetzungen oft nicht in die Textfelder passen bin ich
    ja gewohnt, aber das mir TIA die Position von der hälfte der Texte
    verschiebt ist doch mal wieder großer Dreck.

    Hat mal wieder ein Entwickler bei Siemens die Übersetzungsfunktion
    nur für ein HMI Bild getestet und das ganze dann für gut befunden.

    Das ich in der Praxis jetzt 50 Bilder unter Zeitdruck nacharbeiten kann,
    übersteigt den Horizont des Entwicklers.

    Ich muß mein Standardspruch zu TIA überarbeiten.

    "Automaisieren Sie in 3 Tagen, was früher nur 5 Minuten gedauert hat."
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  3. #1013
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    1.964
    Danke
    378
    Erhielt 574 Danke für 428 Beiträge

    Standard

    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    aber das mir TIA die Position von der hälfte der Texte
    verschiebt ist doch mal wieder großer Dreck.
    Klingt ja wieder ganz toll.
    Inwiefern verschiebt der die Texte? Ändert sich die eingetragene X/Y-Koordinate in den Einstellungen eines Objektes?
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  4. #1014
    Registriert seit
    23.03.2006
    Ort
    Thüringen
    Beiträge
    1.906
    Danke
    155
    Erhielt 269 Danke für 192 Beiträge

    Standard

    Hi,
    am meisten hält uns zur Zeit auf das man nicht mit mehreren Leuten gleichzeitig an einem Projekt arbeiten kann. Alles nur über Importfunktionen und einer kann dann nur testen.

    Gruß
    Mario

  5. #1015
    Registriert seit
    13.10.2007
    Beiträge
    11.527
    Danke
    2.636
    Erhielt 2.953 Danke für 2.025 Beiträge

    Standard

    Zitat Zitat von RONIN Beitrag anzeigen
    Klingt ja wieder ganz toll.
    Inwiefern verschiebt der die Texte? Ändert sich die eingetragene X/Y-Koordinate in den Einstellungen eines Objektes?
    Woran es liegt habe ich glaube ich schon gefunden.

    Wenn beim Text die der Hacken an der Größenanpassung angklickt ist, der Text Rechtsbündig
    angeordnet ist und die Übersetzung länger wird, was ja meistens der Fall ist, passt TIA die länge
    des Textfeldes an und verschiebt es. Hier ein Beispiel:

    TIA texte.jpg
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  6. #1016
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.241
    Danke
    667
    Erhielt 575 Danke für 441 Beiträge

    Standard

    Zitat Zitat von mariob Beitrag anzeigen
    Hi,
    am meisten hält uns zur Zeit auf das man nicht mit mehreren Leuten gleichzeitig an einem Projekt arbeiten kann. Alles nur über Importfunktionen und einer kann dann nur testen.
    this! Das ist eine Funktion die hat bei Step7 sooo wunderbar funktioniert. Bausteine wurden automatisch gesperrt wenn ein anderer das den offen hatte. Wirklich geniale funktion. Warum die das bei TIA gestrichen haben wird sich mir nie erschliessen.

    Die hätten das eher noch etwas erweitern können. z.B. Netzwerkprojekte in der Liste, auscheckbar machen. Also CPU die man in Betrieb setzen will. Auschecken. Und jeder der Online drauf zugreift kann dann die CPU nicht mehr verändern.
    Und ein Projektweites Audit-Trail wär ja auch mal was.

    mfG René

  7. #1017
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.241
    Danke
    667
    Erhielt 575 Danke für 441 Beiträge

    Standard

    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    Hat mal wieder ein Entwickler bei Siemens die Übersetzungsfunktion
    nur für ein HMI Bild getestet und das ganze dann für gut befunden.
    Ich hatte das auch. Hast du zufällig automatische Grössenanpassung in den Textfeldern aktiviert? Ich schreibe Eingabefelder und Checkboxen etc immer mit Textfeldern rechtsbündig auf der Linken Seite an. Wenn die Textfelder jetzt automatisch Grössenangepasst werden und man sie dann per ausrichten an der Rechten Kante anordnet. Dann werden sie nachher automatisch angepasst aber offenbar an der Linken oberen Ecke festgenagelt.

    Da hilft nur, automatische Grösse ausschalten. Die Felder genügend Gross machen. rechtsbündiger Text und dann an der rechten Kante ausrichten.

    mfG René

  8. #1018
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    1.964
    Danke
    378
    Erhielt 574 Danke für 428 Beiträge

    Standard

    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    Wenn beim Text die der Hacken an der Größenanpassung angklickt ist, der Text Rechtsbündig
    angeordnet ist und die Übersetzung länger wird, was ja meistens der Fall ist, passt TIA die länge
    des Textfeldes an und verschiebt es.
    Ja, wenn Größenannpassung an ist wird das Textfeld länger. Verschieben im Sinne vom "Die eingetragenen XY-Koordianten der linken oberen Ecke ändern sich" tut es sich aber nicht.
    Da das Feld eben von der Position der linken oberen Ecke und der Textlänge ausgeht kommt dann sowas raus.

    Da war auch Flexible noch nicht schlau genug dass bei rechtsbündigem Text von der rechten, oberen Ecke ausgegangen werden sollte und dann nach links verlängert....
    Insofern ist das Verhalten doch gleich (schlecht) wie bei Flex oder irre ich. Man muss also nach jeder Sprach-/Textänderung, nach wie vor überall nachprüfen und ggf. korrigieren.
    Oder irre ich?
    Geändert von RONIN (27.06.2016 um 10:02 Uhr)
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  9. #1019
    Registriert seit
    15.12.2007
    Beiträge
    692
    Danke
    82
    Erhielt 102 Danke für 92 Beiträge

    Standard

    So, jetzt bin ich wohl auch fällig.
    Ich habe mir ein Gestell zum testen aufgebaut und etwas mit TIA V13 SP1 UPD8 und einer 1511-1PN in Zusammenspiel mit einem Danfoss FC302 gespielt.
    Dazu habe ich mir einen neuen Baustein für den Frequenzumrichter geschrieben, der unter anderem die Program_Alarm Bausteine der S7-1500 benutzt etc.
    Ansich sind ja tolle Ideen dabei und es funktioniert auch generell was ich programmiert habe, allerdings ist das TIA-Portal ja echt unterirdisch von der Bedienung.

    Aber jetzt was mich richtig aufregt:
    Selbst einfache Aufgaben wie die Erstellung eines Bildbausteins in WinCC Advanced funktionieren nicht richtig.
    Im Bildbaustein-Editor habe ich die Texte von E/A-Feldern rechtsbündig ausgerichtet, wenn man den Baustein in einem Bild aufruft bleiben die ums verrecken linksbündig ... ebenso nach dem laden in der Runtime.
    Also Support Request aufgemacht. Soll Siemens schließlich wissen das was nicht passt.
    Antwort:
    Ich soll den Bildbaustein mit der Instanz im Bild abgleichen. Fertig. Case wurde ohne das ich eine Chance auf eine Antwort habe, weil ich das ja bereits mehrfach versucht habe, geschlossen.
    Die Jungs vom TIA-Support sind anscheinend gnadenlos überfordert.
    Zum kotzen, echt! Ich probiere noch so lange es geht TIA zu vermeiden, nur leider wird man nicht mehr lange drum herum kommen.

  10. #1020
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    1.964
    Danke
    378
    Erhielt 574 Danke für 428 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Astralavista Beitrag anzeigen
    Antwort:
    Ich soll den Bildbaustein mit der Instanz im Bild abgleichen. Fertig. Case wurde ohne das ich eine Chance auf eine Antwort habe, weil ich das ja bereits mehrfach versucht habe, geschlossen.
    Die Jungs vom TIA-Support sind anscheinend gnadenlos überfordert.
    Wenn du genau auf die Signatur schaust, wirst du beim Namen die Fa. Heitec sehen.
    Das ist der sogenannte neue "First Level Support" der seit einiger Zeit ausgelagert wurde...

    Ich schreib sehr viele Requests, machmal sind Sie gut, manchmal spinnen Sie komplett - Siehe Hier

    Zum Thema "Request geschlossen".
    Der Request kann erst geschlossen werden wenn du ne Antwort hast, du kannst der Request auch jederzeit selber öffnen oder offen halten solange du einfach auf eine Antwort auf die SR-Mail schreibst.
    Wenn du auf die "Request geschlossen"-Mail antwortest, geht er automatisch wieder auf.
    Dann schaut schon wieder einer drauf dass er zu geht.

    Die scheinen da irgendwie nervös zu seine wenn man einen Request lange offen hält und nicht gleich nachgibt, denen sitzt halt auch irgendeine Kontrolle im Nacken. Hier ein Beispiel das man schon hartnäckig mit denen sein muss.

    Ich würde ein kleines Beispielprojekt mit deinem Problem-Bildbaustein an die Mail anhängen mit dem Satz dass die Antwort vom Support nicht funktioniert hat, Screenshots etc.
    Je mehr Material du denen lieferst, desto eher fasst einer was an (auch irgendwie verständlich)

    Irgendwie tun mir die armen Hunde ja auch leid...
    Geändert von RONIN (27.06.2016 um 16:56 Uhr)
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

Ähnliche Themen

  1. [TIA-V11] Rechnet TIA falsch bei SCL
    Von BlackLizzard im Forum Simatic
    Antworten: 43
    Letzter Beitrag: 09.02.2016, 02:59
  2. Frust mit SPS/Step7
    Von plc_from_hell im Forum Simatic
    Antworten: 21
    Letzter Beitrag: 03.03.2015, 17:52
  3. Antworten: 21
    Letzter Beitrag: 08.10.2014, 13:36
  4. Frust mit der Projektpflege
    Von Jens_Ohm im Forum Sonstige Steuerungen
    Antworten: 16
    Letzter Beitrag: 10.01.2008, 07:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •