Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 30 von 119 ErsteErste ... 2028293031324080 ... LetzteLetzte
Ergebnis 291 bis 300 von 1181

Thema: TIA Frust

  1. #291
    Registriert seit
    03.07.2006
    Beiträge
    1.725
    Danke
    515
    Erhielt 301 Danke für 221 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Und für Leute mit Updatevertrag kommt bei jedem Versionssprung das Problem, dass ein CPU Stop notwendig ist.
    Das geht mir auch auf den Sack.... unter Step7 Classic habe ich einmal die Hardware Konfig eingespielt und dann könnte ich alles übertragen und im Programm ändern ohne die CPU in Stop zu schalten.
    Ich konnte auch selber bestimmen was ich übertrage und was ich noch nicht übertrage..... Das geht unter TIA auch nicht mehr ganz so einfach.

    Was dieser Versionssprung mit meinem Programm Code zu tun hat leuchtet mir auch nicht ein.....


    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    Selbst dieses Hochziehen der Runtime bzw. CPU auf den entsprechenden Stand, geht auch
    mal gerne in die Hose, so das man Stunden oder Tage damit verbringen kann ein Panel
    wieder ans leben zu bekommen. Das bezahlt einen kein Mensch.

    Mein Standpunkt steht, so wie es jetzt ist und wie Siemens mit den Problemen umgeht
    ist das Produkt TIA-Portal nicht Industrietauglich.
    Das habe ich persönlich auch noch nicht gehabt das mit TIA ein Panel Image oder ein Firmware Update in die Hose geht..... Also Glück gehabt
    Aber bei WinCC 2008 Flex..... da habe ich früher öfters mein PPI Multi-Masterkabel aus dem Auto geholt....

  2. #292
    Registriert seit
    13.10.2007
    Beiträge
    11.527
    Danke
    2.636
    Erhielt 2.953 Danke für 2.025 Beiträge

    Standard

    Dann möchte ich mal zum TIA-Frust in meinen aktuellen Projekt etwas schreiben.
    Ich habe hier eine kleine Maschine, mit eine Handvoll Servoregler, FUs, Ventilinsel,
    ET200s Stationen, 1200er Comfort Panel und einer ET200s IM-F CPU.

    • Das Problem mit dem Unterstrich

    Ich Arbeite mit dem Bitmeldeverfahren und habe meine Meldungen in Arrays untergebracht,
    damit ich Vollsymbolisch Programmieren kann, habe ich für jede
    Meldungen ein Bit angelegt die in etwa so aussieht SM._1000, SM ist das Array
    und steht für Störmeldung und die Zahl entspricht der Meldenummer in der HMI.

    TIA akzeptiert in AWL keinen unterstrich mehr, damit ich jetzt noch ein wenig
    mit meinen Fundus arbeiten kann habe ich jetzt vor den Unterstrich ‚Nr‘ gesetzt.
    Für den Fehler habe ich den Support kontaktiert, einen Thread hier im Forum
    erstellt und schließlich die Variablen umbenannt, eine Eigenschaft die ich schon
    seit Jahren anwende.

    • Auf einmal bekomme ich eine Übersetzen des Panels eine Meldung

    ‚PnIoOperatingMode: Wert außerhalb des zulässigen Bereits:‘
    Ich glaube da wird es nicht viele geben die mit dieser Meldung etwas anfangen können,
    also wieder den Support kontaktiert. Eine Rückruf habe ich aber erst am nächsten Tag
    bekommen, eigentlich wollte ich noch etwas mit dem Panel testen, wieder ein Tag kaputt.

    Der Supporter war allerdings gut, hatte schon mal von der Fehlermeldung gehört, konnte
    diese aber nicht sofort zuordnen. Nach einen Frage/Antwort-Spiel und einer parallelen suche
    im System brachte die Lösung.

    Ich hatte am Vortag meine Profibusteilnehmer die BMK Kennzeichen gegeben, da hat TIA
    den Namen nicht mehr richtig mitgeführt. Ich musste in der Gerätekonfiguration unter
    Betriebsart den Hacken ‚IO-Device‘ setzen und wieder rücksetzen. Dann wird das Panel
    wieder richtig eingekettet.

    Der Fehler ist bekannt, sollte aber im V13 SP1 behoben sein. Der Supporter bat darum nicht
    speichern zu drücken und das Projekt einzuschicken, damit Sie schauen können was da los ist.

    • Ein umbenennen der Ebenen benennt auch das Bild um.

    Ich habe im Bild ein paar Objekte in einer Ebene gelegt, damit ich den Überblick behalte,
    nenne ich die Ebene entsprechend der Objekte um, damit andere etwas anfangen können.
    Ich Arbeite in ein paar anderen Bildern weiter und möchte, dann zum ursprünglichen Bild
    zurück, ich finde es aber nicht mehr in der Projektnavigation.

    Scheiße denke ich, das musst du wohl aus Versehen gelöscht haben. Nützt nichts erstelle ich
    es neu. Während ich an den Bild arbeite, entdecke ich nach einer halben Stunde in der
    Projektnavigation ein Bild, was ich nicht kenne. Angeklickt, das ist ja mein versehentlich
    gelöschtes Bild … Komisch.

    Ich versuche wieder die Ebene anzupassen, wieder dieses komische Verhalten bis ich
    dahinter gekommen bin das wird Bild auch umbenannt wird.

    Wieder ein Anruf beim Support, die Stimme vom Abfangjäger kannte ich noch, Sie hat
    mich auch wieder erkannt. War ein nettes Gespräch und wollten jetzt gleich beide
    die Sonnenfinsternis beobachten, leider war bei uns in OWL nicht viel davon zu sehen.

    Der Supporter der später zurück rief, kennt das Problem.

    • Rezepturverwaltung funktioniert nicht

    Das ist mein aktuelles Problem, ich Arbeite eigentlich gerne mit der Rezeptur und hatte
    das eigentlich in der WinCCflexibel Welt im Griff. Ich benutze immer zwei Rezepturen
    eine für Produktionsdaten und eine für Maschienenparameter. Da mir die Listen Darstellung
    nicht gefällt und für meinen Fall nicht ausreichend ist, nutze ich Rezeptur-
    bilder, dh Variablen werden Strukturell auf mehreren Seiten dargestellt.
    In Flexibel gab es immer das Problem, wenn man vor den Editieren der Variablen
    nicht in der Rezepturanzeige war, wird nach Anwahl der Anzeige, die aktuelle Rezeptur
    geladen und alle Einstellungen wieder platt gemacht.
    Also habe ich immer die Anzeige Unsichbar mit in das Variablenbild mit hineingenommen.
    Heute fällt mir auf das beim Blättern in den Bildern, dieser Effekt des platt machen.

    Wenn man aber das Handbuch von TIA liest, habe ich alle Reiter richtig gesetzt.

    Ich werde mich jetzt etwas tun müssen was ich eigentlich nicht will, ich trenne mich von
    der Rezepturverwaltung und werde da etwas eigenes aufbauen mit CSV Datein.

    Also nächste Woche wieder den Support anrufen.


    Neben den schon genannten merklichen Arbeiten mit angezogener Handbremse, soll so etwas
    normal sein, ein Projekt und in zwei Wochen viermal den Support kontaktieren. In vier Wochen
    muss mein Projekt laufen, was kann denn da noch alles kommen.

    An alle TIA begeisterten: ‚Hallo Mc-Fly, das Portal ist schon über vier Jahre freigeben und du
    willst mir erzählen, das ist alles normal‘
    Geändert von rostiger Nagel (21.03.2015 um 22:14 Uhr)
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  3. #293
    Registriert seit
    03.07.2006
    Beiträge
    1.725
    Danke
    515
    Erhielt 301 Danke für 221 Beiträge

    Standard

    Ein umbenennen der Ebenen benennt auch das Bild um.

    Ja das ist ein BUG..... gibt aber eine kleine Hilfe bis das behoben ist...... hab ich mal durch spielen gefunden

    In Projektnavigator das Bild markieren -> Eigenschaften -> Ebenen ..... Dort die Bilder umbenennen dann bleibt Dein Bild-Name erhalten

    Bild Panel.jpg

  4. #294
    Registriert seit
    13.10.2007
    Beiträge
    11.527
    Danke
    2.636
    Erhielt 2.953 Danke für 2.025 Beiträge

    Standard

    Ja Ähm,

    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    Abhilfe, die Ebenen nicht im Baum (roter Kreis) umbenennen sondern unter
    den Eigenschaften des Bildes (grüner Kreis).
    Auf jeden fall war der Bug nicht im V13 ohne SP.

    Anhang 27907
    Trotzdem das war vor den SP1 nicht und ich habe kein Bock
    nach wegen zu suchen um einen offensichtlichen Bug zu
    umgehen.

    Über die Rezepturverwaltung habe ich mich schon im letzten
    Jahr mit den Support unterhalten, wann sehen die sich in der Lage
    diese so einzurichten, wie es im im eigenen Hanbuch beschrieben ist.

    TIA V13 --TP700 -- Frage zur Rezepturanzeige
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  5. #295
    Registriert seit
    16.10.2012
    Beiträge
    609
    Danke
    47
    Erhielt 24 Danke für 19 Beiträge

    Standard

    Ich werde mich jetzt etwas tun müssen was ich eigentlich nicht will, ich trenne mich von
    der Rezepturverwaltung und werde da etwas eigenes aufbauen mit CSV Datein.
    Ich wüsste mal gerne, wie das funktioniert. Rezepturen sind eigentlich essentieller Bestandteil, die müssten schon irgendwie laufen damit man ein Panel vernünftig aufsetzen kann.

  6. #296
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.493
    Danke
    308
    Erhielt 1.442 Danke für 1.217 Beiträge

    Standard

    Zitat Zitat von Draco Malfoy Beitrag anzeigen
    Ich wüsste mal gerne, wie das funktioniert. Rezepturen sind eigentlich essentieller Bestandteil, die müssten schon irgendwie laufen damit man ein Panel vernünftig aufsetzen kann.
    Solange du keine Ansprüche an das "wie" hast...
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  7. #297
    Registriert seit
    03.07.2006
    Beiträge
    1.725
    Danke
    515
    Erhielt 301 Danke für 221 Beiträge

    Standard

    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    Ja Ähm,



    Trotzdem das war vor den SP1 nicht und ich habe kein Bock
    nach wegen zu suchen um einen offensichtlichen Bug zu
    umgehen.

    Über die Rezepturverwaltung habe ich mich schon im letzten
    Jahr mit den Support unterhalten, wann sehen die sich in der Lage
    diese so einzurichten, wie es im im eigenen Hanbuch beschrieben ist.

    TIA V13 --TP700 -- Frage zur Rezepturanzeige
    Haha. ... Ok ab jetzt lese ich alle Beiträge von dir ganz genau....

    gruss

  8. #298
    Registriert seit
    08.08.2008
    Ort
    Köln
    Beiträge
    322
    Danke
    55
    Erhielt 81 Danke für 62 Beiträge

    Standard

    Damit unter TIA mein PG so schnell arbeitet wie mit Classic musste ich auf
    I7, 8GB Ram und SSD aufrüsten, erst auf dieser Plattform macht eine Installation überhaupt Sinn.
    Vom Gefühl hats aber die SSD am meisten gebracht.

    Jetzt stellt sich allerdings die Frage auf was mit dem nächsten Versionssprung die Hardware
    hochgerüstet werden muss, das ist ja ein Fass ohne Boden.

    Meine ersten 2 Projekte habe ich erstmal nur für Inhouse und an Maschinen gemacht auf die ich
    ohne Fernwartung zugreifen kann, bisschen Profinet, bisschen Analog, ca.200E/As und das 2nd Generation
    KTP700 Basic Panel als HMI, alles in FUP und mit VIPA 315SN/Eco CPU.

    Funktioniert ohne Probleme, brauchte auch nicht viel Zeit zur Umgewöhnung, ist ja irgendwie immer das gleiche
    nur eben mit veränderter Oberfläche.
    Aber wirklich schneller war ich mit TIA nicht, im Gegenteil, auf dem Bildschirm wird soviel unnötiges angezeigt,
    da bin ich die meiste Zeit die Fenster am verkleinern/vergrößern und am suchen wo was ist was ich gerade brauche.
    Also Intuitiv ist das nicht.

    Bisschen offtopic jetzt, aber: Irgendwie glaube ich das die Programmierer von TIA und der Tapatalk APP in
    der gleichen Schulklasse waren.
    Habe diese APP viele Jahre gerne benutzt bis mit jedem update immer mehr grau in grau eingeführt wurde.
    Alles voller bunter Bilder und nicht nachvollziehbarer Struktur, die wirklichen Inhalte der Texte verlieren
    immer mehr an Bedeutung.

    Nun denn, schönen Sonntag euch.

  9. #299
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.082
    Danke
    387
    Erhielt 2.252 Danke für 1.891 Beiträge

    Standard

    @Helmut:
    Zu deiner Rezeptur-Geschichte :
    Eine Rezeptur- oder Parameter-Verwaltung, die vernünftig aussieht und so funktioniert, wie ich es mir vorstelle habe ich allerdings noch nirgendwo gesehen. Das ist z.B. bei VisiWin auch Sch...e (wahrscheinlich habe die bei Siemens abgeguckt).

    Gruß
    Larry

  10. #300
    Registriert seit
    13.10.2007
    Beiträge
    11.527
    Danke
    2.636
    Erhielt 2.953 Danke für 2.025 Beiträge

    Standard

    Zitat Zitat von Larry Laffer Beitrag anzeigen
    @Helmut:
    Zu deiner Rezeptur-Geschichte :
    Eine Rezeptur- oder Parameter-Verwaltung, die vernünftig aussieht und so funktioniert, wie ich es mir vorstelle habe ich allerdings noch nirgendwo gesehen. Das ist z.B. bei VisiWin auch Sch...e (wahrscheinlich habe die bei Siemens abgeguckt).

    Gruß
    Larry
    In der Classic Welt (WinCCflex) hatte es für meine Anwendungen Funktioniert,
    nach langer Suche, wie es den funktionieren könnte. Es tat für mich jahrelang
    seinen Dienst, mit allen Einschränkungen, doch Verlässlich.

    Aber selbst das ist jetzt mit TIA nicht mehr gegeben.

    Wenn du sagst bei VisiWin ist es ähnlich, bin ich mir sicher das du es dort einfach
    umschiffen kannst, mit den Möglichkeiten die .net dir bietet.

    Ehrlich gesagt verstehe ich nicht warum man so ein so wichtiges Element,
    wie eine Rezepturverwaltung so wenig Augenmerk schenkt.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

Ähnliche Themen

  1. [TIA-V11] Rechnet TIA falsch bei SCL
    Von BlackLizzard im Forum Simatic
    Antworten: 43
    Letzter Beitrag: 09.02.2016, 02:59
  2. Frust mit SPS/Step7
    Von plc_from_hell im Forum Simatic
    Antworten: 21
    Letzter Beitrag: 03.03.2015, 17:52
  3. Antworten: 21
    Letzter Beitrag: 08.10.2014, 13:36
  4. Frust mit der Projektpflege
    Von Jens_Ohm im Forum Sonstige Steuerungen
    Antworten: 16
    Letzter Beitrag: 10.01.2008, 07:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •