Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 66 von 119 ErsteErste ... 1656646566676876116 ... LetzteLetzte
Ergebnis 651 bis 660 von 1181

Thema: TIA Frust

  1. #651
    Registriert seit
    06.03.2011
    Ort
    Daham
    Beiträge
    215
    Danke
    61
    Erhielt 13 Danke für 13 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Leider sind viele unser Kunden technische Leihen und die dies machen könnten, sagen zurecht eure Maschine euer Problem. Das nächste ist der Kunde müsste sich vorher alle Rezepturen vom HMI sichern und nachher wieder aufspielen. Ich seh schon die Anrufe mit wir haben das Update eingespielt jedoch sind die Rezepturen weg. Pack and Go is super wenn man weiß was man tut. Schöne grüße aus Kos, Griechenland. So jetzt erst mal ab auf die Baustelle.

  2. #652
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.319
    Danke
    454
    Erhielt 1.067 Danke für 707 Beiträge

    Standard

    Was lese ich da von Update 5 ??? Gibt es das schon ?
    Vielleicht ist das Leben ja ein Integer. Wenn man negativ genug denkt, wird's irgendwann positiv.

  3. #653
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.088
    Danke
    26
    Erhielt 711 Danke für 621 Beiträge

    Standard

    Hi,

    nein UPD5 gibt es noch nicht, kommt erst noch. Aktuell ist UPD4 !

    Gruß
    Christoph

  4. #654
    Registriert seit
    13.10.2007
    Beiträge
    11.537
    Danke
    2.648
    Erhielt 2.967 Danke für 2.030 Beiträge

    Standard

    Das währe doch auch etwas für uns TIA-Geschädigte

    http://www.slidenjoy.com/
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  5. #655
    Avatar von Ralle
    Ralle ist offline Super-Moderator
    Themenstarter
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    11.851
    Danke
    500
    Erhielt 2.591 Danke für 1.870 Beiträge

    Standard

    Möglicherweise hatten wir das hier schon, aber gerade stößt es mir wieder bitter auf:

    1.

    Code:
    Regeln zum Umschalten der Programmiersprache
    Regeln Beachten Sie folgende Regeln, wenn Sie die Programmiersprache für einen Baustein umstellen möchten: Alle CPU-Familien: Sie können nur ganze Bausteine umschalten. Einzelne Netzwerke können nicht umgeschaltet werden. Bausteine, die in den Programmiersprachen SCL oder GRAPH programmiert werden, können Sie nicht umschalten. Bei GRAPH-Bausteinen können Sie aber bei der Sprache der Netzwerke zwischen KOP und FUP wechseln. S7-300/400: Sie können zwischen den Programmiersprachen KOP, FUP und AWL umschalten. Sie können Netzwerke in einem Baustein mit einer anderen Programmiersprache erstellen und anschließend in den gewünschten Baustein kopieren. Einzelne Netzwerke des Bausteins, die nicht umgeschaltet werden können, werden in der Originalsprache angezeigt. S7-1200/1500: Sie können zwischen den Programmiersprachen KOP und FUP umschalten. S7-1500: Sie können innerhalb von KOP- und FUP-Bausteinen AWL-Netzwerke erstellen. Das Kopieren zwischen AWL und KOP/FUP ist jedoch nicht möglich.
    Boah, was ist daran Fortschritt, wenn ich ein paar simple AWL-Anweisungen nciht mehr in FUP schalten kann.

    2. AT-Ansicht

    Die geht nur bei nicht optimierten Bausteinen.
    Wenn man es bei optimierten versucht, kommt aber keine wirklich erhellende Fehlermeldung, wozu auch. Da ich nicht jeden Tag mit TIA arbeite, braucht man manchmal eine ganze Weile, um zu merken, warum da etwas nicht geht.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  6. #656
    Registriert seit
    01.03.2007
    Beiträge
    262
    Danke
    26
    Erhielt 33 Danke für 28 Beiträge

    Standard

    Hallo,

    mein letzter Post hier im Forum ist sicher auch Jahre schon wieder her...

    Zuerst einmal:
    Zitat Zitat von holgero Beitrag anzeigen
    Vielleicht kann man in TIA14 auch mal die nervige Einrückfunktion des SCL-Editors anpassen oder abschalten.
    Die Einrückfunktion lässt sich abschalt unter "Extras"->"Einstellungen"->"Allgeimein"->"Skript-/Texteditoren" im Unterpunkt Einrückung. Wenn du dort den Punkt "Keine" auswählst kannst du so einrücken wie du das willst.


    Naja, zum Thema TIA:

    Wie hie auch schon einige geschrieben haben ist die Idee an sich ja schon toll, dass man nur ein Programm für alles hat, wenn es doch auch nur in der Praxis so aussehen würde.

    Die ersten Probleme, die ich habe beginnen schon bei der Migration.
    Ich wollte vor Kurzem einmal einen Baustein aus einem Projekt vom Step7 in das TIA übertragen. In der Werbung wird ja immer schon gezeigt wie alles mit Drag&Drop von A nach B geschoben werden kann, war in dem Fall leider nicht möglich. Dann dachte ich mir: OK, dauert dann halt mal 5 Minuten um das zu migrieren und gut ist. Nach dem 5. Versuch der Migration habe ich dann aufgegeben. Die ersten 3 Male hat TIA irgendwelche inkonsistenen Bausteine bemängelt und natürlich schafft es TIA nicht nach einem nicht erfolgreichen Migrationsversuch die Leichen, die es im Projekteordner angelegt hat selbst zu entsorgen. Danach kam dann die Katastrophe: 2 G120C-Umrichter. Ich hätte ja kein Problem wenn das TIA sagt, dass dort Hardware ist, die (noch?) nicht kompatibel ist und deshalb nicht migriert werden kann, aber wenigstens das migriert was geht oder zu fragen: "Du, hör mal zu: Das kann ich nicht migrieren, geht's auch ohne oder soll ich abbrechen?". Am Ende habe ich jetzt ein neues Projekt im Step7 angelegt und den Baustein darüber migriert. Die Aktion hat mich ca. eine Stunde und viele Nerven gekostet.

    Dann geht es weiter mit der Bedienung und "Style"-Elementen im TIA.
    Es fängt ja schonmal an mit der Portalansicht. Was soll denn der Sch***? Egal was man da macht früher oder später landet man so oder so in der Projektansicht und in der Projektansicht kann man alles machen was in der Portalansicht auch geht... ich habe das Gefühl, dass das nur drin ist, damit das Marketing schöne Screenshots hat?!
    Dann im AWL-Editor ist das bescheidenste und für mich das nutzloseste Feature überhaupt: animiertes Scrolling. In keinem professionellen Editor gibt es sowas, hält einen nur auf und die Chance nach einer längeren Spazierfahrt mit dem Courser an der gewünschten Stelle zu halten sinkt auf auf ein Minimum, weil der Courser schneller als das Bild ist...
    Dann im SCL-Editor und im Graph-Aktions-Editor: Es gibt dort dieses schöne Status-/Informationsfenster, das wirklich immer im Weg ist. Dann schiebe ich das Ding zur Seite und meistens dann so weit nach rechts, dass ich es dann nichtmehr finde und den Baustein wieder schließen und öffnen muss.
    Und das Schlimmste ist das Eigenschaften-Info-Diagnose-Ding, das da unten rumlungert. Das steht irgendwie immer auf dem was ich gerade nicht brauche und anders als der Rest von den TIA-Fensterchen lässt sich das nicht auseinandernehmen sondern ist und bleibt eine Einheit.

    Dann die Compiler und das Handling mit diesen:
    Zuerst einmal ist die Geschwindigkeit miserabel. Im Step7 war ein Baustein noch innerhalb von Millisekunden übersetzt und in der Steuerung, mit dem TIA muss erstmal vorbereitet werden, dann Konsistenzprüfung, dann übersetzen, dann noch ein Dialog, ob man die Änderung wirklich laden will, dann lädt es und dann sind bei einer kleinen Änderung schon gut mal 20 Sekunden vergangen.
    Dass das Übersetzen nur von Änderungen in einem Panel nur in einem von fünf Versuchen vielleicht mal funktioniert ist ja schon schlimm genug und frisst Zeit ohne Ende. Aber beim Übersetzen von Panels ist es nicht mehr möglich Bausteine in die CPU zu übertragen und zu allem Überfluss bricht das Übersetzen ab, wenn man das Projekt speichern will.
    Die Tatsache, dass man bei einem Firmwareupdate von 5 Panels ersteinmal eine halbe Stunde Pause machen muss ist auch sowas... beim Step7 und WinCCflex konnte man einfach an der Steuerung weitermachen, beim TIA geht garnichts mehr.

    Ich wundere mich auch jedes mal über die Datenbausteine. Ich habe teilweise ein paar Datenbausteine in einer Maschine, die ihre Parameter nicht verlieren sollten. Beim TIA reicht es ja schon durch die Symbolik, wenn ein Name geändert wird (irgendein Reserve-Bit umzubenennen), dass der Baustein reinitalisiert werden muss. Wie genial wäre es, wenn die Werte im Online-Baustein von der alten auf die neue Symbolik kopiert werden könnte, sofern der Datentyp und Symbolname noch übereinstimmen...?!

    Vor Kurzem musst ich einmal eine Textliste in eine HMI importieren, in dem Hauptprojekt, das nicht gerade klein ist hätte es für ca. 300 Zeilen 5 Stunden gebraucht, in eine leere HMI hat es nur 30 Sekunden gebraucht diese Texte zu importieren. Dann hat das Kopieren der Texte von dem leeren Projekt in das große Projekt nur 5 Sekunden... also manchmal verstehe ich da echt nicht was da abgeht oder wie...

    Was mir an der S7-1500er ziemlich gut gefällt ist, dass es die 64-Bit-Integer, den Longreal und Unicodestring gibt. Im SCL sind diese meiner Meinung nach auch gut zu gebrauchen, aber geht es dann Richtung AWL... da braucht es dann zum Rechnen Bausteine... liegt wohl daran, dass der AKKU nicht mitgewachsen ist...

    Zu guter Letzt noch: TIA Openness, das ist ja mal die größte Grütze, der ich bisher begegnet bin... nicht einmal ein vollständige Dokumetation kriegen die hin, nur ein paar Beispielprogramme und ein halblebiges Heftchen, in dem toll drinsteht wie die Funktionen anzuwenden sind, aber nichts wie die zu importierenden Daten angeordnet werden sollen bzw. wo man was im den Exportierten daten findet... und dann kann man natürlich nicht auf alles zugreifen, sondern nur auf ein paar exclusive Daten... und wenn man dann mal was beim Support nachfragt kommt eine Schilderung wo man mal nachschauen könnte, aber konkrete Informationen wo man was findet und wie es aufgebaut ist...

    Ich könnte jetzt noch den ganzen Tag so weiterschreiben, wenn ich wöllte, aber das sind so die Sachen, die mir so aus dem Stehgreif einfallen.
    So im Großen und ganzen tut das TIA ja was es soll, es hat aber viele viele Macken und teilweise ist es zum Haareraufen, aber es geht, wenn man sich mal langsam an die Oberfläche gewöhnt hat kann man damit arbeiten, aber ich brauche durch die vielen Fallstricke, die das TIA bereitgestellt hat wesentlich länger für meine Projekte.
    Ich hoffe mal, dass in den nächsten Versionen mal an den Mängeln gearbeitet wird, anstatt an neuen Features.

    Ich wünsche euch allen mit dem TIA viel Spaß und Freude, ich hab es mit dem TIA nicht...
    „Software wird schneller langsamer als Hardware schneller wird.“ - Niklaus Wirth (1995)

  7. Folgender Benutzer sagt Danke zu Human für den nützlichen Beitrag:

    holgero (24.09.2015)

  8. #657
    Avatar von Ralle
    Ralle ist offline Super-Moderator
    Themenstarter
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    11.851
    Danke
    500
    Erhielt 2.591 Danke für 1.870 Beiträge

    Standard

    Ach so, die Vorlage ist gut, was mir zum Thema "Ein Programm für Alles" noch so einfällt.

    Da ich einen neuen Baustein programmiere und einen "Alten" als Vorlage habe, habe ich diese beiden Bausteine aus der Oberfläche gelöst und nach rechts auf einen zweiten Monitor geschoben (ohne 2. ist es ja furchtbar ), der zum Programmieren übrige Platz bei 2 Bausteinen reicht nicht mal für ganz kurze Variablen. Dann noch auf dem linken Bildschirm eine PDF. Aber ach, immer wenn ich rechts in einem Baustein arbeite, ist auch links das TIA Fenster wieder ganz oben.

    1. Ok, ich minimiere das mal ... LOL, auch die Bausteinfenster werden minimiert.
    2. Hm, ich könnte die Hauptfenster wenigstens als Ganzes kleiner machen ... Uups, es gibt anscheinend eine Minimalgröße, die ich nicht unterschreiten kann.
    3. Na, dann auch nach rechts auf den Bildschirm schieben. OK, schick aber nun liegt es immer hinter den beiden Bausteinfenstern, auch Sch..., denn wenn ich die Suche im Baustein nutzen will, dann seh ich nichts, denn die ist im Hauptfenster.

    Die Suche ist eh super durchdacht, denn man kann nicht einfach einen Begriff oder eine Variable durch Doppelklick markieren und mit "Strg F" suchen, nein, Doppelcklick auf die Variable, "Strg C" (kopieren), "Strg F" (Suche öffnen) "String V" (Begriff einfügen), dann noch mit der MAUS!!!!!!! auf den Button "suchen". Ok, gibts vielleicht auch 'nen Shortcut dafür??? Hab ich wohl noch nicht entdeckt in diesem Suchspiel. Und das ist schon das Optimum!!!

    Das mal so ein gaaaanz kleiner Ausschnitt aus diesem wunderbaren "Workflow". Der Amateur, der sich diesen Schwachsinn ausgedacht hat (ne, kann nicht sein, mit DENKEN hat das Ganze ja nichts gemein), also der Trottel, sollte dazu verdonnert werden 6 Monate mit seinem Müll zu proggen, ich wette, der steht das nicht durch oder/und bringt sein Projekt nicht fertig.
    Geändert von Ralle (23.09.2015 um 23:35 Uhr)
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  9. #658
    Registriert seit
    11.12.2009
    Beiträge
    2.015
    Danke
    383
    Erhielt 370 Danke für 257 Beiträge

    Standard

    Hatte heute auch wieder was... was mir BEINAHE den Tag versaut hat.

    TIA V13 UPD4 SCL:

    Mehrzeilige Kommentare macht man ja mit (* Kommentar *)

    Da ich ein fauler Mensch bin, läuft das bei mir so ab:

    () tippen
    Pfeil nach Links, zwei Sternchen

    dann steht dort

    (**)

    Wenn man das eingetippt hat, wird ALLER Code der danach kommt auf einmal gelöscht.
    Wenn man Rückgängig macht, steht statt dem Code irgend ein <Platzhalter> ... Nochmal zurück rettet dann alles.

    WIE KANN SOWAS SEIN???? HALLO?

    Gibt es irgendwo nen Link wo man solche Bugs melden kann?
    Da ich recht flink mit der STRG+S Taste bin (Safe often, Safe early - besonders bei Siemens) hätte mich das ganze 300 Zeilen Code kosten können (trotz täglicher Backups)

    Grüße

    Marcel
    Stell Dir vor es geht, und keiner kriegts hin!

  10. #659
    Avatar von Ralle
    Ralle ist offline Super-Moderator
    Themenstarter
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    11.851
    Danke
    500
    Erhielt 2.591 Danke für 1.870 Beiträge

    Standard

    Das ist ein Feature, genial, man kann damit Code löschen. Ist doch super. Die Idee dazu stammt bestimmt von dem selben Gammeltypen, der sich die Suchroutine ausgedacht hat.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  11. #660
    Registriert seit
    16.03.2014
    Beiträge
    295
    Danke
    65
    Erhielt 27 Danke für 24 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke,
    ich bin absoluter Einsteiger in Sachen TIA und habe ca. 1 Jahr intensiv Twincat V2.x gelernt...

    Soll nun wegen eines anderen Auftraggebers Siemens TIA lernen...

    Also alles sauberst installiert in einer extra sauberen WIN7-64 Installation.

    Dann bin ich sehr blauäugig los, wähle ne S7-300 aus und tippe unter SCL (Komme halt von Hochsprachen)
    schnell mal nen Selbstlaufenden TON ein und nen Counter...
    Dann Simulation drücken und ab hier verstehe ich alle bisherigen Postings:
    Ewiges warten das was passiert und wehe man klickt nochmals, ABSTURZ !?

    Naja, so ging das weiter...
    (Das gleiche Programmierbeispiel lief dann erstmal unter ner 1500er gar nicht korrekt, Wauh ! )

    Wie schafft ihr es damit in guten Turnarroundzeiten zu entwickeln ?
    (Oder wird der dazu passende PC noch entwickelt ?)

    Ich glaube jetzt erst langsam zu verstehen, wieso TIA-Entwickler so teuer sind:
    Das dauert ja alles ewig, stürzt ständig ab etc.
    Und ich bin wohl erst im 1% aller Möglichkeiten angekommen.

    Naja, ist ja der Marktmonopolist !

    Ich lerne halt weiter, ist etwas frustrierend...

    So wirklich wichtig ist mein Beitrag ja auch nicht

    Bye
    Hardy

Ähnliche Themen

  1. [TIA-V11] Rechnet TIA falsch bei SCL
    Von BlackLizzard im Forum Simatic
    Antworten: 43
    Letzter Beitrag: 09.02.2016, 02:59
  2. Frust mit SPS/Step7
    Von plc_from_hell im Forum Simatic
    Antworten: 21
    Letzter Beitrag: 03.03.2015, 17:52
  3. Antworten: 21
    Letzter Beitrag: 08.10.2014, 13:36
  4. Frust mit der Projektpflege
    Von Jens_Ohm im Forum Sonstige Steuerungen
    Antworten: 16
    Letzter Beitrag: 10.01.2008, 07:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •