Über CP343-1 (Ethernet) auf CP342-5 (Profibus) zugreifen

Wolfgang14

Well-known member
Beiträge
128
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Grüße :)
Ich mache zu Zeit einen Versuchsaufbau und habe eine CPU 315 DP mit einer CP343-1 und eine CPU314 mit einer CP342-5 .
Da mir zur Zeit leider kein MPI Adapter zur verfügung steht wollte ich ein Programm per Ethernet Schnittstelle auf meine CPU315 schieben dies gelang ohne Probleme nun wollte ich gern noch meine CPU314 per Profibus koppeln und ebenfalls per Ethernet Programmieren jedoch bekomme ich das Programm nicht auf die 314er geschoben .
Habe die 315er bereits als Master und die 314er als Slave angelegt .
Wie bekomme ich mein Programm über die 315er auf die 314er ?

Danke schonmal im vorraus :)
 

Fabpicard

Well-known member
Beiträge
753
Punkte Reaktionen
102
Ich meine mich zu erinnern, das der 314er in deinem Fall erst einmal die Hardware-Konfig reingebügelt werden muss, damit diese nach auch auf die Routing-Informationen welche von der 315er vermittelt werden, reagieren kann.

MfG Fabsi
 

JesperMP

Well-known member
Beiträge
6.544
Punkte Reaktionen
1.258
Zuviel Werbung?
->Hier kostenlos registrieren
Du willst wieso mit den 314'er Programmieren:

PG ---(ethernet)--- CP343-1/315-2DP ---(profibus)--- CP342-5/314.

Du musst in dein STEP7 Projekt beide SPSen und dein PG haben, und mit einander verbunden, genau wie in Wirklichkeit.
Du musst in NetPro den HW Konfig generieren, und am mindestens auf den 315'er laden (ich glaube nicht das es notwendig ist auf der 314'er. Nur den Station in der Mitte braucht die Routing informationen).
In NetPro musst du ein gelben Pfeil auf der PG sehen können. Das ist ein Indikation das STEP7 "sich selber" als den PG erkennt.
Dann solltest du online mit der 314'er gehen können.

Habe die 315er bereits als Master und die 314er als Slave angelegt .
Du brauchst nicht ein S7 CPU als Profibus Master und der andere als Profibus Slave haben. Ich meine aber nicht das es stört wenn du es so konfigurierst.
Aber probier erst ein "normalen" master-master system.
 

JesperMP

Well-known member
Beiträge
6.544
Punkte Reaktionen
1.258
Habe die 315er bereits als Master und die 314er als Slave angelegt .
Meinst du nur offline in STEP7, oder ist es dir gelungen den HW Konfig in der 314'er zu laden ?
Wenn du nicht so weit bist, glaube ich das du an ein Stolperstein gestossen bin.
In den obengenannte Konfiguration musst erstmals den HW Konfiguration per MPI in der 314'er geladen werden.
Der Grund ist: Ein CP342-5 ist ab Werk auf den Profibus Schnittstelle "not networked".
 
OP
W

Wolfgang14

Well-known member
Beiträge
128
Punkte Reaktionen
0
Also wenn ich es umgekehrt mache die 314 mit ethernet (343) und Profibus (342) sollte es gehen ? oder müssen immer erst die Daten z.b. per MPI hinterlegt werden ?
 

JesperMP

Well-known member
Beiträge
6.544
Punkte Reaktionen
1.258
Ein Unterschied zwisschen CP343-1 und CP342-5, ist dass das Ethernet-Modul ist von Werk ab getauft mit ein MAC-Adresse. Über diese MAC-Adresse kann man mit der CP343-1 und den damit verbundene CPU in Verbindung kommen, selbst wenn der CP343-1 kein IP zugewiesen ist. Also kann man ein HW Konfig in der CPU laden, und den CP343-1 ein IP zuweisen.
Ein Profibus CP kann man der erste Inbetriebnahme nur ein andere Weg konfigurieren.
 

Crocker

Member
Beiträge
10
Punkte Reaktionen
0
Wie wäre wenn du beide Steuerungen erst mal über MPI (hast du ja auf beiden CPUen) physikalisch und auch logisch (Subnets ) verbindest. Dann sollte das Routing vom Ethernet Subnet auf das MPI Subnet funktionieren. Achte darauf, dass beide CPUen unterschiedliche MPI Adressen haben. Wenn die 2. CPU (die keinen Ethernet Port hat) noch Werkseinstellungen hat, dann hat sie die MPI-Adresse 2. Dann musst du die MPI-Adresse der anderen CPU auf eine andere Adresse einstellen. Ich würde dann eine Adresse > 3 verwenden, weil auch die MPI-Adresse 3 belegt ist (durch den CP 343-5). Im Zweifelsfall setzte für die 1. CPU die MPI-Adresse auf 10.

PS: Programmierst du noch mit Step7 oder schon mit TIA? Bei TIA ist die Konfiguration der Subnetze eigentlich sehr einfach durch ziehen von Verbindungen im Network View von einem Port zum anderen sehr schnell erledigt.
Im TIA Portal kann man auch im erweiterten Download Dialog sofort erkennen, ob die (unterlagerte) SPS per Routing erreichbar ist.
Hier mal ein Screen Shot (ich hoffe, man darf TIA screen shots hier verbreiten!), der eine ähnliche Konfiguration zeigt. Hier wird allerdings auf ein PROFIBUS Subnet geroutet.
S7_Ethernet_PROFIBUS_Rounting_in_TIA.png
 

DeltaMikeAir

User des Jahres 2018
Beiträge
10.752
Punkte Reaktionen
2.610
Zuviel Werbung?
->Hier kostenlos registrieren
Wie wäre wenn du beide Steuerungen erst mal über MPI (hast du ja auf beiden CPUen) physikalisch und auch logisch (Subnets ) verbindest. Dann sollte das Routing vom Ethernet Subnet auf das MPI Subnet funktionieren. Achte darauf, dass beide CPUen unterschiedliche MPI Adressen haben. Wenn die 2. CPU (die keinen Ethernet Port hat) noch Werkseinstellungen hat, dann hat sie die MPI-Adresse 2. Dann musst du die MPI-Adresse der anderen CPU auf eine andere Adresse einstellen. Ich würde dann eine Adresse > 3 verwenden, weil auch die MPI-Adresse 3 belegt ist (durch den CP 343-5). Im Zweifelsfall setzte für die 1. CPU die MPI-Adresse auf 10.

PS: Programmierst du noch mit Step7 oder schon mit TIA? Bei TIA ist die Konfiguration der Subnetze eigentlich sehr einfach durch ziehen von Verbindungen im Network View von einem Port zum anderen sehr schnell erledigt.
Im TIA Portal kann man auch im erweiterten Download Dialog sofort erkennen, ob die (unterlagerte) SPS per Routing erreichbar ist.
Hier mal ein Screen Shot (ich hoffe, man darf TIA screen shots hier verbreiten!), der eine ähnliche Konfiguration zeigt. Hier wird allerdings auf ein PROFIBUS Subnet geroutet.
Anhang anzeigen 58525
Mal aufs Datum geschaut?
 

Crocker

Member
Beiträge
10
Punkte Reaktionen
0
Sorry, hab übersehen, dass es eine alte Kamelle ist aber vielleicht hilfts dem ein oder anderen in der Zukunft noch sein Routing-Problem zu beheben.
 
Oben