CP343 Lean, freeModBus TCP/IP als Slave ( Server )

MandiNice

Well-known member
Beiträge
149
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Hallöchen

Im aktuellen Projekt soll ich mit einer CP343 Lean eine ModBus-Kommunikation einbinden
( free ModBus TCP/IP als Slave ( Server ) )


Ich habe das Beispielprojekt einkopiert.

Der Fehlerzähler zählt im Sekundentakt hoch und der Statuscode zeigt 8183.

Nachdem was ich rausfinden konnte bedeutet das :
Alles OK, es besteht aber keine Verbindung ?
Stimmt das ?

Das Dumme ist, ich kann wirklich keine Verbindung aufbauen.
Der ModBus-Master meldet "keine Antwort von Slave"

Die IP-Adresse sollten passen ( ich kann die Karte pingen )
Die Lizenz ist registriert.

Kann mir da jemand einen Tip geben.

Danke Euch.

beste Grüße
Mandi
 

Waelder

Well-known member
Beiträge
952
Punkte Reaktionen
116
Hallo Mandi,

lass mich mal das aufzählen :

Du möchtest Daten bereit stellen mit deiner S7 für ein Modbus System ist das Richtig ? Die Modbus Steuerung holt lediglich die Daten ab sehe ich das richtig ? D.h deine S7 fungiert als Server ?
Ich hatte vor kurzem fast dei gleiche Aufgabe (allerdings eine IM158 CPU) und die Siemens Vorlage benutzt und den TCP Wizard benutzt und die kommunikation releativ schnell zum laufen bekommen.
Du wirst anstelle der IM wohl eine CP auswählen müssen.
Eigentlich war es bei mir so, dass die Modbus (SPS?) die Daten abholt und nicht ich ihm die Daten schicke. Hast Du als KomPartner eine Schneider SPS ? Setzt euch doch mal zusammen und testet eure kommunikation. Eigentlich müsste die Modbus Steuerung deine IP kennen und die Daten abholen.
Mit ein bisschen probieren hat das gepasst ursprünglich wollte ich auch sen Modbus via TCP IP anfahren war aber der Falsche weg.

Gruss Micha



Modbus.jpg Modbus1.jpg Modbus2.jpg Modbus3.jpg
 
Oben