TIA F-DQ Helltest aktiv obwohl nicht konfiguriert

Fluffi

Well-known member
Beiträge
395
Punkte Reaktionen
52
Zuviel Werbung?
->Hier kostenlos registrieren
Ich habe ein seltsames Problem bei dem ich aktuell nicht mehr weiter weiß.
Bei einem F-DQ 4x24VDC/2A PM HF_1 Modul schalten die Ausgänge im Takt von 100s oder 1000s (je nachdem was eingestellt ist), kurz 2x hintereinander auf High. Es wird also der sogenannte Helltest durchgeführt. Nur vertragen das die angeschlossenen Geräte nicht, da es zu einem hörbaren Schalten kommt sowie Folgefehlern und was mich einfach nur verwundert ist, der Helltest ist auf allen Kanälen nicht aktiviert, wie auch Diagnose Drahtbruch nicht aktiv ist und in den DQ-Parametern ist zudem noch "Deaktivierung Dunkeltest" ausgewählt. Also alle F-Tests sind aktuell in dem Modul und auch allen anderen nicht als aktiv konfiguriert. Trotzdem findet der Helltest statt. Die Konfig und das Prorgramm wurden schon x-nal neu übersetzt und übertragen.
Auch der Trick mit alle Häcken in der Konfig aktivieren, übersetzen und laden und danach wieder entfernen hat nichts gebracht, ebenso wie das Löschen des IM-Ordners Ein Programmierungsfehler ist auch auszuschließen, da auch ein fest auf Low programmierter Ausgang das zwingend macht. Lege ich die angeschlossenen Kanäle fest auf 0V statt auf die F-DQs, so tritt das Problem nicht auf, was bedeutet es muss auch wirklich am Modul liegen und nicht an den Geräten. Messtechnisch kann ich die Taktung auch erfassen, sie ist also wirklich da, aber wie gesagt, nirgends konfiguriert.
Sieht nach einem Bug aus. Ist das evtl. ein FW Problem oder kann sowas vom Hochrüsten kommen? Ich weiß nicht mehr weiter. Bin wirklich für jede Hilfe dankbar.
 
Zuletzt bearbeitet:

NBerger

Well-known member
Beiträge
905
Punkte Reaktionen
238
Welche CPU ? Welche Firmware?...

Hast du mal die max. Rücklesezeit runtergesetzt (0,8 - 5ms)

Behebt die mögliche Parametrierungsignoranz nicht, aber der Aktor reagiert dann möglicher weise nicht.
 
OP
F

Fluffi

Well-known member
Beiträge
395
Punkte Reaktionen
52
Zuviel Werbung?
->Hier kostenlos registrieren
ich hatte beide Rücklesezeiten bereits auf den niedrigsten Wert gestellt. Leider ohne Verbesserung.
Die CPU ist eine 1512SP F-1 PN mit FW 2.8
Der FW-Stand des F-DQ Moduls ist auch aktuell.
Mir ist völlig schleierhaft wie diese Funktion aktiv sein kann, wenn sie definitiv nicht eingestellt ist und es mir beim Online-Zugriff auch nicht als aktiv dargestellt wird.
 
Zuletzt bearbeitet:

Wincctia

Well-known member
Beiträge
762
Punkte Reaktionen
160
Hallo Fluffi,

hast du schon mal die Baugrupp + CPU oder noch besser ganze Anlage Spannungslos gemacht?

würdest du bitte kurz mal skizzieren wie dein Aktor an der Karte angeklemmt ist?

Gruß tia
 
OP
F

Fluffi

Well-known member
Beiträge
395
Punkte Reaktionen
52
Bin in der IBN-Phase, hab daher das ganze Setup schon gefühlt 100x spannungslos gemacht.
Der Aktor ist lediglich einmal mit einem F-DQ Kanal verbunden und einmal mit Masse, allerdings nicht mit den Kanal-0V sondern mit den F-Steuerungsspannungs 0V da der Kanal ja P- und M-schaltend ist. Es handelt sich dabei um ein Sicherheitschaltgerät welches für diesen Steuerungseingang keine separate ausgehende Masse hat.
 
Zuletzt bearbeitet:

Wincctia

Well-known member
Beiträge
762
Punkte Reaktionen
160
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo Fluffi,

laut diesem Dokument wird beim Bitmuster Test abwechselnd P und M geschaltet. Seite 30. Da steht aber auch dies ist abhängig von der Parametrierung aber wie dies abzuschalten ist steht leider nirgend.

der Unterschied zum Helltest ist hier, meiner Meinung nach ist hier das bei Empfohlener Verdrahtung kein Stromflies. Beim Helltest schon. Seite 25 unter Bild


Evtl Könntest du die Rücklesezeit Einschalttest mal reduzieren bis du eine Passivierung bekommst diese beeinflusst laut Seite 24 den Einschalttest





evtl. Bringt dich das ja etwas weiter


Gruß Tia
 
OP
F

Fluffi

Well-known member
Beiträge
395
Punkte Reaktionen
52
Das Digitalausgabemodul F-DQ 4×24VDC/2A PM HF führt, abgängig von der
Parametrierung, einen Bitmustertest durch.


Und da ich nicht die normalerweise bei dem Test vorliegende offene Gegenseite, sondern eine Verbindung auf M habe, schaltet mein Aktor.
Es gibt also Dunkel-, Hell- und den Bitmustertest (=Einschalttest). Ich hatte immer den Helltest mit dem Einschalttest gleichgesetzt. Sind sie aber nicht das selbe, auch wenn sie ähnlich sind. Leider kann man nur Dunkel- und Helltest deaktivieren und wie es scheint den Bitmustertest nicht, auch wenn in der Doku "abhängig von der Parametrierung" steht. Die Rücklesezeiten habe ich schon maximal reduziert, da ist leider nichts mehr rauszuholen
Vielen Dank Wincctia! Dank dir weiß ich nun endlich wo es herkommt. Auch wenn ich das Problem nicht direkt lösen werden kann, ist zumindest die Erkenntnis schon mal wichtig. Vielleicht hilft einem ja auch der Thread bei einem ähnlichen Problem weiter.
Meine Lösung wird wohl nun sein, Relais statt den Aktor direkt zu schalten, die können aufgrund der Trägheit die Impulse ab. Ist halt blöd wenn man einen Safety-Ausgang hat und das dann hier noch zusätzlich so realisieren muss, aber in den sauren Apfel muss ich nun beißen. Oder gibt es vielleicht von Siemens F-DQ Module die diesen Test nicht machen? Wobei ich davon nicht ausgehe, sonst wäre es ja bei meinem zumindest parametrierbar.
 
Zuletzt bearbeitet:

A3Q

Well-known member
Beiträge
341
Punkte Reaktionen
73
Bin in der IBN-Phase, hab daher das ganze Setup schon gefühlt 100x spannungslos gemacht.
Der Aktor ist lediglich einmal mit einem F-DQ Kanal verbunden und einmal mit Masse, allerdings nicht mit den Kanal-0V sondern mit den F-Steuerungsspannungs 0V da der Kanal ja P- und M-schaltend ist. Es handelt sich dabei um ein Sicherheitschaltgerät welches für diesen Steuerungseingang keine separate ausgehende Masse hat.
Müsstest du dann nicht die Versorung des Kanals deaktivieren?

EDIT:
Vergiss was ich gesagt habe. Das war ja du bei F-DI. Das mit der Masse hatte mich gerade verwirrt.
 
Zuletzt bearbeitet:

ioStart

Well-known member
Beiträge
139
Punkte Reaktionen
18
Zuviel Werbung?
->Hier kostenlos registrieren
Wir hatten auch mal das Problem mit einem Servo. Der ist auch nicht ausreichend träge gegenüber dieser Testschaltung. Diese kann man nicht deaktivieren.
Bei unserer Anwendung hat folgendes das Problem gelöst:
Bei der Parametrierung des Kanals kann man den Dunkeltest für 48 Stunden deaktivieren. Das bewirkt, dass der Dunkeltest nie mehr ausgeführt wird, wenn innerhalb dieser 48Stunden der Ausgang aus anderen Gründen einmal abschaltet.
 

rlw

Well-known member
Beiträge
321
Punkte Reaktionen
104
Hallo,
das Problem hat man auch mit Relais, die sehr schnell abfallen, (z.B. Kamm-Relais von Wago,) oder mit schnellen Eingängen von Umrichtern,
da geling es problemlos beim Dunkeltest den Umrichter zu stoppen.
Pilz hat da eine sogenannnte " Filterklemme" Best.Nr. 774196 erfunden, ist eine Diode mit nachgeschaltetem Kondensator.

gruß rlw
 

NBerger

Well-known member
Beiträge
905
Punkte Reaktionen
238
Nun Safety hört nicht an der SPS auf.
Auch die veerwendeten Relays müssen entsprechend Mindestanforderungen genügen.
Da sollte man nicht irgendwelche Kammrelays in einen Sicherheitskreis hängen und dann moppern wenns nicht geht. (Thema zwangsgeführte Kontakte, Manipulationsschutz...)
 

rlw

Well-known member
Beiträge
321
Punkte Reaktionen
104
Zuviel Werbung?
->Hier kostenlos registrieren
Nun Safety hört nicht an der SPS auf.
Auch die veerwendeten Relays müssen entsprechend Mindestanforderungen genügen.
Da sollte man nicht irgendwelche Kammrelays in einen Sicherheitskreis hängen und dann moppern wenns nicht geht. (Thema zwangsgeführte Kontakte, Manipulationsschutz...)

Das sind nicht irgendwelche Relais, sondern natürlich Relais die die Anforderungen für die Sicherhetstechnik erfüllen.
Wenn der Bitmuster-Test länger dauert als die Abfallzeit des Relais ist, dann öffnet eben der Kontakt.
Genau dafür wurde die Filterklemme von Pilz entwickelt, die hält die Spannung hinter Diode/Kondensator hoch damit der Aktor oder der Eingang diesen Einbruch nicht sieht.
 

NBerger

Well-known member
Beiträge
905
Punkte Reaktionen
238
Na also ein zusätzliches Bauteil das die Reaktionszeiten des Relays ändert... Natürlich wird dies auch in der Risikobeurteilung und Auslegung behandelt...:rolleyes:
 
Oben