Fehler 303 Verbindung zum AG gestört

Balou

Well-known member
Beiträge
221
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Mahlzeit

ich habe ein Problem mit einem OP 15 COROS an einer S5 115.

Die CPU hat 2 Schnittstellen das OP hängt an der 2 Schnittstelle.

Von Zeit zu Zeit fällt das OP aus und Zeigt folgende Meldung:

Code:
Fehler 303 Verbindung zum AG gestört

In diesem Fall ist keine Bedienung wie auch Störanjzeige mehr Möglich.

Man bekommt das OP nur wieder zur Funktion wenn man die SPS abschgaltet und wieder einschaltet.

Woran kann das liegen bzw. was kann man tun damit das nicht vorkommt.

Problem ist das es sich um Palettierer handelt die man nach dem CPU AUS wieder komplett neu einstellen muss (Sackzahl, Lagen, usw).

Wir haben das Problem von Zeit zu Zeit an all unseren Palettierern.

MfG Balou
 

smoe

Well-known member
Beiträge
334
Punkte Reaktionen
10
Ein Stop, Run schalten der Cpu reicht nicht aus? Wenn sich der Fehler nicht beheben lässt könntest du einen Neustart der OP Verbindung bei laufender CPU versuchen.

smoe
 

RolfB

Well-known member
Beiträge
130
Punkte Reaktionen
8
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo Balou,

das könnte an der Leitungslänge und fehlenden Zenerdioden liegen.
Wir hatten diesen Fehler damals bei einer selbst gefertigten Leitung
( ca. 140m Länge ) und durch Einlöten von zwei Zenerdioden, wie im
Siemens Beitrag 36661 beschrieben, war der Fehler behoben.

HTH

mit freundlichen Grüßen

RolfB
 
OP
B

Balou

Well-known member
Beiträge
221
Punkte Reaktionen
0
Hi

also das in den STOPP nehemn ist nicht der feine weg weil wir es mehrmals schon hatten das sich in dem moment die CPU und OP Daten unterschieden haben und es deswegen zu Fehlern kam die niemand definieren konnte.

Leitungslänge ???? sind ca. 15 m von Zenerdioden im Kabel weiß ich nix mich würde aber die Beschaltung Intressieren.

Das komische ist das es nicht immer auftritt und einige Daten scheinbar weiter Übertragen werden und andere wiederrum nicht.

Wir hatten das gleiche Problem schon mal damals war es aber ein Kabelfehler und auch ein Neustart der Anlage brachte keine Abhilfe.

MfG Balou
 
A

Anonymous

Guest
Hallo Balou,

die Zenerdioden (12V) kommen in den Stecker am OP:

1 x von Pin 15 (GND) in Richtung Pin 13+9 (ist ja gebrückt)
1 x von Pin 15 (GND) in Richtung Pin 11 (T20mA)

Die Gesamten Belegungen kannst du im Anhang der Siemens HMI Kommunikationsdoku finden.
Siemes schlägt die benutzung der Zenerdioden bereits ab einer Kabellänge über 10 Meter vor. Das würde ich als erstes mal versuchen.

Mit Verbindungsproblemen hatte ich anfangs auch zu kämpfen, hier ein Tip:

Nach dem aufruf des Standart FBs enthalt AKKU1 wohlmöglich eine Fehlernummer. Einfach direkt nach dem Aufruf des FBs den AKKU Wert mal in ein DW transferieren und schauen was er rausgibt. (Bei mir war es damals Fehler Nr. 115 (s.u.)

Eine Möglichkeit währe die Lifebit Überwachung:
Bei zu kleinen Zykluszeiten (hatte ich das Problem) oder zu grossen Datenmengen kann die Lifebit überwachung anspringen.
Im DW98 im Schnittstellenbereich des OPs kann der Wert der Überwachung z.B. auf KF +2000 (Zyklen) erhöht werden.

Sollte das nicht hinhauen versuche dochmal bevor du die CPU stoppst um provisorisch weiter zu kommen im Systemmenu des OP einmal Offline und wieder Online zu schalten.


Viel Glück!
 
Oben