IO-Link IODD-Datei gesucht

Ralle

Supermoderator
Teammitglied
Beiträge
14.854
Punkte Reaktionen
3.642
Zuviel Werbung?
->Hier kostenlos registrieren
Folgendes Problem:

IO-Link Master von Siemens: ET 200eco PN 4 IO-L + 8 DI + 4 DO (6ES7 148-6JA00-0AB0)
Sensor: LR-TB2000C von Keyence IODD Datei: KEYENCE-LR-T-20220301-IODD1.1

Der IO-Link-Master kann 4 IO-L + 8 DI + 4 DO anscheinend nur mit Version1.0, die Sensor-Datei hat Version 1.1
Im Device-Tool werden mir deswegen nur IODD mit Version 1.0 angezeigt.

Hat jemand für diesen Keyence-Sensor noch eine alte IODD mit Version 1.0? Im Netz ist einfach nichts zu finden außer KEYENCE_LR-T_IO-Link_V1_5.zip (und das ist V1.1)
 
OP
Ralle

Ralle

Supermoderator
Teammitglied
Beiträge
14.854
Punkte Reaktionen
3.642
Das fürchte ich auch. Ich bekomme noch eine andere Datei von Keyence.
Damit teste ich das. Geht nichts, kommt ein anderer IO-Link-Master, diesen von Siemens hatte der Kunde vorgeschrieben.
Es gibt noch einen ähnlichen von Siemens, der kann aber nur 4 IO-Links und keine E/A, wie der derzeitig vorhandene.
Der unterstützt aber V1.0 und V1.1.
Verstehen kann ich das nicht, warum liefert Siemens nicht auch FW für die Version 1.1, bei anderen Geräten machen sie es ja auch?

Eigentlich ein Ausschluß-Kriterium für IO-Link, wenn man jetzt auch noch zusehen muß, dass die Versionen zueinader passen. Das blickt ja keiner mehr.
 

Windoze

Well-known member
Beiträge
202
Punkte Reaktionen
102
Ich glaube bei IO-Link V1.1 ist eine neue Baudrate für die Kommunikation dazu gekommen. Evtl. unterstützt die Hardware das nicht.

Ich hatte aber mal exakt das selbe Thema mit dem ET200eco, war nur ein SensoPart Sensor.
Wir haben dann auch das 4xIO-Link Modul, was V1.1 kann, daneben gesetzt.
 

Blockmove

Supermoderator und User des Jahres 2019
Teammitglied
Beiträge
9.485
Punkte Reaktionen
2.541
Zuviel Werbung?
->Hier kostenlos registrieren
Das fürchte ich auch. Ich bekomme noch eine andere Datei von Keyence.
Damit teste ich das. Geht nichts, kommt ein anderer IO-Link-Master, diesen von Siemens hatte der Kunde vorgeschrieben.
Es gibt noch einen ähnlichen von Siemens, der kann aber nur 4 IO-Links und keine E/A, wie der derzeitig vorhandene.
Der unterstützt aber V1.0 und V1.1.
Verstehen kann ich das nicht, warum liefert Siemens nicht auch FW für die Version 1.1, bei anderen Geräten machen sie es ja auch?

Eigentlich ein Ausschluß-Kriterium für IO-Link, wenn man jetzt auch noch zusehen muß, dass die Versionen zueinader passen. Das blickt ja keiner mehr.

Wo es geht, versuche ich IO-Link ohne IODD zu verwenden.
Bei vielen Devices funktionieren die zyklischen Prozesswerte auch ohne Konfig (IODD) auf dem Master.
Steck doch mal deinen Sensor an und schau, ob irgendwelche Werte rüberkommen.
 

olliew

Well-known member
Beiträge
141
Punkte Reaktionen
25
Ich glaube bei IO-Link V1.1 ist eine neue Baudrate für die Kommunikation dazu gekommen. Evtl. unterstützt die Hardware das nicht.
In IO-Link v1.0 war die COM3 / 230.4 kbps noch optional für den IO-Link Master. Das ist naturlich doof und wurde in v1.1 korrigiert.

6ES7148-6JA00-0AB0 unterstützt COM3 laut Datenblatt nicht, somit gibt es kein v1.1.
Wenn der Keyence LR COM3 verwendet oder kein Ruckfall auf v1.0 ermöglicht, dann kommen die beide schlicht nicht 'zusammen'.


diesen von Siemens hatte der Kunde vorgeschrieben.
Eventuell mit Kunde besprechen, mit das relativ alte Teil von Siemens wird es immer wieder Überraschungen geben.
 
OP
Ralle

Ralle

Supermoderator
Teammitglied
Beiträge
14.854
Punkte Reaktionen
3.642
Alles klar, vielen Dank für eure Rückmeldungen.
Ich brauche einen anderen Master. Ausgerechnet dieser eine, kann das nicht und Keyence kann nur V1.1.

@Blockmove
Online kommt leider nichts an, hab mal ein generisches Protokoll reingesetzt und geschaut, leider nada.
PS: Was ja nach den Ausführungen oben der Kollegen auch irgendwie logisch ist.
 

AUDSUPERUSER

Well-known member
Beiträge
1.928
Punkte Reaktionen
817
Zuviel Werbung?
->Hier kostenlos registrieren
IO-Link 1.0 und 1.1 unterscheiden sich nicht nur dadurch, dass es bei 1.1 auch COM3 gibt.
Es gibt Datastorage = automatische Reparametrierung der Geräte, und die Umschaltung der Betriebsart.
Der Protokollaufbau ist anders, und das ist das Problem.

IO-Link 1.0 kam nur notgedrungen auf den Markt, eigentlich sollte diese Version gar nicht veröffentlicht werden.

Es gibt Geräte, die sowohl SIO (konventioneller Anschluss) IO-Link 1.0 und IO-Link 1.1 unterstützen.

Da IO-Link 1.0 aber fast tot ist, bauen das manche Hersteller gar nicht mehr ein.
Für die paar IO-Link Master, falls die überhaupt noch zum Einsatz kommen, die kein 1.1 unterstützen lohnt sich das auch nicht mehr.

In Deinem Fall natürlich doof, weil es Dich mit einer solchen Kombination trifft.

Siemens, aber auch andere Hersteller, wie ifm electronic, Balluff, Turck, Murr usw. haben IO-Link Master im Angebot, die IO-Link auch voll unterstützen.
 
Oben