IPC477C und TIA V11

honeytbone

Member
Beiträge
10
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Hardware:
IPC477C mit WIN7 embedded und WIN AC RTX 2I/E Ports
PC mit TIA V11
Ich komme nicht auf das Panel bzw. auf die Soft SPS
Pingen funktioniert.
Siemens hat doch bestimmt auch dafür ein Beispiel parat, dass ich nur nicht finde?
Hat jemand vielleicht eine Idee, wo ich eine Schritt für Schritt Anweisung finde oder kann mir jemand einen Tipp geben, wie die IE Schnittstellen und das WIN LC RTX konfiguriert werden müssen?

Erfolglos.PNG Hab ich den Aufbau so richtig gemacht?
Als IP Adresse für IE2 habe ich 192.168.1.30 und für IE_1 192.168.1.161. PC hat 192.161.1.5.
 

rostiger Nagel

Forums-Knochenbrecher
Teammitglied
Beiträge
15.051
Punkte Reaktionen
4.728
Am PC gibt es einen Komponenten Konfigurator (KoKo), dort kannst du den Aufbau des IPC Virtuell
durchführen, dadurch weiß die Soft SPS wie du mit ihr kommunizieren möchtest.

Da deine beiden Schnittstellen Profinet werden sollen und du diese noch unter den Windows
Einstellungen verändern kannst, kann die richtige Einstellung noch nicht im KoKo eingetragen sein.,
da diese, sobald Sie PN sind nicht mehr aus der Windows Ebene nutzbar sind.

Deshalb Rate ich dir, nur einen Schnittstelle als PN zu konfigurieren die andere lässt für Windows
Anwendungen und zur Kommunikation.
 
OP
H

honeytbone

Member
Beiträge
10
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Hmm,
ich habe es jetzt geschafft, ich kann mit dem IPC Verbindung aufnehmen habe aber immernoch einen Fehler in einer unterlagerten Baugruppe. Ich kann aber den Baum komplett öffnen und er zeigt mir nirgends einen Fehler an? Bei WinAC RTX ist ein grüner Punkt und bei den Programmbausteinen.
Um auf den IPC zu kommen habe ich den EWF deaktiviert, neugestartet und aus dem TIA Portal eine IP Adresse zugewiesen.

Im Koko habe ich auch nachgeschaut, da war eine Verbindung IF2 auf die onboard Netzwerkkart gemapt. Ich denke daran lag es nicht. Wo sehe ich die IP Adresse welche von WinAC verwendet wird. Ist es die, die auf dem IPC in den Netzwerkeinstellungen der Netzwerkkarte zu sehen ist?
 
OP
H

honeytbone

Member
Beiträge
10
Punkte Reaktionen
0
Vielen Dank erstmal für die schnelle Antworten:p
Im Koko sind alle Funktionen deaktiviert, trotz deaktiviertem EWF und gestoppten WinAC. Ich kann im Tab Submodule weder Edit.., add, Diagnostic noch sonst etwas ausführen.
 

rostiger Nagel

Forums-Knochenbrecher
Teammitglied
Beiträge
15.051
Punkte Reaktionen
4.728
Zuviel Werbung?
->Hier kostenlos registrieren
Wenn deine CPU läuft muss Sie abgeschaltet (nicht Stop) oder in RUN-P Modus befinden.
Es ist aber immer besser abzuschalten, das ist wie mit eine Hardware SPS, da schaltest
du diese ja ich aus wenn du Baugruppen steckst.

Mach Doc mal einen Screenshot vom KoKo mi den Submodulen in der CPU.
 
OP
H

honeytbone

Member
Beiträge
10
Punkte Reaktionen
0
Ok, funktioniert. Jetzt möchte ich noch ein wenig dezentrale E/A einbinden. ET200SP IM155-6PN ST mit ein paar E/A. Also im TIA Portal als dezentrale E/A eingefügt, in der Netz Ansicht mit dem WinAC des IPC verbunden und diesem auch zugeordnet.
GeräteUndNetze.jpg
Alles übertragen und versucht online zu verbinden und geht nicht...
Was ich nicht verstehe:
Ich möchte mit dem Laptop auf den IPC zugreifen und darf nur auf den WinAC zugreifen 192.168.0.30 und die Dezentrale E/A wird aber auch diesem Port zugewiesen kann das sein? Weil PN und IE? Ich habe zwei PN/IE Ports am IPC. Ich will mich auf einen mit dem Laptop verbinden als Programmier Schnittstelle und auf dem anderen möchte ich die dezentrale E/A anschließen. Ist die denkweise falsch?
Muss ich auf dem IPC eine neue Schnittstelle für die dezentrale E/A anlegen z.B. auf IF1?
koko.png
 

rostiger Nagel

Forums-Knochenbrecher
Teammitglied
Beiträge
15.051
Punkte Reaktionen
4.728
Grundsätzlich geht das was du vorhast, da ja noch eine Schnittstelle frei ist, füge diese
als IE-Allgemein auf einen freien Steckplatz zb 3 ein ( Achtung nicht in der WinLC ), über
diese kommunizierst du dann zum Projetierungsrechner.
 
OP
H

honeytbone

Member
Beiträge
10
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
DAAAANNNNKKKEEEEE! Hat soweit alles funktioniert, jetzt habe ich auf alles Zugriff und habe glaube ich die Basics begriffen. Morgen werde ich versuchen noch die FUs einzubinden und dann steht schonmal das Hardware Gerüst und ich kann anfangen zu programmieren.
Ohne deine Hilfe hätte ich wahrscheinlich eine Woche gebraucht um so weit zu kommen...und nerven um mich durch den Siemens Support zu kämpfen.
Eigentlich sollte Siemens dich bezahlen für den Support den du hier gibst!
Danke nochmal
 
Oben