Master-Slave-Kommunikation zwischen Siemens-CPU und VIPA-CPU

SPS-Beginner

New member
Beiträge
1
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo zusammen,
ich habe ein Problem beider Kommunikation zwischen einer Siemens CPU 319-PN/DP und einer VIPA CPU 315SN/NET
Die Siemens ist dabei als Master konfiguriert, die Vipa als Slave.
Das Einbinden der Vipa-Steuerung war kein Problem und der Profibus läuft ebenfalls problemlos. Der Datenaustausch läuft teilweise.
Konfiguriert ist das ganze so:
EB10 beim Slave --> AB610 beim Master; Länge 1 Byte; Konsistenz gesammt
AB10 beim Slave --> EB610 beim Master; Länge 10 Byte; Konsistenz gesammt

so weiterführend in 10er-Sritten bis zu EB/AB80
Probleme gibt es komischerweise nur bei den Ausgangsbytes AB30 & AB40
Da bringt mir der Diagnosepuffer 4 Fehlermeldungen:
"Peripheriefehler beim Übertragen der Ausgänge aus dem Prozeßabbild auf die Ausgänge bei AB30."
Selbe Fehlermeldung für die AB34; AB40; AB44
Die Vipa bringt eine SF-Störung.
Wenn ich diese 20 Ausgangsbytes aus der Konfiguration rausnehme funktioniert alles einwandfrei.
Alles andere an Kommunikation und Austausch funktioniert tadellos.
Habe nun mit Hilfe von Kollegen bereits einiges ausprobiert und komme zu keiner Lösung.

Ich hoffe sehr, dass ihr für mich Lösungsansätze habt, die zum Erfolg führen und bedanke mich im vorraus für die freundliche Hilfe.
 

hovonlo

Well-known member
Beiträge
242
Punkte Reaktionen
79
Einfach mal den Vipa-Support kontaktieren, hierzu vielleicht auch gleich mal das erstellte Projekt (zumindest die HW-Konfig) mit bereitstellen.
 
Oben