Motor Zeitschaltung

Pliskin

Member
Beiträge
7
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo liebe Gemeinde,

Ich bin seit ein paar Tagen dabei mir eine Zeitschaltung für eine Motorsteuerung zu programmieren. Trotz der schon vielen threats zu diesem Thema hoffe ich das ihr mir noch mal damit weiter helfen könnt. Ich habe das Forum schon weit durchsucht und habe meiner Meinung nach auch die meisten Tipps richtig angewandt aber leider will mein Ausgang nicht im gewünschten Zeitfenster anspringen. Ich hab euch mal einen Screenshot von meinem Programm beigefügt.


Da ich hier neu bin und dies mein erster Post ist noch kurz zu meiner Person. Ich mache gerade mein Fachpraktikum in einer Produktionsautomatisierungsfirma und befasse mich nun seit ca zwei wochen mit Step7 und bin sehr davon angetan :)

Also ich hoffe wir können uns in Zukunft weiter helfen
Vielen dank schon mal im voraus

Mfg Pliskin
 

Anhänge

  • Zeitschaltuhr.jpg
    Zeitschaltuhr.jpg
    103 KB · Aufrufe: 52

borromeus

Well-known member
Beiträge
2.270
Punkte Reaktionen
329
Als bei Dir ist es 10:49!
Die Bedingungen sind erfüllt, der Ausgang =1

@Mäuseklavier: /D *D nimmt die Millisekunden weg...
 
OP
P

Pliskin

Member
Beiträge
7
Punkte Reaktionen
0
Ja richtig wird dort als 1 angezeigt, allerdings wird in der Variablentabelle der Ausgang mit false gekennzeichnet und ich habe eben nach dem ich deine Antwort gelesen habe das Programm noch mal auf die richtige CPU drauf gespielt (vorher nur über PLCsim) und auch dort das selbe. Weder die Ausgangsleuchte leuchtet noch springt der Motor an.

Gruß
Pliskin
 
OP
P

Pliskin

Member
Beiträge
7
Punkte Reaktionen
0
@Mäuseklavier: Hier noch mal ein Bild mit dem Netzwerk woher das out_Uhrzeit stammt.

Also meine Uhrzeit wird auch ja richtig angezeigt nur scheint etwas mit dem Vergleich vielleicht nicht zu stimmen?!
 

Anhänge

  • Zeitschaltuhr.png
    Zeitschaltuhr.png
    31,5 KB · Aufrufe: 14
OP
P

Pliskin

Member
Beiträge
7
Punkte Reaktionen
0
ja das wird er auch aber nur als ausgang mit irgendwelchen vorbedingungen spricht E01&M20.0 =A4.1 , ich habe ihn nirgendwo negiert. Denke er könnte doch nur blockiert sein wenn er irgendwo negiert wird oder ?!
 

Sinix

Well-known member
Beiträge
1.588
Punkte Reaktionen
216
Wie schon so oft hier im Forum:
Es ist ratsam Ausgänge nur an einer Stelle im Programm zu schreiben.:D
 
Oben