Portweiterleitung im Router und Zugriff mit Step7 (wie von PN/DP beschriebene)

Jochen Kühner

Well-known member
Beiträge
4.201
Punkte Reaktionen
484
Zuviel Werbung?
->Hier kostenlos registrieren
Ich verusuche zur Zeit mit einem Kollegen die Verbindung zu einer PLC wie von PN/DP im Beitrag hier beschriben: http://www.sps-forum.de/showthread....er-das-Internet-mit-Step7?p=218061#post218061 hinzubekommen.

Problem: Es klappt nicht.

Was Ich mich nun aber Frage ist, wieso das Überhaupt Funktionieren sollte? Step7 denkt ja, wenn Ich es wie im beispiel einrichte, das die erste PLC die IP 82.176.x.x hat. Daher verbindet es sich doch dann mit dieser und versucht nun dieser zu sagen das Sie eine Routing Verbindung zur 2-ten PLC aufbauen soll. Das problem ist ja aber das Step7 ja in wirklichkeit schon mit der 2ten PLC verbunden ist, da ja der Port 102 im Router zu dieser weitergeleitet wird!

Oder hab ich da einen Denkfehler?

Was kann ich noch falsch gemacht haben? Netpro wurde nach allen Einstellungen auf die CPU übertragen!
 

PN/DP

User des Jahres 2011-2013; 2015-2017; 2020-2021
Beiträge
19.470
Punkte Reaktionen
5.871
Hast Du im Projekt ein PG/PC dem Ethernet(WAN) zugeordnet?
Ist in der 2. PLC die interne Adresse des Firmen-Gateways als Router eingestellt (im Beispiel die 192.168.10.254)?

Im PG-"Home"-Netzwerk darf es nicht gleiche Adressbereiche wie im fernen Firmen-Netzwerk geben.
Die PG/PC-Schnittstelle darf nicht auf TCP/IP(Auto) eingestellt sein.

Harald
 
OP
Jochen Kühner

Jochen Kühner

Well-known member
Beiträge
4.201
Punkte Reaktionen
484
Zuviel Werbung?
->Hier kostenlos registrieren
Alle 4 Punkte ja...

Den Webserver der PLC kann ich durch Eingabe der Routeradresse auch erreichen.

Und laut Wireshark probiert sich Step7 auch mit dem Router zu verbinden.

Mir ist nur immer noch nicht klar warum das überhaupt funktionieren sollte...
 
Oben