Probleme mit einer S7/300, CP 342-5, an einem Sinec L2 Bus

badbikerkiel

Member
Beiträge
16
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Hi,
ich habe folgendes Problem:
Wir haben in unserer Fa. ein Sinec L2 Profibus, an diesem Profibus sind 17 Teilnehmer ( S5 AG´s ) angeschlossen ( CP5430TF und S5-95U mit Sinec L2 Schnittstelle ). Zusätzlich wollen wir einen 18. Teilnehmer einbinden, eine S7/300 mit einem CP342-5 als AG-AG Verbindung.
Projektierungsbeispiel habe ich mir bei Siemens Support heruntergeladen und die S7 mit den Busparametern des Sinec L2 Netzes parametriert.

Über die Sinec NCM Software habe ich die Baudrate 187,5...höchste Teilnehmeradresse 18....5 fremde aktive TLN.(95U). eingestellt und die globalen Busparameter berechnen lassen. Anschließend habe ich die neuen Datenbasen in die CP`s übertragen und im jeweiligen DB1 der S5-95U die Parameter verändert. Ohne die S7 läuft der L2 Bus dann sehr stabil!

Wenn ich den CP342-5 an das L2 Bussystem aufstecke, meldet sich die Station 18 im logischen Token Ring an. Gleichzeitig wird aber der Teilnehmer 17 ( S5-95U ) aus dem Token Ring entfernt und die 95U meldet einen BF. Alle anderen Stationen sind im Token Ring.
Wenn ich den S7/ CP 342-5 von unserem Bus entferne und die 95U neu starte, befindet sie sich wieder als TLN. 17 im Token Ring.
Der Teilnehmer 17, ist der letzte am Buskabel angeschlossene Teilnehmer.

MerKwürdig ist auch, das, wenn ich mir das ANZW des SEND bzw. REC. im S5 AG ( der Station die Datenaustausch mit der S7 betreiben soll )betrachte, der Auftrag machmal als "fertig ohne Fehler" bearbeitet wird und am nächsten Tag steht dann permanent ein Fehler an.

Die NCM Software zeigt mir als Fehler: 0008 keine remote Resourcen.

Aber das größere Problem ist für mich noch der Rausschmiß des Teilnehmers 17, das andere werde ich dann schon irgendwie hinkriegen.

Würde mich freuen, wenn jemand aus dem Forum, eine Lösung für mich hätte.

Achim
 
A

Anonymous

Guest
Meine Vorschläge
1. Richtige SAPS geschrieben ?
2. HSA höher setzen (aus Erfahrung stört nicht)
3. SPS S7 auch als „fremde“ unter NCM anmelden
4. TTR Faktor höher setzen (besonders bei schnellen SPS)
5. SPS S7 auf andere Stelle versetzen (ich weiß total blöd aber ..)
6. Andere TLNR für S7 nicht 18 sondern z.B. 20
7. Senden (von S7 Seite) nur dann wenn Änderungen vorhanden (S7 ist zu schnell für S5 CPs)
8. Netzabgleich gemacht ? (unter NCM d.h. Netzparameter global = lokal ?)

Ich habe schon oft bis 30 SPS von Siemens vernetzt. Deswegen sind mir die Probleme bekannt.
 
OP
B

badbikerkiel

Member
Beiträge
16
Punkte Reaktionen
0
Hallo "Taddy", danke für deine Vorschläge!


Deine Vorschläge

1. Richtige SAPS geschrieben ? Habe ich kontrolliert, sind richtig!
2. HSA höher setzen (aus Erfahrung stört nicht). Habe ich auf 31 Teilnehmer gesetzt.
3. SPS S7 auch als „fremde“ unter NCM anmelden. Habe die S7 als 6. fremden TLN in die NCM Busparameter für unseren Bus aufgenommen.
4. TTR Faktor höher setzen (besonders bei schnellen SPS). Lasse ich vorerst aus.
5. SPS S7 auf andere Stelle versetzen (ich weiß total blöd aber ..) Die Stationen liegen sehr weit auseinander ( bis zu 200m ).
6. Andere TLNR für S7 nicht 18 sondern z.B. 20. Guter Vorschlag, werde ich am Donnerstag ausprobieren.
7. Senden (von S7 Seite) nur dann wenn Änderungen vorhanden (S7 ist zu schnell für S5 CPs). Die S7 muss mit der S5 zyklisch zusammenarbeiten, da beide Steuerungen voneinander abhängig sind und Antriebe geschaltet und überwacht werden.
8. Netzabgleich gemacht ? (unter NCM d.h. Netzparameter global = lokal ?) Auf jeden Fall, alle Parameter sind in den Stationen ( S5 CP´s, S5-95U und der S7) gleich.

Ich werde erst wieder am Donnerstag die S7 am Bus betreiben.
Heute habe ich erst einmal deine Vorschläge angewandt und dementsprechend in die Datenbasen übertragen.

Ich hoffe, dass es am Donnerstag klappt und der letzte Teilnehmer nicht wieder herausgeschmissen wird :(

Werde mich auf jeden Fall melden!

Vielen Dank noch einmal, Achim
 
A

Anonymous

Guest
Hallo Achim !
Ich glaube nicht, dass Du Fehler in Deinem Projekt hast. Ich kann aber (wenn Du möchtest) eine ähnliche Anlage als Zip-Datei schicken. Ich habe damals folgende SPS verbunden: 3 X SPS 135, 4 X 95U (mit L2 Schnittstelle) und 5 oder 7 SPS 115 dazu PC als FMS Teilnehmer. Alle SPS S5 haben CP 5431 und kommunizieren mit AG-AG Protokoll, zusätzlich auch FMS mit dem PC (natürlich nur ein Busskabel, Cu, ohne Verstärker). Außer L2 und FMS müssen die SPS zusätzlich mit ASI, Sinaut und DP „kämpfen“.Gesamtlänge ca. 500 Meter. Als letzte habe ich vor ca. 2 Jahren eine SPS S7 (315 2 DP) mit dem CP 342-5 eingebunden (identisch wie Deine Anlage). Alles ohne Probleme.
 
OP
B

badbikerkiel

Member
Beiträge
16
Punkte Reaktionen
0
Hallo Taddy,

erst einmal vielen Dank, für deine Bemühungen.

Also, die 2 Stationen, die S7 und die S5 Station kommunizieren jetzt ohne Probleme miteinander. ( in meinem Fall TLN 12 -die S5 und TLN 18 -die S7 ). Das merkwürdige war, dass nach einer Änderung der Parameter in der S5 Station ( SEND - Baustein ) z.B. Änderung der Anzahl der zu übertragenen Datenworte, die S7 erst nach einem Netz AUS/EIN die Kommunikation mit der S5 korrekt quittierte ( zu sehen in dem Anzeigenwort auf der S5 Seite ) und damit der Empfang in der S7 funktioniert.

Das wusste ich nicht!
Dies wirft bei mir noch einige Fragen auf.

Weiterhin besteht aber das Problem des herausgeworfenen TLN 17,
der als letzter TLN am Bus liegt.
Unserer Meinung nach müßte dies ein Hardwareproblem sein.
Wir benutzen den Busterminal Siemens RS 485 _6GK1500-0AA00.
Es kommt uns so vor, als wenn bei aufgestecktem CP 342-5 ( über den RS 485 Busterminal ) die nachfolgende Busstrecke einfach terminiert wird und so der nachfolgende TLN aus dem Netz fliegt.
Ich habe das Teil auch schon einmal ausgetauscht, weil ich die Vermutung hatte die Busklemme ist defekt. Aber der Erfolg ist der gleiche.

Vielleicht weisst du, ob wir uns den Terminal mit der Bestellnr.
6GK1500-0AA10 besorgen müssen.
Der sieht ja etwas anders aus.
Ich habe aber leider keine nähere Beschreibung über das Teil gefunden.

Viele Grüße aus Kiel, Achim
 
A

Anonymous

Guest
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo Achim

Seit Jahren nutze ich kein Busterminal. Du kannst das Buskabel direkt in einem Busstecker verbinden. Die Stecker haben sogar Endwiderstände. Nicht vergessen, wenn dein Kabel zu kurz ist, darfst du keine Stichleitungen machen. Beide Enden der Buskabel müssen entweder in einem Busterminal oder in einem Stecker enden. Auf deiner Stelle würde ich ohne Busterminal versuchen. Ein Busterminal ist kein Verstärker sonder Verdrahtungshilfe.
Noch eine Sache. In S7 sollte man immer die neuen Versionen der FC 5 und 6 von Siemens nutzen. Ich habe schon mehrere Stunden investiert um den Fehler zu finden. FC 5 AG_SEND V4.2 FC 6 AG_RECV V4.7
Ich schicke dir auch Daten des Busterminals.

Verschiedene Ausführungen sind erhältlich:
 Bis 1,5 Mbit/s
Busterminal RS 485
 Bis 12 Mbit/s
Busterminal 12M.
Für alle Ausführungen gilt:
 Gehäuse in IP20-Technik.
 Wandmontage oder Montage auf tiefer Standardhutschiene möglich.
 Außenliegender 6-poliger Klemmblock zum Anschluss von ankommender und abgehender Busleitung und Potentialausgleichsleitern.
 Integrierte Steckleitung mit Sub-D-Stecker zum Anschluss der Teilnehmer.
 Abschlusswiderstandskombination über Drehschalter zuschaltbar.
Für das Busterminal 12M gilt zusätzlich:
 Bereiche für Übertragungsraten über Drehschalter einstellbar.
 Versorgung des Busterminals 12M durch den angeschlossenen PROFIBUS-Teilnehmer (DC 5 V/90 mA) über 9-polige Sub-D-Buchse.
 Maximale Segmentlängen siehe Technische Daten.
 Ankommende und abgehende Busleitungen werden beim Einlegen der Abschlusswiderstände aufgetrennt.
 
OP
B

badbikerkiel

Member
Beiträge
16
Punkte Reaktionen
0
Problem gelöst!!

Nun doch, nach langer Zeit möchte ich mich melden und mich besonders bei Taddy bedanken.

Die Schwierigkeiten die in unserem Sinec L2 auftraten haben wir behoben....freu!
Das Problem, war die Segmentlänge unseres Netzes, die wir scheinbar überschritten hatten....dies habe ich durch einen Test ( Aufteilung des Netzen in 2 Segmente ) festgestellt.
Nach Aufteilung des Netzes in 2 Segmente,
haben sich alle Profibusteilnehmer ohne Murren an unserem Sinec L2 Bus ngemeldet.

Achim
 
Oben