S7-1200 schneller Zähler

cooper512

Member
Beiträge
8
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Ich habe eine CPU S7-1200 – 1212. Zur Positionierung eines Bauelementes meiner Anlage habe ich einen Inkrementalgeber mit 500 imp / 1-min eingebaut und an den schnellen Zähler HSC_1 angeschlossen. A/B Kanal geht an E0.0/E0.1 Rücksetzeingang ist E0.3 = Endlage meiner Anlage. Das mir einen Genauigkeit von ca. 1mm vollkommen ausreicht, werte ich das Ergebnis des Zählers selbst aus. (s. Anlage).
Mein Problem ist jetzt, das das ED1000mit meinem Zählerwert in unregelmäßigen Abständen sich auf nullstellt, ohne das E0.3 aktiv ist.Kennt jemand das Problem oder hat einenLösung?

s7-1200-zähler.jpg
 

hucki

User des Jahres 2014
Beiträge
5.550
Punkte Reaktionen
1.651
Zuviel Werbung?
->Hier kostenlos registrieren
Ist in der HW-config vielleicht ein Eingang zum Rücksetzen aktiviert?
Ja:
... Rücksetzeingang ist E0.3 = Endlage meiner Anlage. ...


@cooper512,
vlt. zeigst Du mal noch Deine genaue HSC-Config.
Hast Du vlt. noch irgendwo den CTRL_HSC für den HSC1 benutzt?
Und ganz sicher, dass der E0.3 nicht auch nur kurzzeitig den Pegel wechselt (mal abklemmen)?
 

Tigerente1974

Well-known member
Beiträge
1.815
Punkte Reaktionen
289
Und ganz sicher, dass der E0.3 nicht auch nur kurzzeitig den Pegel wechselt (mal abklemmen)?

Da sehe ich auch die wahrscheinliche Ursache. Zumindest kann man dann nicht mehr sicher ausschließen, dass doch mal ein Impuls gekommen ist. Ich kenn mich mit TIA leider nicht aus. Kannst Du ggf. einen Merker nehmen, um den Zähler zurückzusetzen?
Dann könntest Du den E0.3 im SPS-Programm auswerten und den Zähler "von dort" zurücksetzen. Dann kannst Du Dir auch einen Testmerker oder einen Zähler dranhängen um Fehlimpulse zu erkennen.
 
Oben