S7-300 Analoge Höhen/Distanzmessung 4-20mA

Marius86

Member
Beiträge
22
Punkte Reaktionen
2
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo!

meine Aufgabe ist es mit Hilfe eines Distanzsensors die Höhe eines Förderguts festzustellen und diese mit einem Bit Signal anzuzeigen (Es gibt nur 4 verschiedene Größen).
Programmiertechnisch ist das kein Aufwand, aber ich habe noch nicht mit Analogen Baugruppen gearbeitet und möchte nicht die Falsche bestellen.

Als Distanzsensor steht mit der DT35 von Sick zur Verfügung.

Als Analoge Baugruppe habe ich mir die 6ES7331-7KB02-0AB0 mit zwei Analogen Eingängen ausgemacht. Eine billigere Variante konnte ich nicht finden und der Sensor erlaubt die Einstellung auf 4-20mA genau wie die Baugruppe.
Die Auflösung von 12-Bit ist auch ausreichend (Messbereich ~1000mm).
Die kleinste Größendifferenz des Förderguts beträgt 30mm. Dass müsste mit der Tolleranz von 10mm des Sensors auch ausreichen oder übersehe ich hier etwas? (Ich kann mit den Begrifflichkeiten Remission und Reproduzierbarkeit nicht viel anfangen. Ich vermute Remission ist die "Reflektierfreundlichkeit", was in unserem Fall aber uninteressant ist, da der Gesamtabstand sowieso <3000mm ist).

Habe ich etwas bei der Auslegung übersehen?

Mein Hauptproblem ist der Anschluss. In der PDF ist der Anschluss eines 2DMU und 4DMU beschrieben. Aber liegt mir hier mit dem Sensor nicht ein 3DMU vor? (Q2/Qa = Ausgangsstrom, L+ = Versorgungsspannung, M = Masse für Versorgungsspannung und Ausgangsstrom)
Ich bin mir auch nicht sicher ob ich das Anschlussbild allgemein richtig verstehe. (Seite 366)
Was mache ich mit dem zweiten Eingang, der nicht benutzt wird?

http://www.google.de/url?sa=t&rct=j...sICQAw&usg=AFQjCNEDfRr3_62T5WGA3cbn4ssU9nxqWA
Tut mir Leid für den langen Link, irgendwie funzt das Linken nicht so wie ich möchte ;)

Im Anhang befinden sich die Dokumente des Distanzsensors.

Grüße Marius
 

Anhänge

  • online_data_sheet_DT35-B15251_de_20120507_1225[1].pdf
    1,1 MB · Aufrufe: 43
  • im0044955.pdf
    1,4 MB · Aufrufe: 30

AndreK

Well-known member
Beiträge
415
Punkte Reaktionen
27
Ich würde den als 2 Leiter anklemmen... +Analogausgang des Sensors in den + Eingang der Karte, - der Karte zum Massebezugspunkt des Sensors. Würfel oder HW-Software auf 4-20mA stellen... und im FC105 bei Hi_LIM und Lo_LIM die Skalierungswerte vom Sensor eintragen... also z.B. Lo_LIM 300mm und bei Hi_LIM 1000mm... dann bekommst du am Ausgang deinen Abstand in mm. Geht natürlich auch in %, oder was weiß ich...

Das jetzt mal ohne deine Links und Datenblätter zu sichten...
 
OP
M

Marius86

Member
Beiträge
22
Punkte Reaktionen
2
Zuviel Werbung?
->Hier kostenlos registrieren
Danke für den Hinweis mit dem Baustein. Ich hatte das zwar schon manuel umgesetzt, aber so sieht es doch etwas besser aus.

Mein Problem ist immernoch der Anschluss. Denn die Begrifflichkeit Eingang/Kanal und Kanalgruppe werden ziemlich durcheinander benutzt.

Auf Seite 374 steht, dass nicht beschaltete Kanäle kurzgeschlossen werden sollten. Nicht benutzte Eingänge in einer Kanalgruppe sollen allerdings frei gelassen werden. Was liegt bei mir vor?
In der Zeichnung auf Seite 366 steht CH0 und CH1 dabei (Was übersetzt eigentlich Kanal 0 und 1 heißen sollte.). Allerdings denke ich dass damit die Eingänge gemeint sind.

Wenn ich es richtig verstehe, habe ich eine Kanalgruppe mit zwei Eingängen auf meiner Baugruppe. Denn andernfalls könnte ich in der HW Config mehrere Messbereiche einstellen (für mehrere Kanalgruppen), was nicht der Fall ist.

Also CH1 offen lassen, korrekt?
 

borromeus

Well-known member
Beiträge
2.270
Punkte Reaktionen
329
1. Das ist eindeutig ein Vierleitermessumformer-> Messbereichsmodul Stellung C
2. daraus folgend Kanal 1 in Serie schalten mit Kanal 0
 
OP
M

Marius86

Member
Beiträge
22
Punkte Reaktionen
2
1. Das ist eindeutig ein Vierleitermessumformer-> Messbereichsmodul Stellung C
2. daraus folgend Kanal 1 in Serie schalten mit Kanal 0

Und was ist dann mein zweiter Masse Anschluss? Oder meintest du damit, dass es wie ein Vierleitermessumformer angeschlossen wird?

Also schließe ich wie folgt an:

S=Sensor, B=Baugruppe
S1. L+ --- +24V extern
S3. M --- 0V extern

B1. L+ --- +24V extern
B20. M --- 0V extern

S2. Qa --- B2. M0+
B3. M0- --- B4. M1+
S3. M --- B5. M1-

Des weiteren brücke ich Comp+, Comp-, M0- und M1-.

So richtig? Ich werde es wohl nochmal aufzeichnen.
 

borromeus

Well-known member
Beiträge
2.270
Punkte Reaktionen
329
Zuviel Werbung?
->Hier kostenlos registrieren
Das Gerät bekommt eine 24V Versorgung
es gibt 4-20mA am Qa (vermute ich mal) aus.
Dieser Draht geht auf der Karte beim + rein.
Minus wird überall derselbe sein, vermute ich mal.

Comp kannst du brücken.

In DEINER Anleitung auf Seite 374 steht dass Du Kanal 1 durchschleifen sollst.

Die 24 V vom Gerät kannst Du natürlich von der gleichen Spannung wie die der SPS-AE-Karte nehmen, besser wäre es diesen + auf eine Sicherung zu hängen. Dann kannst Du separat einsichern.
 
OP
M

Marius86

Member
Beiträge
22
Punkte Reaktionen
2
So, die Skizze habe ich mal angehängt.

Mir ging es jetzt auch nur darum, ob man das technisch als 3DMU oder 4DMU bezeichnet. Aber dass es als 4DMU verdrahtet wird, macht Sinn. Denn die Einspeisung ist vom Ausgangssignal getrennt. Und das ist beim 2DMU nicht der Fall.

Danke schonmal.
 

Anhänge

  • skize.JPG
    skize.JPG
    28,7 KB · Aufrufe: 64

borromeus

Well-known member
Beiträge
2.270
Punkte Reaktionen
329
Bitte lesen!
Du sollst den Kanal1 mit Kanal 0 durchschleifen wie im Handbuch.
Wenn Du das nicht machts wird nichts passieren, da Du dieses Handbuch aber erwähnt hast habe ich den darin enthaltenen Text an Dich weitergeleitet.
 
OP
M

Marius86

Member
Beiträge
22
Punkte Reaktionen
2
Zuviel Werbung?
->Hier kostenlos registrieren
Du meinst doch diesen Satz:
"Strommessung 4 bis 20 mA, 4-Draht-Messumformer: Unbenutzten Eingang mit Eingangder gleichen Kanalgruppe in Reihe schalten."

Ich stehe jetzt etwas auf dem Schlauch. Aber schalte ich die Eingänge nicht in Reihe, indem ich M0- mit M1+ brücke und mein Ausgangssignal auf M0+ und meine Masse auf M1- lege?

Die Schaltung oben sieht anders aus, weil ich den Comp noch wie in der Zeichnung auf Seite 366 mit den M0-/M1- gebrückt habe.
 
Zuletzt bearbeitet:
OP
M

Marius86

Member
Beiträge
22
Punkte Reaktionen
2
Also stimmt meine Zeichnung oben bis auf die Masse an M1+/M0-. Das hat mich schon gewundert, dann würde das auch die Reihenschaltung aufheben ;)

Vielen Dank!
 
OP
M

Marius86

Member
Beiträge
22
Punkte Reaktionen
2
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo!

Ich grabe das Thema mal aus. Es geht immernoch um die gleiche Konstellation.
Heute wollte ich das ganze mal testen. Leider bleibt die Analoge Baugruppe dauerhaft in Störung (rote SF Leuchte ist an).
Vermutlich ist die Karte inzwischen schon futsch.
Was mich wundert, ist das am Eingang der Analogen Karte 24V anliegen. Der Sensor ist auf 4-20mA Ausgabe Signal eingestellt. Allerdings gibt er bei ausgeschaltetem Laser, trotzdem maximales Signal durch. Die angesprochenen 24V stoeren mich. Denn wenn ich es richtig gerechnet habe, dürften am Analogen Eingang der Karte maximal ~0,5V anliegen.
Muss ich also einen Vorwiderstand wählen, so dass bei der Karte maximal 0,5V anliegen bei voll durchgeschaltetem Signal?
Ich bin davon Ausgegangen, dass ich den Sensor direkt auf die Karte hängen darf, wenn beide auf 4-20mA eingestellt sind. Das ist also nicht so? :rolleyes:

Edit: Hat sich erledigt. Nochmal alles eingestellt&verdahtet, dann ging's.

Grüße,
Marius
 
Zuletzt bearbeitet:
Oben