[Siemens] gewollt oder ...?

Mobi

Well-known member
Beiträge
1.368
Punkte Reaktionen
135
Zuviel Werbung?
->Hier kostenlos registrieren
Guten Morgen,

also ich hab mal in Step7 TIA Portal ein bisschen "rumgespielt". Und da ist mir aufgefallen, dass man bei den Variablen-Namen sogar Sonderzeichen verwenden kann. An sich eine gute Sache, aber dennoch dürfte es nicht möglich sein. Wie bei anderen Programmen auch. Aber wenn man sie verwendet, werden sie noch nicht mal richtig verarbeitet (siehe Anhang). Ich hab mal als Name "%#&$" genommen. Dann wird aber im Programm "%#$" angezeigt, wobei dannoch das Dollarzeichen einen Strich unter sich hat.
Also scheint es mir, dass Siemens vergessen hat Sonderzeichen zu verbieten.
 

Anhänge

  • Unbenannt.JPG
    Unbenannt.JPG
    36,9 KB · Aufrufe: 113
  • Unbenannt2.JPG
    Unbenannt2.JPG
    29,9 KB · Aufrufe: 47

M-Ott

Well-known member
Beiträge
1.773
Punkte Reaktionen
374
Sieht so aus. Ich habe es gerade ausprobiert, mit dem "&" kommt er nicht zurecht. Interessanterweise kann man "&&&" nicht direkt als Symbol für eine neue Variable im KOP/FUP/AWL-Editor angeben aber über "Variable umbenennen".
Wenn man auf AWL umstellt, dann sieht man wieder das "richtige" Symbol.
 

Sinix

Well-known member
Beiträge
1.588
Punkte Reaktionen
216
Zuviel Werbung?
->Hier kostenlos registrieren
Hab mal genau das Gleiche bei mir eingetippt, jedoch wurde die Symbolik im Programm exakt gleich angezeigt.
Auch wenn ich die Menmonik auf International wie bei dir umschalte. Liegts wieder an der Basic-Version, die du verwendest?

Gruß MK
 

Sinix

Well-known member
Beiträge
1.588
Punkte Reaktionen
216
Sieht so aus. Ich habe es gerade ausprobiert, mit dem "&" kommt er nicht zurecht. Interessanterweise kann man "&&&" nicht direkt als Symbol für eine neue Variable im KOP/FUP/AWL-Editor angeben aber über "Variable umbenennen".
Wenn man auf AWL umstellt, dann sieht man wieder das "richtige" Symbol.

Aha, das konnte ich auch nachvollziehen, in FUP falsch, in AWL richtig.
Und das Ganze immer nur beim "&"
 

IBFS

Well-known member
Beiträge
4.057
Punkte Reaktionen
886
Ihr habe einfach zu viel Zeit ... trinkt einen Kaffee und dann an die Arbeit ..... frisch auf .... los :ROFLMAO:
 

Perfektionist

Well-known member
Beiträge
3.557
Punkte Reaktionen
518
ob Siemens da "vergessen" hat, etwas zu verbieten, weiß ich nicht. Da allgemein Probleme bei der Verwendung besonderer Zeichen entstehen, hab ich mir selbst auferlegt, nicht alles zu machen, was möglich ist. Aber das ist das Ergebnis von dreissig Jahren Computererfahrung und muss nicht für immer gültig sein und bleiben.
 

spqr76

Well-known member
Beiträge
125
Punkte Reaktionen
4
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo,
ich habe auch den Versuch gestartet das TIA Portal V10.5 oder auch V11 zu nutzen. Allerdings stürzt die Software recht schnell ab.Egal ob man eine neues Projekt anlegt etc... Da ich diesen Effekt auf diversen Siemens Field PG M3 (alle aus unserer Firma) feststellen konnte, muss es ein Problem mit dem von der IT vorgeschriebenen McAffee Virsenscanner geben.Ich kann mir nicht vorstellen das Siemens eine Software auf den eigenen Geräten installiert die nicht funbktioniert . Oder ? So ist es bei mir. Sollte es wirklich daran liegen müssen wir eventuell über eine alternative zu Siemens nachdenken. Da die IT Zuständigen sich meistens in diesen belangen bei uns in der Firma durch setzen. Auch bei der migration von älteren Projekten wurde nicht an Diagnosefähigkeit wie Proagent gedacht. Bin mal gespannt wie das weiter geht. Die momentan für mich sinnvollste Lösung scheinen PC_Runtime Systeme zu sein. Ich teste gern neue Sachen , aber sie sollten auch im 7 tage 24std Betrieb sicher funktionieren....An den meisten Anlagen hat man doch eh die grössten Probleme durch Perepherie da muss mein OS schon sauber laufen...;)
 

bits'bytes

Well-known member
Beiträge
347
Punkte Reaktionen
53
Aha, das konnte ich auch nachvollziehen, in FUP falsch, in AWL richtig.
Und das Ganze immer nur beim "&"

Hat vielleicht damit einen Zusammenhang dass man in der Hochsprachen-Programmierung einen Menüeintrag wie z.B. "File" (mit <Alt>F als Tastenkürzel) als "&File" in der Ressource angegeben hat. Windows hat das dann als "File" angezeigt....
 
Oben