Sinamics S120, ProfiSafe, Einstellen der F_Dest_Add

elifendt

Well-known member
Beiträge
94
Punkte Reaktionen
2
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo,

Ich arbeite mit folgenden Komponenten: CPU317F, CU320, Double-Motor-Module, Smart-Line-Module. Damit Profisafe über Ethernet funktioniert, muss man wie im Funktionshandbuch Safety Integrated die F_Dest_Add im Starter gleich einstellen wie in der Hardware-Konfiguration. Ich verwende für diese Zahl immer die jeweilige Antriebsobjekt-Nummer. Wenn ich eine zweite Achse dazu bekomme und diese an Profisafe anhänge, funktioniert als F_Dest_Add nur eine fortlaufende Zahl eins größer der Zahl der ersten Achse. Beispiel: Achse 1 - F_Dest_Add = 3, Achse 2 - F_Dest_ADD = 4; Wenn ich für die 2. Achse zum Beispiel die 2 einstelle als F_Dest_Add so kommt die Fehlermeldung: 1900: PB/PN: Konfigurationstelegramm fehlerhaft (501).
Jetzt meine Frage:
Gibt es irgendwo eine Beschreibung wie die F_Dest_Add zu vergeben sind? Hatte schon mal jemand damit Probleme? Im Safety-Funktionshandbuch steht nur drin: "Der Wert kann beliebig innerhalb des Bereichs liegen, muss aber in der Safety-Projektierung des Antreibs im SINMAICS-Antriebsgerät nochmals manuell eingetragen werden. "

Grüße
eli
 
OP
E

elifendt

Well-known member
Beiträge
94
Punkte Reaktionen
2
Zuviel Werbung?
->Hier kostenlos registrieren
Das ProfiSafe funktioniert schon! Das heißt, die Konfiguration ist richtig (in HW-Konfig und Starter ist ein Safe-Teil vorhanden). Allerdings muss ich für die F_Dest_Add der 2. Achse eine Zahl eingeben eins kleiner wie die der F_Dest_Add der 1. Achse, damit es funktoiniert. Mich würd es interessieren welche genauen Vorgaben es für die F_Dest_Add gibt!
 

Sinix

Well-known member
Beiträge
1.588
Punkte Reaktionen
216
Das die Adresse für die 2.Achse schon vergeben ist schon geprüft?


Jetzt meine Frage:
Gibt es irgendwo eine Beschreibung wie die F_Dest_Add zu vergeben sind? Hatte schon mal jemand damit Probleme? Im Safety-Funktionshandbuch steht nur drin: "Der Wert kann beliebig innerhalb des Bereichs liegen, muss aber in der Safety-Projektierung des Antreibs im SINMAICS-Antriebsgerät nochmals manuell eingetragen werden. "

Grüße
eli

In meiner Beschreibung steht noch:
"Ausnahme: Der Wertebereich wird von der GSD-Datei vorgegeben und ist für die PROFIsafe-Adressvergabe nicht auf 1 bis 1022 beschränkt."
 
OP
E

elifendt

Well-known member
Beiträge
94
Punkte Reaktionen
2
Danke für deine Hilfe!

Die Adresse für die 2. Achse ist noch nicht vergeben. Wird überhaupt noch bei anderen Teilnehmer die F_Dest_Add vergeben?

Nochmal zum Beispiel:
F_Dest_Add 1.Achse = 3
F_Dest_Add 2.Achse = 4
--> Alles funktioniert wunderbar

F_Dest_Add 1.Achse = 3
F_Dest_Add 2.Achse = 2
--> Fehlermeldung: "1900: PB/PN: Konfigurationstelegramm fehlerhaft (501)"
Was soviel heißt wie "PROFIsafe Parameter fehlerhaft (z.B. F_Dest)."

Was ist somit in Zukunft einzustellen, damit alles sicher beim ersten mal funktoiniert?
 
Oben