TP270 Download Probleme über Profibus

plc_tippser

Well-known member
Beiträge
2.500
Punkte Reaktionen
301
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo Leute,

heute quäle ich mich mit o.g. Gerät. Ich habe das TP an (unter anderem) einem Power PG mittels MPI/PB-Kabel zum Download angeschlossen.
Manchmal habe ich auch schon Projektstände runterspielen können. Aber die meiste Zeit gehts nicht.

Das TP hat die Adr. 10, das PG 5. Wenn ich mir in der Schnittstellen Konfig. die Teilnehmer am Netz zeigen lasse, sind beide da.

Das TP ist ohne Häckchen "Einziger Master" die CP5611 mit.

Was ist hier nur los :?:
 

Ralle

Supermoderator
Teammitglied
Beiträge
14.410
Punkte Reaktionen
3.378
Unter Transfersettings in Settings des TP270 hast du aber den Channel 2 auf MPI
und Häkchen an 'Enable Channel' und 'Remote Control' ?

Gruß Ralle !
 
OP
P

plc_tippser

Well-known member
Beiträge
2.500
Punkte Reaktionen
301
Zuviel Werbung?
->Hier kostenlos registrieren
Ja ist angehackt.

Bei MPI-Transfer funktioniert es jetzt, wenn ich das Häckchen "Einziger Master" aktiviere.

Bei PB Eigenschaften wird das Häckchen immer wieder automatisch gelöscht, sobald die RT einmal wieder lief.
 

Ralle

Supermoderator
Teammitglied
Beiträge
14.410
Punkte Reaktionen
3.378
Ist aber eigentlich nicht Sinn der Sache, ich hab zwei Maschinen mit jeweils einem TP270 (also 4 Teilnehmer) am MPI-Netz und bei mit ist nur das PG (5.Teilnehmer) der 'einzige Master am Bus'. Mit dieser Konfiguration geht der Transfer auf jedes TP problemlos wobei beide Maschinen und beide OP in einem einzigen Projekt stecken.

Ich habe also weder bei Protool unter 'Steuerungen' noch auf dem TP im Systemmenü das TP als Master angegeben, sondern nur das PG unter 'PG/PC-Schnittstelle einstellen' im Simatic-Manager.

Gruß Ralle!
 
OP
P

plc_tippser

Well-known member
Beiträge
2.500
Punkte Reaktionen
301
So soll es ja auch sein. Wobei, hast du nur die TPs am Netz? Keine Master CPUs? Wenn CPUs vorhanden sind, darf auch das PG nicht einziger Master sein, da sonst das PG ohne Rücksicht auf den restlichen Datenverkehr einfach losbrüllt :lol:

Ich werde mich gleich noch mal intensiv mit dem Transfer per MPI beschäftigen. Aber bisher wars halt nur mit einziger Master im TP. Aber ich habe derzeit auch keine CPU angeschlossen. Werde ich wohl auch mal ändern.

Gruß pt
 

Ralle

Supermoderator
Teammitglied
Beiträge
14.410
Punkte Reaktionen
3.378
Zuviel Werbung?
->Hier kostenlos registrieren
Ne, CPU sind nicht 'einziger Master am Bus'.
Das kann man auch nur in Protool/Steuerungen einstellen (nicht in der Hardwarekonfiguration der CPU), wenn man die CPU mit dem entsprechenden OP vernetzt.
Master ist definitiv überall aus, außer an meinem PG und der MPI Bus läuft auch ohne PG !

Gruß Ralle !
 
OP
P

plc_tippser

Well-known member
Beiträge
2.500
Punkte Reaktionen
301
Ne, CPU sind nicht 'einziger Master am Bus'.

Stimmt. Sie sind der Master am Bus. Du fügst ja auch ein Mastersystem ein. Einzigster Master brauchst Du nur, wenn keine Master CPU vorhanden ist. Unter einem anderen Topic von Marcus haben wir schon die entsprechenden Hilfetexte und Beschreibungen von Siemens gepostet.

Aber, wir lassen uns ja immer neu belehren.

Bisher habe ich nun alle Möglichkeiten ohne CPU getestet.

Ich kann bisher nur übertragen, wenn dem OP einzigster Master angehängt wird. Profibus sowie auch MPI.
Nun kommt die Aktion mit CPU

Bis denn, pt
 
OP
P

plc_tippser

Well-known member
Beiträge
2.500
Punkte Reaktionen
301
Zuviel Werbung?
->Hier kostenlos registrieren
So,
TP usw. läuft.

Meine endgültigen Einstellungen für den Download über PB mit einer CPU:

- PG "Nicht einzigster Master am Bus"
- TP "Nicht einzigster Master am Bus"

Und alles wird gut :D

pt
 
Oben