Step 7 Umrichter wechsel - Hardware Anpassung in Simatic S7

Freeesh12

New member
Beiträge
4
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo,
zu Beginn erstmals die relevanten Daten:

- Steuerung : Siemens CPU 315er
- Ansteuerung : Profibus
- Defektes Gerät : Lenze Umrichter der Reihe 8200
- Neues Gerät : Lenze Umrichter 8400 Stateline C

Versuche seit einigen Tagen die Ansteuerung zum Umrichter herzustellen dies funktioniert aber nur bedingt,
ich konnte eine Profibus Verbindung zum Umrichter herstellen (bedeutet er hängt im Profibus Netz der Steuerung und die Verbindung steht soweit) zudem
erhalte ich vom Umrichter auch dessen Statusbit´s. Nun das Problem : Der Umrichter empfängt meine Steuerbits nicht... Laut Fa. Lenze liegt das nicht am Umrichter sondern an der "Steuerung".
Liegt mein Fehler schon in der HW Konfig??
Hardware ALT 1.PNG Hardware ALT 2.PNG Hardware NEU 1.PNG Hardware NEU 2.PNG
 

rlw

Well-known member
Beiträge
321
Punkte Reaktionen
104
hallo,
bei den siemens umrichtern muss ich im datentelegramm (Steuerwort 1) "führung durch PLC" angeben.
hat der lenze das nicht?
 

rlw

Well-known member
Beiträge
321
Punkte Reaktionen
104
Wenn die SFC 14/15 laufen , dann fehlt nur dass du dem umrichter sagen musst "hör auf die Profibussignale"
Also schau in's Steuerwort 1 welches Bit gesetzt sein muss damit die Ansteuerung funktioniert.
Bei mir wird Bit 10 im Steuerwort gesetzt.
 

Ralle

Supermoderator
Teammitglied
Beiträge
14.951
Punkte Reaktionen
3.705
Ist das wirklich korrekt, das der selbe Record am Empfangs- und am Sendebaustein anliegt?
 
OP
F

Freeesh12

New member
Beiträge
4
Punkte Reaktionen
0
Jetzt müsste es passen mit den SFC´s. Danke für die Hilfe. Werde jetzt mal versuchen dem Umrichter Bit´s zu senden und ob dieser sie empfängt.
 

Anhänge

  • Programm 1.PNG
    Programm 1.PNG
    19,5 KB · Aufrufe: 21
Zuletzt bearbeitet:

rlw

Well-known member
Beiträge
321
Punkte Reaktionen
104
ich würde zwischen den e/a bereichen im db, wenn du den gleichen db für e und a verwendest,
einige Bytes einschieben, damit du im falle einer telegrammerweiterung reserve hast.
ich hab da mindestens 20byte reserve vorgesehen
 
Zuletzt bearbeitet:
Oben