WinCC Flex Wincc flexible Advanced fragen

sirpsy

Member
Beiträge
14
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Guten Morgen ☕

leider bin ich nicht so erfahren mit WinCC flexible und benötige Hilfe 😅

Hier erstmal die Vorgeschichte.
Zur Zeit darf ich mich mit alten Maschinen auseinandersetzten.. soll heißen, dass wir uns eine alt Maschine aus einem Tochterwerk gekauft haben.
Dazu habe ich die aktuellen Programmstände etc. bekommen.

Einmal die Hardware:
VIPA CPU 315SB (2AG12) -> Angelegt im Simatic Manager als Siemens CPU 318-2
TP177B(TP 177B 6" mono DP)

Nun sollte etwas im Programm und HMI angepasst werden.
Also Simatic Manager aufgemacht -> Programm dearchiviert -> Rechtsklick auf Bausteine -> Bausteine Vergleichen... -> Suppi ^_^ Viper sagt nach 30 Tagen Tschüß Programm..
Also die erste Baustelle.. waren zwei Wochen meines Lebens, jetzt ist alles gut.

Nun zum Schlimmen teil.. da das HMI etwas cooler war zu mir, hat es natürlich das Programm behalten.. war auch echt Hilfreich.
Nun muss ich aber das was ich Programmiert habe, dabei leider auch Fehlermeldungen, natürlich auch aufs HMI bekommen.

Und hier fangen meine Fragen an.
1 Frage: Als ich das Programm über den Simatic Manager aufgemacht habe, konnte ich leider nie ein HMI Projekt sehen, dieses musste ich immer über WinCC Öffnen, ist das richtig so? Ich meine mich zu erinnern, dass ich vor zwei Jahren schonmal so ein altes Projekt hatte und dort konnte ich das HMI im Projekt sehen, kann mich aber auch irren 😅

2 Frage: Wenn ich das mit WinCC öffne, und bearbeite, würde ich das Projekt auch gerne Archivieren, leider bekomme ich das nicht hin.
Ich geh auf: Projekt -> Archivieren -> Quelle -> Und nun kann ich im "Verlauf" das Projekt sehen, aber nicht anwählen und unter "Integriert", kann ich es auch nicht anwählen..

3 Frage: WinCC Projekt Übertragen: Ich nimm mir mein "Siemens PC Adapter Anschluss PG/PC" wähle die Schnittstelle im Simatic Manager aus ( diese geht auch, sonst hätte ich ja kein PLC Projekt übertragen können ) und gehe dann auf "Transfer" stell das Panel auf Transfer, gib das Passwort dafür ein, wähle MPI/DP aus und die Stationsadresse aus den WinCC Projekt -> Rücktransfer aktivieren -> Transferien -> dann versucht er immer die Verbindung aufzubauen und bricht diese wieder ab.

Ich habe mit zwei verschiedenen Siemens PC Adapter Anschluss PG/PC es versucht. Hab mir ein "ADAPTER MPI-ETH ADAPTER ACCON-NETLINK-PRO COMPACT" besorgt und damit nochmal getestet. Kein Erfolg. Ich weiß leider nicht mehr weiter. Weiß jemand was ich noch testen könnte?
 
OP
S

sirpsy

Member
Beiträge
14
Punkte Reaktionen
0
okay, ich werde das jetzt nicht mehr verfolgen.
Ich werde das Wincc Projekt verwerfen.
Das Panel ist so alt, dass ich kein guten Ersatz finde.
Ich werde jetzt das WinCC Projekt hochziehen in Tia v14 und das HMI gerät tauschen -> KTP700

Falls jemand wissen will wie.
WinCC Öffnen -> HMI Gerät tauschen auf KTP 600 -> Tia v14 Projekt migrieren -> Gerät tauschen auf KTP700 Basic.

Ansonsten vielen Danke an die Leser und Helfer.
 

JesperMP

Well-known member
Beiträge
7.017
Punkte Reaktionen
1.415
Zuviel Werbung?
->Hier kostenlos registrieren
1. Ein WinCC Flexible HMI kann entweder in ein Simatic Manager Projekt integriert sein, oder es kann nicht-integriert sein.
Wenn du die HMI nur öffnen kann wenn du WinCC Flexible startet und davon das HMI Projekt öffnet, dann ist die HMI nicht-integriert.
Mann kann ein nicht-integrierte HMI in ein Simatic Manager Projekt integrieren. Es gibt ein Funktion dafür in WinCC Flexible.
edit: Wurde ich aber nicht zuerst machen.

2. Bin nicht sicher was hier schief geht.

3. Auf die TP177B, was sind die Einstellungen unter Control Panel .. Transfer ?
Was sind die Transfer Einstellungen in WinCC Flexible (nicht die unter PG/PC Schnittstelle) ?
Wenn du Rücktransfer aktivieren wählst muss es eine Flashkarte in der OP sein. Gibt es dies ? Sonnst Rücktransfer abwählen und probieren.
 
OP
S

sirpsy

Member
Beiträge
14
Punkte Reaktionen
0
1. Ein WinCC Flexible HMI kann entweder in ein Simatic Manager Projekt integriert sein, oder es kann nicht-integriert sein.
Wenn du die HMI nur öffnen kann wenn du WinCC Flexible startet und davon das HMI Projekt öffnet, dann ist die HMI nicht-integriert.
Mann kann ein nicht-integrierte HMI in ein Simatic Manager Projekt integrieren. Es gibt ein Funktion dafür in WinCC Flexible.
edit: Wurde ich aber nicht zuerst machen.

2. Bin nicht sicher was hier schief geht.

3. Auf die TP177B, was sind die Einstellungen unter Control Panel .. Transfer ?
Was sind die Transfer Einstellungen in WinCC Flexible (nicht die unter PG/PC Schnittstelle) ?
Wenn du Rücktransfer aktivieren wählst muss es eine Flashkarte in der OP sein. Gibt es dies ? Sonnst Rücktransfer abwählen und probieren.
Frage zum 1 Punkt. Kann ich das WinCC Projekt auf Tia v14 hochrüsten? Und wenn ja, wie bekomme ich dann die Verbindung mit dem Simatic Manager? Oder gibt es diese dann schon?

Zu Punkt 3: Genau, dass Panel ist auf Transfer.
Die Transfereinstellungen sind MPI/DPI auf Stationsadresse 2. Stationsadresse habe ich bei der "Verbindung" rausgelesen.
Gut zu wissen, vielen Dank ! Das werde ich gleich nochmal ohne Rücktransfer versuchen.
 

JesperMP

Well-known member
Beiträge
7.017
Punkte Reaktionen
1.415
1. Kann man, aber ist nicht einfach.
Und dann muss das Panel getauscht werden. TP177B mono DP geht nur mit WinCC Flexible.
Und die Verbindung mit das Simatic Manager Projekt wäre denn über die 'Proxy PLC' in TIA.
Kurzgesagt, dies ist für geübte.

3. Was sind die Transfer Einstellungen in WinCC Flexible ?
Ist die MPI Busgeschwindigkeit gleich, im STEP7 Projekt für die '318' CPU, in das WinCC Flexible Projekt, auf die TP177 ?
 
OP
S

sirpsy

Member
Beiträge
14
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
1. Kann man, aber ist nicht einfach.
Und dann muss das Panel getauscht werden. TP177B mono DP geht nur mit WinCC Flexible.
Und die Verbindung mit das Simatic Manager Projekt wäre denn über die 'Proxy PLC' in TIA.
Kurzgesagt, dies ist für geübte.

3. Was sind die Transfer Einstellungen in WinCC Flexible ?
Ist die MPI Busgeschwindigkeit gleich, im STEP7 Projekt für die '318' CPU, in das WinCC Flexible Projekt, auf die TP177 ?
Erstmal riesen Dank an dich JesperMP ! Du nimmst dir viel Zeit danke !
Zu 1. Da wir keine TP177B mehr nutzen wollen, muss ich jetzt das Projekt in Tiav14 laufen lassen und die Proxy PLC rein bringen, leider weiß ich noch nicht genau wie, aber ich hoffe das Siemens da eine gute Anleitung für hat 😆

Zu 3. Ich bin mir nicht sicher wo ich die MPI Busgeschwindigkeit finde, aber in den MPI Parameter im Simatic Manager steht 187,5 kbits
Beim Transfer in WinCC finde ich leider nix.
 

JesperMP

Well-known member
Beiträge
7.017
Punkte Reaktionen
1.415
1. https://cache.industry.siemens.com/.../77430539_wincc_migrationguide_DOC_V30_en.pdf

3. Und das gewählte Schnittstelle in der '318' CPU, was ist die Busgeschwindigkeit dort ?
Ich kenne VIPA nicht, aber die kombinierte MPI/DP Schnittstellen in 318 und TP177B können andere Busgeschwindigkeiten als 187.5k.
Die Transfereinstellungen sind MPI/DPI auf Stationsadresse 2. Stationsadresse habe ich bei der "Verbindung" rausgelesen.
Es gibt bei in der Verbindungsdialog in WinCC Flexible 2 Stationsaddressen. Den von der HMI und den von der PLC.
Stationsaddresse "2" ist typisch für die PLC verwendet. Deswegen vermute ich das "2" ist falsch.
Bitte den gesammte MPI Netzwerk checken. Auf der TP177B muss du die Stationsadresse und Busparameter durch das Windows Control Panel checken.
 

winnman

Well-known member
Beiträge
1.909
Punkte Reaktionen
279
Und ev. auch mal die Adresse des PG ändern und noch mal suchen nicht das das TP zufällig die selbe Adresse wie das PG hat.
 
OP
S

sirpsy

Member
Beiträge
14
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
1. https://cache.industry.siemens.com/.../77430539_wincc_migrationguide_DOC_V30_en.pdf

3. Und das gewählte Schnittstelle in der '318' CPU, was ist die Busgeschwindigkeit dort ?
Ich kenne VIPA nicht, aber die kombinierte MPI/DP Schnittstellen in 318 und TP177B können andere Busgeschwindigkeiten als 187.5k.

Es gibt bei in der Verbindungsdialog in WinCC Flexible 2 Stationsaddressen. Den von der HMI und den von der PLC.
Stationsaddresse "2" ist typisch für die PLC verwendet. Deswegen vermute ich das "2" ist falsch.
Bitte den gesammte MPI Netzwerk checken. Auf der TP177B muss du die Stationsadresse und Busparameter durch das Windows Control Panel checken.
Zu 1. Vielen Dank ! :)


Zu 3. Im Windows Control steht auch Stationsadresse 2

Und ev. auch mal die Adresse des PG ändern und noch mal suchen nicht das das TP zufällig die selbe Adresse wie das PG hat.
Du meinst wenn ich die Schnittstelle Einstelle? Werde ich mal testen. Danke !
 

JesperMP

Well-known member
Beiträge
7.017
Punkte Reaktionen
1.415
Also, es gibt die 3 Teilnehmer.
PG
TP177
VIPA CPU (~318)

Welche Stationsadressen haben sie in das Simatic Manger Projekt, und tatsächlich eingestellt auf die Geräte ?
Das hier sind die typische MPI Stationsadressen
PG = 0
HMI = 1
PLC CPU = 2

Dass du den HMI = 2 gewählt hat ist nicht problematisch wenn du nur die andere Adressen auch dementsprechend gewählt hast.
 
OP
S

sirpsy

Member
Beiträge
14
Punkte Reaktionen
0
Es gibt insgesamt 13 Teilnehmer.
Ich habe alle Adressen geprüft. Ich habe auch mit ein Profibusmessgerät den Bus gemessen.
Ich bin da schon auf der richtigen Adresse (glaube ich). Nichts destotrotz ihr kennt es. Mein Chef möchte das ich weiter komme.
Also tausch ich jetzt das HMI gerät.

Derzeit arbeite ich gerade dran, dass KTP700 Basic DP mit der PLC Proxy zu verheiraten.
Das hat auch schon ganz gut geklappt. Nur die HMI-Meldungen ärgern mich etwas.
Da dass Programm teilweise DWord benutzt, und dass KTP diese leider nicht auflösen kann.
Und auch viel auf Boolische Merker geschrieben, die mir leider auch in der Triggervariable alle Rot angezeigt werden o_O

SPS Forum.jpg
 

JesperMP

Well-known member
Beiträge
7.017
Punkte Reaktionen
1.415
Zuviel Werbung?
->Hier kostenlos registrieren
So langsahm werde ich wahnsinnig.
Das es 13 Teilnemher in das MPI Netzwerk gibts konntest du ja in ersten Beitrag erwähnt haben.
Auch wenn du die TP177 austaucht musst du ja den gesammten MPI Netzwerk dokumentieren.
Du sagst du hast alles geprüft, aber einfache Fragen willst du nicht beantworten.
Ich hoffe du hast Erfolg. Ich bin aus.
 
OP
S

sirpsy

Member
Beiträge
14
Punkte Reaktionen
0
Entschuldige bitte, hast du Recht ! Habe ich tatsächlich vergessen. im MPI Netz gibt es nur die CPU, HMI und dann mich mit dem PG.
PG = 0
CPU = 2
HMI = 2
Das wird dann wohl der Fehler sein?

Ich möchte schon deine Fragen beantworten.
ich könnt dir jetzt kurz meine Situation erklären, ist aber auch nur viel mimimi..


SPS2.jpg SPS3.jpg





Falls du raus sein solltest, trotzdem danke für deine Hilfe !



Mein Problem mit dem DWord im KTP700 ist leider noch aktuell
In der HMI Variablen Liste ist aber alles gut..

SPS Forum.jpg

sps4.jpg
 
OP
S

sirpsy

Member
Beiträge
14
Punkte Reaktionen
0
Lösung gefunden:
Dword müssen als analogmeldung angelegt werden.

HMI Verbindung mit PLC klappt.

Thema kann geschlossen werden.
 
Oben