Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Wago 750-881 mit SQL-Datenbank verbinden

  1. #1
    Registriert seit
    03.02.2013
    Ort
    Baden-Württemberg
    Beiträge
    46
    Danke
    8
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich bin momentan dabei, meine Wago 750-881 mit einer SQL-Datenbank zu verbinden.
    Für den ersten Versuch habe ich mich an folgendes Video gehalten:
    http://www.youtube.com/watch?v=0isTiU06bbA

    Soweit hab ich alles fertig, das einige Problem ist jetzt dass ich die Fehlermeldung
    *Fehler 3740: (23): Unbekannter Typ 'SHA1Context'* bekomme und deshalb das Projekt nicht übertragen kann.
    Habe gerade schon ne ganze Weile auf Google gesucht, aber nichts gefunden, woher das kommt, bzw, wie der Fehler behoben werden kann.
    Vielleicht hat von euch jemand ne Idee.

    Danke im Voraus.

    Gruß
    doemy
    Zitieren Zitieren Wago 750-881 mit SQL-Datenbank verbinden  

  2. #2
    Registriert seit
    03.02.2013
    Ort
    Baden-Württemberg
    Beiträge
    46
    Danke
    8
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hat sich soeben erledigt, habe vergessen, die zusätzlich benötigte Bibliothek einzubinden.
    Sie heißt *WagoLibSHA1.lib*, falls es nochmals jemandem so geht.

    Gruß
    doemy

  3. #3
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.751
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    Dir fehlt eine Datentypdefinition, welche in einem deiner verwendeten Bausteine benötigt wird.
    Wahrscheinlich fehlt dir also die hier: http://www.wago.com/wagoweb/document...0/a302000d.htm
    genannte "WagoLibSHA1".

    Edit: ...zu langsam...

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  4. #4
    Registriert seit
    03.02.2013
    Ort
    Baden-Württemberg
    Beiträge
    46
    Danke
    8
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo Manuel,

    vielen Dank für deine Antwort.

    Die Übertragung hat wie gesagt jetzt funktioniert, dafür habe ich jetzt ein anderes Problem:
    Wenn ich die Wago mit der Datenbank verbinden will, kommen mehrfach hintereinander folgende Fehlermeldungen in der aufgeführten Reihenfolge:
    *Waiting for "OK Packet" from server*
    *"Handshake Initialisation Packet" recieved - Generate "Scramble-Key"*
    *Connection established - Waiting for "Handshake Initialisation Packet" from server*
    *Try to connect to 192.168.178.35*
    *Try to connect with 192.168.178.35*
    *CONNECTED WITH DATABASE - "WagoDB"*

    Nach einigen Durchläufen kommt dann die Meldung *DISCONNECTED*.

    Also müsste die Kommunikation zwischen den beiden Geräten (Mein SQL-Server läuft auf einer Synology Diskstation SD212+, IP-Adresse der Station ist die oben aufgeführte 192.168.178.35) funktionieren. Nur scheint die Verbindung immer wieder abzubrechen.

    Vielleicht hast du, oder auch gerne jeder andere, ja eine Ahnung woher das kommen könnte oder was ich falsch gemacht habe.

    Danke und Gruß
    doemy

  5. #5
    Registriert seit
    16.06.2014
    Beiträge
    13
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Moin,

    habe leider das gleiche Problem, wie der Ersteller in seinem letzten Beitrag erläutert hat. Schade, dass keine Antwort mehr existiert. Gibt es hierfür möglicherweise bekannte Probleme?

  6. #6
    Registriert seit
    26.01.2010
    Beiträge
    51
    Danke
    1
    Erhielt 13 Danke für 12 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Es gibt eine Alternative, die tadellos funktioniert. Mit SQL4automation kann man mit WAGO Steuerungen direkt auf SQL Datenbanken zugreifen. Auf Seite Steuerung kann eine fertige Bibliothek eingebunden werden. Doku, Bibliothek und Domeverion kann hier heruntergeladen werden.

Ähnliche Themen

  1. WAGO 750-881 mit Oscat Bibliotheken füttern
    Von Ampel03 im Forum CODESYS und IEC61131
    Antworten: 5
    Letzter Beitrag: 15.02.2012, 12:22
  2. Sonos mit Wago 750-881 ansteuerbar?
    Von c.anhalter im Forum CODESYS und IEC61131
    Antworten: 5
    Letzter Beitrag: 11.02.2012, 22:17
  3. Wago 750-881 und SQL
    Von bytebold im Forum CODESYS und IEC61131
    Antworten: 5
    Letzter Beitrag: 30.10.2011, 15:04
  4. Suche WAGO 750-841, 750-871 oder 750-881
    Von Controllfreak im Forum Suche - Biete
    Antworten: 1
    Letzter Beitrag: 05.10.2011, 11:19
  5. SQL Datenbank mit einer SPS verbinden
    Von Sandy im Forum Sonstige Steuerungen
    Antworten: 7
    Letzter Beitrag: 11.02.2008, 11:53

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •