Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 19 von 19

Thema: Wago 750-841 als TCP / IP ModBus Slave betreiben

  1. #11
    Registriert seit
    04.01.2006
    Beiträge
    80
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Na dann ist doch alles ganz easy . ich nehme an du hast einen PC, der auf alle deine WAGO Steuerungen zugreift. Da wird vermutlcih auch die Software , von der
    wir immer noch nicht wissen was da läuft, laufen.

    Dann sehe ich es so: vergib wie MSB schon schrieb jeder WAGO eine IP Adresse ( aber bitte immer eine andere, keine IP darf doppelt erscheinen, wegen Adresskonflikten).

    Vielleicht ist ja der Zustand auch schon so, dass jede Wago eine IP Adresse hat. Wenn dem so ist, dann hast du dein MAster SLAVE Prinzip verwirklicht. Dein PC mit der Software ist der MASTER
    und deine vielen Wagos sind die Knechte sprich "SLAVES".

    Was willst du mehr. Wenn du z.B. auf dem PC als Software "PROFILAB 4.0" von der Firma Abacom laufen hättest, könntest du jeden SLAVE über das MODBUS / TCP protokoll mit der jeweiligen
    IP Adresse ansprechen und entsprechende INfo über die Register holen oder schreiben, wie auch immer. Die Unterscheidung der SLAVES erfolgt einfach ueber die IP Adresse, denn jeder Controller
    hat eine andere. Du jetzt verstehen ??????

  2. #12
    Horschd ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.06.2011
    Beiträge
    29
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    danke,

    ich hatte inzwischen auch rausgefunden das man den Slaves keine ID zuteilen braucht, sondern das über die IP läuft.

    meine Software ist zurzeit noch das einfache codesys. Die (andere Projektgruppe) wollen das später mit SciLab auslesen.

    jetzt muss ich nurnoch mit der dämlichen Leistungmessklemme einig werden, die wil ihre messdaten noch nicht rausrücken.

  3. #13
    Registriert seit
    04.01.2006
    Beiträge
    80
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi Horschd,

    na da wird ja einiges klarer. Mit codesys lässt sich doch gut arbeiten, da kannst du deine Wago Controller schön programmieren.
    Zum Visualisieren kann man dann alles nehmen, was die Wago Controller bzw. ihr Innenleben ansprechen kann.
    Von SCILAb hab ich zwar mal gehört, aber da ist sicher einiges an Programmierarbeit von Nöten...was ich so auf den ersten Blick sehe.
    Keine Ahnung, ob da MODBUS / TCP integriert ist. NAja...wünsche dir gutes Gelingen !!

  4. #14
    Registriert seit
    14.07.2015
    Ort
    NRW
    Beiträge
    64
    Danke
    10
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo zusammen,

    ich versuche gerade mit visual.net eine Modbus Verbindung herzustellen, zwecks Visualisierung . Als Kontroller habe ich den 750-880 und als BS Win7. Das Problem hängt zurzeit an einer DLL-Datei. Ich habe schon Nmodbus ausprobiert, leider vergebens. Hier habe ich Probleme gehabt das Programm zu debuggen. Als zweites habe ich easymodbus ausprobiert. Hier war das debuggen kein Problem und das lesen aus der Wago hat auch geklappt, aber das Schreiben leider nicht.

    Habt ihr Erfahrungen mit anderen DLL-Dateien die gut laufen oder eine andere alternative?

    Grüße
    Ben

  5. #15
    Registriert seit
    25.02.2010
    Beiträge
    618
    Danke
    35
    Erhielt 121 Danke für 110 Beiträge

    Standard

    Hi.
    Ich habe mit der originalen API Modbus/TCP DLL von Wago bisher keine Probleme gehabt. Bestell Nr. 759-312.
    Grüße Holger

  6. #16
    Registriert seit
    14.07.2015
    Ort
    NRW
    Beiträge
    64
    Danke
    10
    Erhielt 1 Danke für 1 Beitrag

    Standard

    das klingt gut. Mit welchem Betriebssystem benutzt du das denn?

  7. #17
    Registriert seit
    25.02.2010
    Beiträge
    618
    Danke
    35
    Erhielt 121 Danke für 110 Beiträge

    Standard

    Ich habe mir was mit VB.net gebastelt. Läuft unter Win mit Framework 3.5. (32bit)
    Grüsse Holger

  8. #18
    Registriert seit
    14.07.2015
    Ort
    NRW
    Beiträge
    64
    Danke
    10
    Erhielt 1 Danke für 1 Beitrag

    Standard

    danke für die Antwort.
    Ist die im Lieferumfang von den Starterkits enthalten oder kann man die beim Support bekommen?

  9. #19
    Registriert seit
    14.07.2015
    Ort
    NRW
    Beiträge
    64
    Danke
    10
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ich habe etwas gefunden für visual.net (klappt in c# in vb). Das ganze ist eine eigene Modbus Library und nennt sich NModbus4 hier der Link: https://www.nuget.org/packages/NModbus4/

Ähnliche Themen

  1. Antworten: 16
    Letzter Beitrag: 08.03.2014, 20:42
  2. WAGO 750-841 langsamer als 750-842 ?
    Von rene77 im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 09.03.2012, 14:35
  3. Wago 750-304 mit 750-841 betreiben!
    Von Lekta im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 06.02.2012, 20:42
  4. Wago 750-841 und Modbus???
    Von McNugget im Forum CODESYS und IEC61131
    Antworten: 11
    Letzter Beitrag: 07.10.2009, 22:04
  5. Antworten: 2
    Letzter Beitrag: 21.07.2006, 07:10

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •