Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 21 bis 30 von 34

Thema: Lichtmessung für Rolladen-Beschattung mit WAGO 750-881

  1. #21
    Registriert seit
    30.07.2013
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Wu Fu,

    danke für die Info. Wago-Wetterstation bedeutet aber auch die von Fa. Elsner nur als Wago-Version,
    oder? Habe noch nie eine Wetterstation von WAGO gesehen...

    Viele Grüße.

  2. #22
    Registriert seit
    26.01.2013
    Ort
    Hannover
    Beiträge
    100
    Danke
    3
    Erhielt 15 Danke für 10 Beiträge

    Standard

    Also die Wetterstation sendet alle 1,3 Sekunden einen String mit 40 Byte Länge. Wenn du beim Einlesen TimeOut-Probleme hast, liegt das wohl eher an den Prozessen, die nebenher laufen, z.B. die Web-Visu.
    Ich hatte den Eltako-Sensor zunächst an einer KL6041 betrieben, jetzt versuchsweise seit einiger Zeit an einer RS232 mit billigem Umsetzer RS232 - RS485 und es funktioniert ohne Aussetzer. Auch wenn ich mal einen Datensatz nicht erhalten sollte, wäre das doch völlig egal. Oder was für Schwankungen in den Wetterdaten erwartest du innerhalb von 1,3 Sekunden (oder bei einem Datensatzverlust innerhalb 2,6 Sekunden)?

  3. #23
    Registriert seit
    20.11.2011
    Ort
    Niederbayern
    Beiträge
    15
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo zusammen,

    da mich das Thema auch interessiert klinke ich mich mal ein. Ich bin auch gerade daran, eine Beschattung zu realisieren. Leider dauert das bei mir etwas länger da ich kaum Programmierkenntnisse hab.
    Ich hab mir die Elsner Wetterstation bestellt und will die Daten in Kombination mit dem Funktionsblock CalcSunPosition aus TwinCat BuildingAutomation lösen.
    Ich habe die Schattenposition beobachtet und dadurch Beschattungssegmente für Ost und Südseite des Hauses erhalten. Mit Temperatur und Helligkeit kombiniert will ich dann die Rollos in eine definierte ShadowPosition fahren.
    Die Wetterstation soll über die RS485 N031 am Controller laufen.
    Hat das schon mal jemand mit TwinCat gemacht? Soweit ich gelesen habe muss ich extra eine Bibliothek kaufen um die am Controller vorhandene RS485 zu nutzen! Kann das sein?
    Auf Oscat will ich nicht ausweichen, da wie gesagt meine Programmierkenntnisse (alles selbst erspäht) so schlecht sind dass ich Wochen brauche um alles neu zu programmieren. Einzelne Bibliotheken kann ich auch nicht einbinden, da es da anscheinend zu überschneidungen kommt.
    Läuft der WagoBaustein auch auf dem Beckhoff Contoller CX9001.

    Vielleicht hat irgendjemand Beispiele oder noch Ideen, welche Vorgehensweise sich als praktisch erwiesen hat.

    Danke

    Markus

  4. #24
    Registriert seit
    30.07.2013
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von NieZuSpaet Beitrag anzeigen
    Also die Wetterstation sendet alle 1,3 Sekunden einen String mit 40 Byte Länge. Wenn du beim Einlesen TimeOut-Probleme hast, liegt das wohl eher an den Prozessen, die nebenher laufen, z.B. die Web-Visu.
    Ich hatte den Eltako-Sensor zunächst an einer KL6041 betrieben, jetzt versuchsweise seit einiger Zeit an einer RS232 mit billigem Umsetzer RS232 - RS485 und es funktioniert ohne Aussetzer. Auch wenn ich mal einen Datensatz nicht erhalten sollte, wäre das doch völlig egal. Oder was für Schwankungen in den Wetterdaten erwartest du innerhalb von 1,3 Sekunden (oder bei einem Datensatzverlust innerhalb 2,6 Sekunden)?
    Hallo NieZuSpaet,
    danke, dass du dich nochmal gemeldet hast! In einem Datensatzverlust oder späterer Meldung sehe ich auch gar kein Problem. Wichtig wäre ja nur (und das hast du ja bestätigt), dass es überhaupt läuft und auch stabil. Also nicht das sich z.B. die Schnittstelle auf Grund einer zu hohen Datenrate seitens des Sensors aufhängt oder so..
    Ich denke, ich werde es nun mit dem Multisensor und der WAGO-Steuerung wagen...werde mich nach erfolgtem Einbau bei euch zurück melden!

    Viele Grüße und einen schönen sonnigen Sonntag!
    Babyface.

  5. #25
    Registriert seit
    30.07.2013
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Markus,

    warum hast du die ELSNER-Station genommen und nicht den Multisensor?
    Leider kann ich dir zu der Software-Seite noch nichts sagen..bei mir wird es auch noch ein wenige dauern.
    Ich stecke noch in der "Hardware" eines kompletten EFH..
    Viel Erfolg und schönen Gruß..

    Babyface

  6. #26
    Registriert seit
    24.10.2010
    Beiträge
    239
    Danke
    56
    Erhielt 28 Danke für 22 Beiträge

    Standard

    danke für die Info. Wago-Wetterstation bedeutet aber auch die von Fa. Elsner nur als Wago-Version,
    oder? Habe noch nie eine Wetterstation von WAGO gesehen...
    Ich meine natürlich das Wago-Modell von Elsner mit den 3Sekunden. Da hab ich mich etwas unglücklich ausgedrückt.

  7. #27
    Registriert seit
    20.11.2011
    Ort
    Niederbayern
    Beiträge
    15
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Babyface,

    ich kannte nur die Elsner, also hab ich die genommen. Bin ja mal gespannt, aber irgendwie hab ich alles so einigermassen, wenn auch umständlich, zum laufen gebracht.
    Über die Hardware bin ich gottseidank längst raus (ausser die Wetterstation). Ich habe aber dafür auf meinem Mast der Satschüssel, den ich extra länger gelassen habe, eine Leitung gelegt.
    Ach ja, da du gerade bei der Hardware bist ... für Rollos hab ich erst triacs verwendet und mit den Rohrmotoren Probleme bekommen, hab sie dann gegen kl2622 getauscht!!! (nur zur info)
    Irgendwo im Forum hab ich aber das schon genauer erläutert!!!

    Grüsse Markus

  8. #28
    Registriert seit
    26.02.2014
    Ort
    Bodensee
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich häng mich hier mal mit ran, da ich gerade total auf dem Schlauch steh. Ich habe eine Wago SPS 750-881 mit RS485 Modul zur Steuerung meiner Rollläden und Jalousien. Als Windwächter habe ich den Multisensor von Eltako, allerdings ist die mitgelieferte Beschreibung etwas dürftig. Wie muss ich die grüne Klemme mit der Bezeichnung 1, 2, A und B mit der Spannungsversorgung beschalten? Und wo muss ich mein serielles Kabel am Multisensor anschließen?

  9. #29
    Registriert seit
    26.02.2014
    Ort
    Bodensee
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Dürfte sich erledigt haben, im Elsner Datenblatt habe ich es gefunden.
    1: +24V
    2: GND
    A und B: Seriell

  10. #30
    Registriert seit
    27.11.2009
    Ort
    BW - Ecke Ulm
    Beiträge
    438
    Danke
    135
    Erhielt 36 Danke für 33 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin,

    nachdem das Thema sowieso noch einmal aufgewärmt wurde ...
    Spricht die Elsner RS485 Wetterstation (und ihre Brüder, Eltako, Wago-Version) eigentlich nur oder empfängt die auch was von der Steuerung?
    Die Frage kommt mir wenn ich die Pin-Belegung oben sehe.
    RS 485 gibt es ja in 2-Draht und in 4-Draht. Wird hier weil (ich gehe davon aus) nur vom Dach in die Steuerung gesendet wird nur die RX-Seite an der Wago/Beckhoff Steuerung angeklemmt und TX (SPS -> Sensor) bleibt offen?

    Ich habe heute aus dem Fenster lehnend meine Schwiegerleuten zu Raffstoren geraten und gemurmelt, da kommt dann eben noch schnell ein Windsensor an die Steuerung und gut. Jetzt bin ich in der Bringsschuld bzw. muss was passendes suchen.

    An sich würden mir auch die Ausgänge vom (Eltako) MSR12-UC auf Digital-In reichen. Will die Werte nicht weiter auswerten / anzeigen.
    Andererseits weiß man nie, was in xx Jahren kommt. Nur scheue ich etwas den Preis einer RS485-Klemme bei Beckhoff "nur" für bisschen Windalarm.

    Danke im Voraus für Hinweise / Erfahrungsberichte
    --
    ohm200x

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 22.01.2013, 21:46
  2. OPC-Server für Wago 750-881
    Von mortus im Forum WAGO
    Antworten: 12
    Letzter Beitrag: 03.09.2012, 07:07
  3. Datenaustausch Siemens S1200 mit Wago 750-881
    Von p2492 im Forum CODESYS und IEC61131
    Antworten: 4
    Letzter Beitrag: 05.05.2012, 22:34
  4. Sonos mit Wago 750-881 ansteuerbar?
    Von c.anhalter im Forum CODESYS und IEC61131
    Antworten: 5
    Letzter Beitrag: 11.02.2012, 22:17
  5. Suche WAGO 750-841, 750-871 oder 750-881
    Von Controllfreak im Forum Suche - Biete
    Antworten: 1
    Letzter Beitrag: 05.10.2011, 11:19

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •